Thread Tools
Mar 20, 2017, 11:39 AM
Registered User
man i miss the power of the red motors, these black motors are slugs compared to the red, how are the silvers ?? I am sure it has something to do with AH, has anyone done any mods other than 9450's, i looked for a set of red motors but no luck. Has any one been able to disconnect the AH ? did it make any difference, the way it is now it wont hardly pull itself out of a bind its like the motors are being held back...Roost
Sign up now
to remove ads between posts
Apr 24, 2017, 02:06 PM
Venture, ZMR250, X8, X11, CX10
Phrancis's Avatar
I'm considering buying the GPS AH version of this, but I strongly prefer flying in mode4 with the aileron/throttle on the left stick and rudder/elevator on the right. The whole thing looks like a clone of the Syma X8 right down to the TX and I know all syma quads can switch from control modes 2 and 4 by holding down a trim button and turning it on. Syma calls it mode1 and 2, but does anyone know if this can do mode4 as described above? Thanks.
Apr 29, 2017, 08:10 PM
FB Group: We Fly RC's
eghershey's Avatar
OK. After reading the 10 pages on the X16 and really enjoying the X8's (I've had three), I ordered the X16 today. Hope I get a good one. Reviews seem to be iffy about the assembly quality and out of the box flyability. I also looked at the parts for the X16 and it looks like the esc's are set p with a regular 3 wire link to a receiver. If so, has anyone substituted the X16's receiver for a different (perhaps Spektrum) receiver? That would be so neat if possible.
May 19, 2017, 01:34 AM
Registered User

issues with new x16


Hello i am new here. Ordered x16 gps version unpacked it but there is a issue with it. i am not able to fly. and i think i cannot even pair it with the transmitter.
drone is blinking fast (strobe) for one second then 1sec. pause and again.
more info
May 17, 2017 (1 min 16 sec)
.i tried to open it to check for cutted wires soldering issues etc. but found nothing
could you let me know if this is the normal blinking? i need to know if there is issue with transmitter or issue with the drone board receiver

thank you
Last edited by sid.dagivers; May 19, 2017 at 07:12 AM. Reason: wrong video link
May 19, 2017, 11:08 AM
FB Group: We Fly RC's
eghershey's Avatar
Re-read the instructions, as encrypted as they may be. I don't have the GPS model but to start motors, you have to move the joysticks to the bottom and out. That should start the motors. Down and in stops them.
May 20, 2017, 07:30 AM
Registered User
Quote:
Originally Posted by eghershey
Re-read the instructions, as encrypted as they may be. I don't have the GPS model but to start motors, you have to move the joysticks to the bottom and out. That should start the motors. Down and in stops them.
Already did that. I think priblem is pairing with transmitter. Leds on drone are blinking diferently than on youtube videos. I am not paired to the transmitter
May 20, 2017, 07:32 AM
Registered User
Already did. Priblem is pairing drone to the transmitter. Led blinking is different than on x16 youtube videos
Yesterday, 12:19 PM
FB Group: We Fly RC's
eghershey's Avatar
Darn, try this. Turn radio on first then power up the quad and go thru the process. No work? then Turn quad on first and then turn on radio. Wish I could come up with better help.