Thread Tools
Jan 24, 2020, 11:43 AM
Registered User
Quote:
Originally Posted by westphill24
I tried to flash my 5 inch quad today with HGLRC Opto 30a esc's and one of them started to stutter when checking throttle in configurator. I lowered throttle and raised it slightly again and I get nothing. I felt the motor and esc. Motor was slightly warm and the esc was hot. Not burn your hand hot but hot like I was flying hard for a while. The other 3 are fine. Anyone else have this happen? Anyway to check the esc besides desoldering and bench testing?

I used F_H_40_48_REV16_77 since it already had F-H-40 on the esc.
Any help?

I connected to the configurator again and esc4 (the one with the issue) shows up so I flashed again. still nothing. I removed the esc and motor and will test on the bench later. I really hope I didnt burn up the motor and esc. I just dont understand how only 1 esc/motor would have the issue. For some reference I didnt smell/see any smoke from the either. Any info on what the beeps mean from the esc? I do get different beeps before and after I throttle up in the motors tab. I already ordered a replacement esc just in case but Id like to get any input I can before I try to flash another esc and have the same issue.

Again. The motor stuttered at first then nothing. ESC got hot enough to shrink the shrink wrap on it. (I never shrank it after building but there where no exposed connections.)Other 3 motors and esc seem to work fine and although there where no errors on dshot 600 at 8k 2k I dropped the settings to dshot 300 4k4k using an F7 board.

Thanks for any assistance.
Sign up now
to remove ads between posts
Jan 24, 2020, 03:22 PM
Registered User
Quote:
Originally Posted by westphill24
Any help?

I connected to the configurator again and esc4 (the one with the issue) shows up so I flashed again. still nothing. I removed the esc and motor and will test on the bench later. I really hope I didnt burn up the motor and esc. I just dont understand how only 1 esc/motor would have the issue. For some reference I didnt smell/see any smoke from the either. Any info on what the beeps mean from the esc? I do get different beeps before and after I throttle up in the motors tab. I already ordered a replacement esc just in case but Id like to get any input I can before I try to flash another esc and have the same issue.

Again. The motor stuttered at first then nothing. ESC got hot enough to shrink the shrink wrap on it. (I never shrank it after building but there where no exposed connections.)Other 3 motors and esc seem to work fine and although there where no errors on dshot 600 at 8k 2k I dropped the settings to dshot 300 4k4k using an F7 board.

Thanks for any assistance.
Seems like that esc or the motor has died. It’s often surprising to me how fragile escs are. Any short between motor pads will immediately fry an esc.

You have to go about this by narrowing down the potential problem sources. Flash 16.7 and see if the issue still exists. If yes switch two motors and see if the problem is esc or motor bound. Then you’ll need to exchange the faulty component.

Any initial tests (esp with unreleased fw) should always be performed with a current limiting device. Esp these days with 4:1 s it’s just not worth the risk of frying something.
Jan 24, 2020, 04:39 PM
Registered User
Thanks Joe. I already ordered a new esc since the only place to get it is banggood china. Hopefully its not the motor but several US sellers have that. Its just weird it worked fine before until I flashed it. I didnt think to put on stock firmware, Ill try it.

Ive never used a smoke stopper because Ive never had an issue. But..... I see its useful for that one time something happens. If it was a short wouldnt it take out other components?

Anyway you confirmed my thought process for the next steps so Ill see how it goes.
Jan 24, 2020, 10:59 PM
DOLLA DOLLA BILL YALL
quad007's Avatar
any 48khz version stable for L_H_00 yet?

I only see L_H_5...
Last edited by quad007; Jan 24, 2020 at 11:07 PM.
Jan 25, 2020, 04:10 AM
Registered User
Quote:
Originally Posted by JazzMac
16.78 is reserved for some topics/improvements we still are working on. We will release 16.79 from a RC version and together with a release note next Monday.

Always open source and free.
Curious about the state of current development . Tried the 16.78i beta4 uploaded yesterday, only to find it had some issues with motor reversing, so flashed back 16.77 without problems.
Last edited by Markus Gritsch; Jan 25, 2020 at 07:26 AM.
Jan 25, 2020, 10:20 PM
Geek 4 3V3R
Robomaniac's Avatar
I can confirm on mobula6 using emuflight and 0603 motors (no rpm filtering)

O_H_5_48_REV16_77.HEX = jerking motion while flying (not flyable)
O_H_5_24_REV16_77.HEX = fly good but lose 20-30sec flight time!!

I now fly blheli 16.7 with very good performance.

There is no point to flash these if you don't use rpm filtering. It's just someone mention that on FB and didn't really cost me much to give it a try.

my favorite whoop is betaflight with rpmfiltering.
Jan 26, 2020, 04:53 AM
Registered User
Quote:
Originally Posted by Markus Gritsch
Curious about the state of current development . Tried the 16.78i beta4 uploaded yesterday, only to find it had some issues with motor reversing, so flashed back 16.77 without problems.
Many thanks for your tests. We try to make a stable RC for 16.79. Two issues should be fixed.
1. Higher startup throttle.
2. Fix delta-sigma logic.

One improvement
3. Commutation waveforms will be more complete.

Will fix dshot command issue(motor reverse) in beta5.

BLS does shorter open loop startup when doing 3D direction change. I can make some options for you to test. Need your experience to pick a optimal set of tunnings. Not sure can do the suggestion by Alka. Will try but I need to finish esc rpm stabilizer first.
Last edited by JazzMac; Jan 26, 2020 at 05:40 AM.
Jan 26, 2020, 05:10 AM
Registered User
Looking forward to it.
Jan 26, 2020, 06:34 AM
Registered User
tried
S_H_50_48_REV16_77.HEX
on a crazybee f4 pro running 0802 31mm props and unflyable. no amount of tuning would even get it off the ground. Back to 16.7 and flys fine.
Jan 26, 2020, 10:06 AM
Registered User
Hey Jazz,

first of all: thx for your really great work
Today I tried the "C_H_25_24_REV16_77.HEX" on my 5'' kwad with MATEKF722SE and 4x Diatone 302XD with Betaflight 4.1.6, RPM-filter and 4K/4K.

It flies really great. ESCs and motors donīt get warm, even with new betaflight-filter-sliders all to right side (Joshua Bardwell) settings.

But after arming and motors spinning at idle, the motor-rpm changes fast (pulses). I don't see vibratons or so, but I can hear it clear. When I give a little bit of throttle, than the pulsation goes away and everything works perfect.

I recognized this pulsation just after flashing 16.77, even with my previous filter settings and before I activated the RPM-filter.

Greetings from Germany.
Nem.
Jan 26, 2020, 10:42 AM
Registered User
Quote:
Originally Posted by Nemesis01
Hey Jazz,

first of all: thx for your really great work
Today I tried the "C_H_25_24_REV16_77.HEX" on my 5'' kwad with MATEKF722SE and 4x Diatone 302XD with Betaflight 4.1.6, RPM-filter and 4K/4K.

It flies really great. ESCs and motors donīt get warm, even with new betaflight-filter-sliders all to right side (Joshua Bardwell) settings.

But after arming and motors spinning at idle, the motor-rpm changes fast (pulses). I don't see vibratons or so, but I can hear it clear. When I give a little bit of throttle, than the pulsation goes away and everything works perfect.

I recognized this pulsation just after flashing 16.77, even with my previous filter settings and before I activated the RPM-filter.

Greetings from Germany.
Nem.
Hi Nem,
Many thanks for your tests. I am not sure about your issue. But if startup related, I didn't fix it until 16.78_ibeta4. But I only make 48khz versions since it is in beta stage. should be less efficiency for your 5" motors. You can try if still this abnormal rpm at low throttle. Sometimes PID needs to be changed due to different throttle to thrust curve by different firmware.

16.77 24khz do pwm alignment(3 times) compares to 16.7. Should has more power compares to 16.7.

16.78a12 does more pwm alignment(6 times) and has delta sigma algorithm to complete full 11bit throttle DAC.

I will suggest also 16.78a12 which has been tested by many people.
Last edited by JazzMac; Jan 26, 2020 at 10:48 AM.
Jan 26, 2020, 12:24 PM
Registered User
@JazzMac
Thank you for your development. I wonder can you explain what 'a' and 'e' means in your branch. I want to move to the latest version to try 48khz, but I am confused about which version I should choose. Thanks.
Jan 26, 2020, 12:34 PM
Registered User
etracer's Avatar
Quote:
Originally Posted by Nemesis01
Hey Jazz,

first of all: thx for your really great work
Today I tried the "C_H_25_24_REV16_77.HEX" on my 5'' kwad with MATEKF722SE and 4x Diatone 302XD with Betaflight 4.1.6, RPM-filter and 4K/4K.

It flies really great. ESCs and motors donīt get warm, even with new betaflight-filter-sliders all to right side (Joshua Bardwell) settings.

But after arming and motors spinning at idle, the motor-rpm changes fast (pulses). I don't see vibratons or so, but I can hear it clear. When I give a little bit of throttle, than the pulsation goes away and everything works perfect.

I recognized this pulsation just after flashing 16.77, even with my previous filter settings and before I activated the RPM-filter.

Greetings from Germany.
Nem.
Test in the motors tab in Betaflight (NO PROPS!). If the motors are smooth there then your problem is simply that you're reduced the filtering too much and noise is getting through the PID controller when armed.
Jan 26, 2020, 02:10 PM
Registered User
Quote:
Originally Posted by dukevah
@JazzMac
Thank you for your development. I wonder can you explain what 'a' and 'e' means in your branch. I want to move to the latest version to try 48khz, but I am confused about which version I should choose. Thanks.
Blheli_s 16.77 has pwm 48khz. The next release will be 16.79.

I think 16.78_i beta4 is the RC version for 16.79. There is a known issue in dshot command decode.

Please skip other 16.78 sub versions. I will make a release note for 16.79.

A simple list of new features in 16.79:
1. Full pwm alignment
2. 11bit throttle DAC using pwm+delta-sigma
3. Support L type ESC
4. Raise startup throttle
5. Better commutation efficiency

From Ethan's report, BL32 has bettet efficiency. Still trying to find differences. I think we can push open-source bls further.
Last edited by JazzMac; Jan 26, 2020 at 10:34 PM.
Jan 26, 2020, 03:19 PM
Registered User
Quote:
Originally Posted by JazzMac
Blheli_s 16.77 has pwm 48khz. The next release will be 16.79.

I think 16.78_i beta4 is the RC version for 16.79. There is a known issue in dshot command decode.

Please skip other 16.78 sub versions. I will make a release note for 16.79.

A simple list of new features in 16.79:
1. Full pwm alignment
2. 11bit throttle DAC using delta-sigma
3. Support L type ESC
4. Raise startup throttle
5. Better commutation efficiency

Thank you so much.


Quick Reply
Message:

Thread Tools