Thread Tools
Mar 28, 2016, 12:11 PM
Sil
Sil
Registered User
Thread OP
Help!

Binding a Taranis Plus with a frsky XSR receiver.


Hi.
I cannot bing my Taranis PLus with my frsky XSR receiver (wich is labeled X4RS_REV1.1 on the pcb).

The Taranis is loaded with the firmware "opentx-taranisplus-en-2.1.7.bin".

I connected the XSR receiver to the Taranis usinf the smart port to install a nonEU firmware "XSR_nonEU_build151118.frk". The installation was succesfully achieved.

The TX mode is set to D16

I set the Taranis menu ti [bind]. I power the RX while pushing the button. The 2 LED on the RX are lit but nothing else happen.

I also tried to install the firmware "opentx-taranisplus-eu-en-2.1.7.bin" on the taranis and the "XSR_LBT_build151118.frk" firmware on the RX. Same result.

Any idea of what could go wrong?
Sign up now
to remove ads between posts
Mar 31, 2016, 04:11 PM
Registered User
I have exactly the same issue.

I'm programming the XSR using a usb adaptor with a 74LS04 logic inverter on the tx & rx.

I load the firmware connect the XSR it says its fount the receiver, then I press download. The green led flickers quickly. The red led pulses about every 5 seconds. the led on my usb flickers quickly. eventually the bar gets to 100% and says programming is complete and the green led on the receiver starts flashing about once per second.

I then disconnect everything, go into bind on the Taranis power up the receiver whilst holding F/S. Red & green leds turn on solid but thats it nothing else happens.

Ive tried both XSR_nonEU_build151118.frk and XSR_LBT_build151118.frk just in case FrSky got the file names muddled up.
Anyone have any suggestions?
Apr 01, 2016, 07:15 AM
Registered User
Has anyone found a solution yet? I'm having the same problem. If I power it up without pressing the bind button. The red light flickers. Power it with it pressed and both red and green leds are solid. It's stressing me out! Binding is never easy with frsky :/
Apr 01, 2016, 08:28 AM
Sil
Sil
Registered User
Thread OP
Actually I found a solution. Attached are the firmwares for Taranis internal module and XSR receiver

1/ you must be sure of the TARANIS TX internal module firmware :
  • D16 old cannot bind with XSR receiver : Mode_non-EU
  • D16nonLBT: Mode-EU
  • D16LBT:: Mode-EULBT

Copy the the firmware into the Taranis \FIRMWARE directory and install it from the radio to flash the internal module:
  • Press menu 2sec
  • page button once
  • Go to firmware, select the chosen one and press 'ent'
  • select flash internal module (see attached snapshot)


2./ using the Taranis itself or a USB adapter flash the XSR receiver with a matching firmware:
  • XSR_LBT_build151118
  • XSR_nonEU_build151118

Here is a video tutorial to flash RX using the Taranis. Be acarfull not to have a 3S lipo, the Taranis will power the RX using the internal batterie and fry anything that do not support the voltage.
How to flash X8R, X6R or Taranis internal module using OpenTx 2.1 (8 min 48 sec)
Apr 01, 2016, 11:47 AM
Registered User
Thanks for the info Sil

So from what you are saying the Taranis firmware needs to be a certain revision or newer to support the XSR and that my firmware needs updating to either LBT or non-LBT.

Any ideas what the first Taranis firmware revision is that supports the XSR and how I find out what version I have installed on my TX?
Apr 02, 2016, 11:18 AM
Sil
Sil
Registered User
Thread OP
Actually it is related to the TX module inside the taranis, not the Taranis it self. it is not related to openTX or whatever.

I attached all the firmware I used in the previous post.
Last edited by Sil; Apr 02, 2016 at 11:24 AM.
Apr 04, 2016, 04:04 PM
Registered User
Hi Sil

So is there only one working combination?:

D16LBT:: Mode-EULBT on the transmitter
with
XSR_LBT_build151118 on the receiver

the only other combination (which I assume wouldnt work as its EU TX with non-eu RX) appears to be :
D16nonLBT: Mode-EU
with
XSR_nonEU_build151118

I would upgrade to the EU LBT but that the website says it doesn't work with the D8 mode which is what my D4R-II receivers use.
Apr 07, 2016, 04:36 AM
Sil
Sil
Registered User
Thread OP
Hi,
Actually I assumed the D8 mode would not be affected. but I might be wrong.
There are 2 combinaition working as you mentionned. The following is working also.
D16nonLBT: Mode-EU
with
XSR_nonEU_build151118

The problem would be to save your original firmware for backup before updating just in case.
Apr 11, 2016, 03:51 AM
Registered User
Not sure which firmware I actually ended up with but I now have the D4R-II and the XSR both working.

I did reinstall the Taranis 2.1.7 firmware without the EU box checked.
Jun 01, 2016, 08:23 AM
Registered User
AndyKay's Avatar
Thanks so much for this Sil! I had literally tried every firmware available that I could find, even random members emailing me their versions. Only your EU-LBT one worked
Jun 08, 2016, 05:24 AM
Simon
Asomaro's Avatar
I recently bought an XSR rx and I spent friggin hours trying to sort out why it would not bind despite all the right eu firmware revisions. then I found this thread - a huge thanks to Sil for this resolution
Jun 08, 2016, 08:44 AM
Registered User
mpjf01's Avatar
Quote:
Originally Posted by Sil
Actually I found a solution. Attached are the firmwares for Taranis internal module and XSR receiver

1/ you must be sure of the TARANIS TX internal module firmware :
  • D16 old cannot bind with XSR receiver : Mode_non-EU
  • D16nonLBT: Mode-EU
  • D16LBT:: Mode-EULBT
Are you sure about the first point? I have a very early model Taranis (mid 2013 I think) with its original XJT firmware and it binds in D16 mode with my two XSR receivers with no issue.
Jun 10, 2016, 08:47 AM
Sil
Sil
Registered User
Thread OP
I might be wrong, since it is really hard to know the firmware version of the Taranis TX module I did not know what firmware was originaly installed on mine. I assumed it was the old one since it was not binding.

Off course I would suggest to try binding the RX before updating anything.
Jun 13, 2016, 02:22 AM
Registered User
I can confirm that flashing internal module with:
Mode_non-eu.frk

And XSR with:
XSR_nonEU_build151118.frk

WILL WORK ALSO WITH old (d4r) receivers!
Oct 13, 2016, 05:58 AM
Registered User
Hi,

Does anyone know if you can brick the taranis if you flash a different firmware (internal radio) ..ie eulbt, on non eu and non lbt ...or does it just up/downgrade the transmitter ?

Thanks !


Quick Reply
Message:

Thread Tools