Thread Tools
Jun 15, 2016, 04:03 AM
Registered User
I had it wired to the 5 volt output (measured 4.95 V) from my VTX but after a few minutes the images would degrade until i had only horizontal B&W lines on my screen. The VTX got really hot too so i guess my VTX can't deliver the needed current or the 4.95 volt is a notch too low. I now connect it to the 2S battery and all is good (except for the missing "park lines" in my setup menu lol).
Sign up now
to remove ads between posts
Jun 15, 2016, 06:43 AM
Registered User
FloBau's Avatar
Which Vtx do you use?

I'm planning to use a Fatshark 250mW with it, which would also deliver 5V to the camera.
Jun 15, 2016, 07:38 AM
Registered User
The VTX i used for testing was a HK Quanum Elite X40-2
Jun 15, 2016, 09:37 AM
Registered User
Quote:
Originally Posted by RunCam
Please screw tight the back cover or add a foam inside.
Really? That's the kind of answer I would expect from a no-name $10 camera company. One shouldn't have to expect to fix something brand new. Knowingly selling something broken at full price shows how much you care about the hobby. I've spent days trying to tune out a problem I didn't have only to realize it's the camera. No thanks. I'll take my business elsewhere. The "other" original camera is just as good.
Jun 15, 2016, 12:04 PM
Delicous salad addition
Quote:
Originally Posted by Alias_Hendrik
I had it wired to the 5 volt output (measured 4.95 V) from my VTX but after a few minutes the images would degrade until i had only horizontal B&W lines on my screen. The VTX got really hot too so i guess my VTX can't deliver the needed current or the 4.95 volt is a notch too low. I now connect it to the 2S battery and all is good (except for the missing "park lines" in my setup menu lol).
I took mine out the other day for the first time. Worked fairly well although this was my first time on this camera. Video quality seemed about the same as when I powered my old one with a small 3s battery. I did, however, get a "lost signal" error for the first time. Only lasted a second or two but sure hope that doesn't keep up.
Jun 16, 2016, 01:00 AM
Born for RC Fanatics
Thread OP
Quote:
Originally Posted by sna08
Really? That's the kind of answer I would expect from a no-name $10 camera company. One shouldn't have to expect to fix something brand new. Knowingly selling something broken at full price shows how much you care about the hobby. I've spent days trying to tune out a problem I didn't have only to realize it's the camera. No thanks. I'll take my business elsewhere. The "other" original camera is just as good.
If the problem persists, please contact [email protected] for replacement.
Jun 16, 2016, 05:13 PM
Registered User

blank screen


I have two swifts. Both have, after minor crashes, a blank screen. They are still outputting the osd. Anyone have similar problems or any idea how to fix it? I've taken them apart and I can't see any damage.
Jun 17, 2016, 01:11 AM
Born for RC Fanatics
Thread OP
Quote:
Originally Posted by neanic
I have two swifts. Both have, after minor crashes, a blank screen. They are still outputting the osd. Anyone have similar problems or any idea how to fix it? I've taken them apart and I can't see any damage.
Please contact [email protected] with a video to show the problem.
Jun 17, 2016, 03:34 AM
Registered User
Hmerly's Avatar
Got a new Swift and the board inside is shaking. When I fly I get very bad vibrations. Also, I cannot access menu to change settings. My osd cable is good as it works on other camera, but on the new Swift I cannot bring up the menu. Any ideas?
Latest blog entry: My fixed wings
Jun 19, 2016, 11:53 AM
RCFPVFlight addict
daneelgiskard's Avatar
Hi guys!

In this video I compare the image quality of the RunCam Swift and the RunCam Owl Plus in various settings: Bright daylight, dusk & night. I show side by side videos of the different settings and give you my comments - plenty of additional raw footage as well, so that you can form your own opinion.

RunCam Swift & RunCam Owl Plus at Day, Dusk & Night: Video Quality Comparison (9 min 44 sec)


Please subscribe to support my review & DIY videos: https://www.youtube.com/RCFPVFlight?sub_confirmation=1

Many thanks and all the best,
Michael
Jun 19, 2016, 10:39 PM
Cajun Flyer
Anyone have setting they like to share?
Jun 20, 2016, 12:54 AM
aka RCFlyer85
Irock1985's Avatar
Are spare cables available? Main plug
Jun 21, 2016, 03:04 AM
Born for RC Fanatics
Thread OP
Quote:
Originally Posted by Irock1985
Are spare cables available? Main plug
All the accessories for Swift
http://shop.runcam.com/for-swift/
Jun 21, 2016, 10:43 AM
aka RCFlyer85
Irock1985's Avatar
Quote:
Originally Posted by RunCam
All the accessories for Swift
http://shop.runcam.com/for-swift/
Ok thank you I ordered a spare wire harness... Will it ship from the USA?
Jun 21, 2016, 09:47 PM
Born for RC Fanatics
Thread OP
Quote:
Originally Posted by Irock1985
Ok thank you I ordered a spare wire harness... Will it ship from the USA?
From China


Quick Reply
Message:

Thread Tools