Thread Tools
Mar 04, 2016, 05:37 PM
Registered User
Thread OP
Discussion

VtX is recieveing power but no signal to goggles


Anyone experience no connection to my dom v2 goggles but vtx has power?

fuzzy screen switching threw every frequency

switch over to my 200mw mini Vtx from that quantum goggles set last year and it connects instantly just need to change channel to clear one.
my 250 Quad is using immersion RC 600mw VTX

goggles have ImmersionRC Raceband Module (ive tried every combo with the little switches and sill no signal

maybe the vtx is burnt out? just don't get how my 5G8 200mw mini connects too all frequencies just need o find appropriate channel and he 600mw is fuzzy screen no signal regardless.




on attached image seams my vtx is all "on" unlike the picture

https://www.hobbyking.com/hobbyking/s...Hz_Module.html

this is Module in my Dominator v2 ive tried all frequency attempting to connect
Last edited by abiddar; Mar 04, 2016 at 05:43 PM.
Sign up now
to remove ads between posts
Mar 05, 2016, 08:50 AM
Registered User
Thread OP
the one that is working and connecting is my 200mw vtx from his bundle https://www.hobbyking.com/hobbyking/s...mera_PNF_.html


this is my 250 quad with the unresponsive 600mw vtx


the right is partial vtx u can see the red/yellow/back wire go under the pdb and solder to the board and same with camera on left solders onto pdb


Quick Reply
Message:

Thread Tools