Thread Tools
Jan 17, 2016, 09:35 PM
Quadaholic
Thread OP
Discussion

Microminosd and CC3D setup


So I have a few questions for anyone out there that has installed a MicroMinOSD on a CC3D board. I have not found anything on youtube or the web that gives straight forward advice on install. I have done the flashing and programming in Arduino no problem. ALthough I do have a question about setting up cleanflight with CC3D. You can flash CF to it as I understand correct? The issue I have is the actual install of the chip into the CC3D board. I made a quick 2 minute video that might help explain it better.

2016 0117 210106 001 (2 min 15 sec)
Sign up now
to remove ads between posts
Jan 18, 2016, 06:59 AM
Registered User
you need to connect rx to tx and tx to rx , ground and +5v
unfortunately there are some problems with cc3d because it does not have a voltage input like naze to show on telemetry.
If I remember mwosd will work on micro minim osd and put bat1 on osd pins.(if not try the rushosd)
the rest you can find on web .,...
but remember cc3d and micro minim osd not a good ideea. Why? Naze 32 have bat1 input and it will send to minimosd no matter the fw that minim osd have.

hope it helps
Jan 18, 2016, 08:18 AM
Quadaholic
Thread OP
Quote:
Originally Posted by ccatalin
you need to connect rx to tx and tx to rx , ground and +5v
unfortunately there are some problems with cc3d because it does not have a voltage input like naze to show on telemetry.
If I remember mwosd will work on micro minim osd and put bat1 on osd pins.(if not try the rushosd)
the rest you can find on web .,...
but remember cc3d and micro minim osd not a good ideea. Why? Naze 32 have bat1 input and it will send to minimosd no matter the fw that minim osd have.

hope it helps
Yes it does TREMENDOUSLY ty ty ty!
Jan 18, 2016, 12:43 PM
Pro Bro #1008
birdie_in_texas's Avatar
is there an OSD at all that works with CC3D? Or should I change to a NAZE board (if so, which one, it looks like there are a million) on and learn how to deal with them?
Jan 18, 2016, 04:07 PM
Quadaholic
Thread OP
I have found the libre pilot page that deals with minOSD. https://librepilot.atlassian.net/wik...MinOPOSD+setup

Im reading through it all to make sure I get this correct before attempting anything first. From what I gather I flashed my microminosd with the wrong software. The one I used Arduino works with NAZe32. The one I need to flash to it is Arducam OSD. This interface should allow me to configure the main "telemetry port" as the port I wish to use the overlay on my HUD. Since LibrePilot is still new im going to be asking questions as I go on their forums when I get stuck. I will post my results here with the steps I took If I get it going.
Jan 18, 2016, 11:16 PM
Quadaholic
Thread OP
OK Its all hooked up now after a lot of reading I flashed and installed the micro and used Arducam to set it up "much easier tool to use imho". Now its all installed and I just tested it, but get no video. I made a quick 2 min video showing the test install. If anyone can offer help it would be much appreciated thanks.

"UPDATE" I removed the 2 ground pins from the video in/out side and got video, but no overlay. So it is passing video through the microminosd just no overlay hrmmmmm.

20160118 225600 (1 min 51 sec)


I have posted a thread on the Libre Pilot forums here https://forum.librepilot.org/index.p...sg4619#msg4619
Incase anyone would need a reference to anything im doing.
Last edited by Brent S; Jan 19, 2016 at 11:31 AM.
Jan 19, 2016, 02:17 PM
Quadaholic
Thread OP
Im VERY happy to report thanks to the geniousness of the Libre Pilot forums help I NOW HAVE OSD! THANK YA JEEEEEEEEEEEZUS!

https://forum.librepilot.org/index.php?topic=638.0
Dec 27, 2017, 09:01 PM
Hot glue will fix anything!
Uksteve's Avatar
i know this is an old topic but was just wondering, the issue with the video not displaying but then video but no overlay when you disconnected the ground wires........
was that a problem caused by not using the same power source for all the devices, ie cam, video tx and osd? the ground does funny things when they do not share the same battery lol


Quick Reply
Message:

Thread Tools