Thread Tools
Sep 17, 2019, 04:16 PM
Registered User
Thread OP
Version 1.21.0.59:

* Fixed issue with not showing RX telemetry when filtering is turned ON with serial based receivers (SPM4649T and SPM4650);
* For Standard Telemetry if RPM is less than or equal to 999 the RPM value shown as n/a;
* Show RSSI % instead of B level dBm for SPM4650 SRLX2 receiver.

http://www.tlmviewer.com
Sign up now
to remove ads between posts
Sep 18, 2019, 12:57 PM
Registered User
Kambalunga's Avatar
Fligthlog is broken show always N/A for A, B, L, R. Frameloss and Hold works.
RX AR6600T, AR10000 and AR8000.
AR10000 and AR8000 use the TM1000

Occurs when the peak filter or smooth filter is used.
Last edited by Kambalunga; Sep 18, 2019 at 01:05 PM. Reason: Peak and smooth filter
Sep 18, 2019, 01:12 PM
Registered User
Thread OP
Quote:
Originally Posted by Kambalunga
Fligthlog is broken show always N/A for A, B, L, R. Frameloss and Hold works.
RX AR6600T, AR10000 and AR8000.
AR10000 and AR8000 use the TM1000

Occurs when the peak filter or smooth filter is used.
See post above. And it is always great if you add a TLM file.
Sep 18, 2019, 03:55 PM
Registered User
Thread OP
Quote:
Originally Posted by Kambalunga
Fligthlog is broken show always N/A for A, B, L, R. Frameloss and Hold works.
RX AR6600T, AR10000 and AR8000.
AR10000 and AR8000 use the TM1000

Occurs when the peak filter or smooth filter is used.
OK, I found the TLM file that allows me to reproduce the issue. Update will be available soon.
Sep 19, 2019, 03:43 AM
Registered User
Kambalunga's Avatar
Quote:
Originally Posted by btframework
OK, I found the TLM file that allows me to reproduce the issue. Update will be available soon.
TLM files.
Additional TLM file Hobby Wing V4 ESC telemetry for X-BUS.
Last edited by Kambalunga; Sep 19, 2019 at 04:03 AM.
Sep 19, 2019, 01:57 PM
Registered User
Thread OP
Quote:
Originally Posted by Kambalunga
TLM files.
Additional TLM file Hobby Wing V4 ESC telemetry for X-BUS.
Thank you. The issue looks fixed now. The uypdate should be available soon.
Sep 20, 2019, 05:33 PM
Registered User
Thread OP
21.09.2019 (1.22.0.3)
=====================

* Fixed issue with incorrect RSSI channel (A/B) detection for SPM4650 SRLX2 receiver;
* Show RSSI % instead of A loss for Lemon RX;
* Fixed issue with A, B, R, L shown as n/a when Smooth or Peak filtering is selected;
* Enabling and disabling RX telemetry filtering in case of Peak or Smooth filtering is selected (by default it is disabled);
* Smart Battery Telemetry support.

http://www.tlmviewer.com
Sep 25, 2019, 08:28 AM
Custom User Title
Peak filtering makes flat line.
  • Use attached TLM file
  • Apply Peak filtering
  • Mix Data
  • Graph Powerbox Voltage 1 (V)

Using latest version, but this also happened in previous version(s).

Attached graph with Simple Filter (correct.jpg) and Peak Filter (flatline.jpg).
Sep 25, 2019, 08:34 AM
Registered User
Thread OP
It looks like a bug. Thank you. Will try to fix as soon as possible.
Sep 27, 2019, 12:38 PM
Registered User
Thread OP
27.09.2019 (1.22.0.5)
=====================

* Fixed bug in Peak filtering for PowerBox sensor.

http://www.tlmviewer.com
Oct 02, 2019, 02:37 PM
Registered User
Kambalunga's Avatar
Discover a bug. Peakfilter for RPM on ESC and standard telemetry is broken. ESC show always 0 and standard n/a. Smoth filter is okay.
Oct 02, 2019, 02:51 PM
Registered User
Thread OP
Quote:
Originally Posted by Kambalunga
Discover a bug. Peakfilter for RPM on ESC and standard telemetry is broken. ESC show always 0 and standard n/a. Smoth filter is okay.
Actually it is not a bug. Peak filter checks that current value is in range of previous plus some "peak" value. Let say current one is 100. "Peak" set to 50. So if next value is in range 100-149 it appears in log. If nexr value is 150 and above it will be skipped and previous one will be used.

You telemetry recording started before you tuend the receiver. So it is always stores 0. Once yo uturned the receiver TX starts receiving TLM data and gets value as 100 (for example). But "peak" is 50. So 100 > 0 + 50 and value ignored.

Fix start your telemetry recording only when receiver is turned ON. It can be started by throttel position or by switch. Or do not use Peak filters.


Quick Reply
Message:

Thread Tools