Thread Tools
Oct 24, 2015, 10:46 AM
Registered User
Thread OP
Help!

QR X350 Firmware Upgrade Now No Bind???


Hi Folks,
In bother again.
Just done a firmware upgrade on my QR X350. Camera works fine, quad beeps twice then nothing, no second longer beep, and no green lights. I have double checked all the TX settings on my Devo F7, all as per the manual. I ran the upgrade twice to make sure I hadn't made a mistake, and followed a you tube of the procedure just to be certain.
Does anybody have any ideas please.
Cheers Steve
Sign up now
to remove ads between posts
Oct 25, 2015, 10:18 AM
I void warranties
What exact version of Deviation are you running (I'm assuming you're running DeviationTX 4.0.1 unless you're running a nightly build).

Did you do the Devo's rebind steps. If you upgraded the 350QX it would of forgotten the fixed ID so you'll have to totally re-initiate the bind.
Oct 29, 2015, 04:19 PM
Registered User
Thread OP
Hi folks,
Result, on the failed firmware upgrade.
Did a rebind which I admit I had completely overlooked. Still no joy, so then as also suggested to me, re flashed back to original firmware version, 1.1, and now all working okay as was.
Unfortunately G-3 D gimbal still not working, in fact worse, now will not even light up, even with a direct power source. Any ideas would be much appreciated.
Many thanks to all for help so far.
Cheers Steve��


Quick Reply
Message:

Thread Tools