Thread Tools
Jul 15, 2004, 07:05 PM
Registered User

electrifly receiver with 30a esc not working need help


i just bought an electrifly reciever with built in 30a esc. I hooked up new servos and put in the correct crystal and charged the batteries but nothing works not even a servo twitch. I tried older servoes that i know work but still nothing. please help.
Sign up now
to remove ads between posts
Jul 16, 2004, 02:42 AM
It flies? I like it!
Which model receiver? What battery (how many cells/type)? Are you sure the polarity is correct? You do know this receiver uses a "short" crystal that is single conversion (i.e. a regular dual conversion crystal will not work).
Last edited by Lomcevak; Jul 16, 2004 at 02:48 AM.
Jul 16, 2004, 09:00 AM
Registered User
i have the low band with a low band crystal short single conversion. lipo battery 2cell 1500mah. the polarity is correct.
Jul 16, 2004, 11:37 AM
Registered User
buckeyes1997's Avatar
make sure you have the right shift. some receivers work with airtronics/JR and some work with futaba/hitec shifts. i made the mistake of buying the wrong one the other day and couldnt figure out why it didnt do anything when hooked up
;-)
Jul 16, 2004, 04:47 PM
It flies? I like it!
Sounds like it's DOA (or like Buckeyes says, the wrong version). In either case it would appear it's time to send it back.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Honeybee cp2 tail rotor not working need help quick jjwarr Micro Helis 12 Jan 26, 2007 07:05 AM
Help! ESC not working with Futaba Receiver. ovajay Power Systems 10 Oct 07, 2006 08:25 AM
Discussion I.F.O. with Feigao Motor & ESC not working gdbontly Scratchbuilt Indoor and Micro Models 14 Sep 22, 2006 10:47 AM
Rant Heli servos not working... need help! TechyBen Micro Helis 5 Sep 07, 2004 11:33 AM
What's up with "Hot Topics" Not working? slowflyer Electric Plane Talk 1 Sep 08, 2001 09:04 AM