Thread Tools
Jun 12, 2001, 10:43 PM
Registered User

Servo Jitter problems in a Hitec HS 55


I have a Hitec HS55 servo that jitters when I plug it in, appears to not be able to find its centre point. Ths servo still repsonds to control input.
Does anyone know of a way to fix this problem? This is a brand new servo but I have had it for a while now and only just decided to use it.

Thanks,

Stephen
Sign up now
to remove ads between posts
Jun 12, 2001, 11:28 PM
Registered User
I had the same thing happening with ALL of my servos. It turned out that my receiver was bad and was making all of my servos twitch. Is it just one servo twitching or all of them?
Jun 13, 2001, 12:13 AM
Registered User
Just this servo. 3 others are fine. I have tried differnt Tx/Rx combinations.
Jun 13, 2001, 06:15 AM
Registered User
Andy W's Avatar
Does it do it when you plug it into a different channel?
Is your Transmitter turned on?

If Yes to both of the above, send it to Hitec.
..a


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Hitec HS-55 Servo Price Reduction aeropal Radios 4 Jun 01, 2004 02:43 PM
FS: GWS Naro 6Ch Rx with Ch19 X-Tal/ Hitec HS-55 Servo/ GWS Pico Servos-Free Shipping LESLIEx317537 Aircraft - Electric - Airplanes (FS/W) 3 Apr 27, 2004 11:14 PM
Hitec HS-55 Servos, 2 New In Box nspark Aircraft - Electric - Airplanes (FS/W) 2 Dec 19, 2003 05:19 PM
FS: Hitec HS 55 servo Nik-rc Aircraft - Electric - Airplanes (FS/W) 10 Jun 18, 2003 03:49 PM
Hitec HS-55 Servos in an LMH Corona? Mark E Electric Heli Talk 9 Nov 19, 2001 07:12 PM