Thread Tools
Sep 30, 2015, 06:04 PM
Registered User
Thread OP
Help!

Quad Flips on Take Off!


I'm not sure what i'm doing wrong, this is my second quad build, I just moved electronics over to a new frame, but when I increase throttle the quad flips. I have calibrated the escs and the accelerometer. When I try to correct the quad, other motors die out, like there isn't enough power to run all the motors at once. I'm completely stumped
-Naze32
-Hovership 2300kv motors
-Hovership 12 Amp Escs
Sign up now
to remove ads between posts
Sep 30, 2015, 06:48 PM
Team AlienWarpSquad
Re-check all the usaul suspectes.
Fc orrenitation?
ESC plugged into the correct FC pins.
Prop, motors correct?
Do not assume anything is right---check it one step at a time.
Oct 01, 2015, 03:41 AM
Registered User
scottishslayer's Avatar
I'd check for a short somewhere. If you've moved known good electronics over to a new frame then its doubtful that it'd be an issue with calibration or configuration. Double check all the obvious stuff first as waltr said, we've all put a servo lead on backwards at one point or another

Usual suspects may be new motor bolts are too long and contact the windings, or you may have pinched or crushed a wire when assembling the frame.

Good luck
SS
Oct 04, 2015, 12:12 PM
Registered User
Thread OP
Thank you for all the help, I checked the motor mounts and they seem fine. I remember that this was a problem on the other frame, two motors wouldn't spin at low throttle, then I would give it a little roll/pitch until they all were on, worked fine after that.

I changed the pids. The ones I downloaded were for a four cell setup It seems to work better now, but the motors won't lift off at around 80% which is weird because the frame isn't much heavier than the old one. waiting for my 6" props before I test it again, the 5" ones I was using are really beat up.
Oct 04, 2015, 12:53 PM
Registered User
Thread OP
Ok, this is sad. One of the props was on backwards, I've been flying quads for about a year and it takes me a week to figure this out... sigh...
Oct 04, 2015, 12:55 PM
Registered User
William A's Avatar
Lol.

BTDT !
Oct 04, 2015, 01:43 PM
BisDak2
humayraykinaon's Avatar
Quote:
Originally Posted by HypocriticalHit
Ok, this is sad. One of the props was on backwards, I've been flying quads for about a year and it takes me a week to figure this out... sigh...
Sometimes the mistake that we made are somewhat humorous
I remember assembling my rc car 4x4 and wondering why its only running rear wheel drive, I've looked any sign of problem (diffs, all 4 driveshafts, bearings) come to find out, I forgot to put the middle shaft

Have fun flying!!!
Oct 05, 2015, 06:34 AM
Round is Fun
I think everyone has done that at least once. The first time I did it, it didn't take a week to figure it out since the quad spun out of control and destroyed the props forcing a little look-see!

Mike
Oct 05, 2015, 08:36 AM
Electrical Controls Engineer
EE_Flyer's Avatar
Quote:
Originally Posted by HypocriticalHit
Ok, this is sad. One of the props was on backwards, I've been flying quads for about a year and it takes me a week to figure this out... sigh...
that's exactly what i figured. can't say i came to this conclusion without making the same mistake myself....
Feb 11, 2017, 02:05 PM
Registered User
Mine does same freeX MCFX 0-1 had few good fight now flips foward gdkp
Feb 12, 2017, 01:38 PM
Registered User

Mistakes


All mistakes are easily made


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quad (Naze32) Flips on Take Off xxJaRxx Multirotor Drone Talk 5 Dec 23, 2016 08:54 AM