Thread Tools
May 22, 2018, 01:43 PM
Old age ain't for sissies.
wilco1967 Thanks for your reply.
Sign up now
to remove ads between posts
May 22, 2018, 11:48 PM
Registered User
eziosoft's Avatar
Thread OP
Originally Posted by wilco1967
for waypoints, better to use the Mission planner for iNav, from the same guy.... EzGui works, but MP works better, IMHO

Stick command Save means safe the mission currently in memory to Eprom. So you would have to download a mission first to the flight controller, where it is stored in normal memory (which will be lost after a power cycle), and then use the stick command to safe it into eprom (so it will still be there in Eprom after a power cycle of the FC).... I never use this (you can easier select safe to eprom from mission planner).

stick command load is the opposite.... it restores a mission stored in eprom, to normal memory, so it can be used.... Please note, A mission only stored in Eprom cannot be executed.... you have to 'load' it back to normal memory before it can be used.

So for example, at home, you prepare a mission, and store it into eprom (so it will survive a power cycle)
At the field, you power up the quad / plane / whatever, and you give the stick command to load (throttle stick minimum, centre. roll/pitch stick right top corner (for mode 2). Just one second will do.... You won't notice a thing, (or perhaps a beeper, but I don't have one so not sure).
Now you can start flying, and once airborne, active the mission using a switch. It should now perform the mission.

make sure your first waypoint is less then 100 meters from your takeoff position, or it won't arm.

Can't comment on your second group of questions/remarks..... all I can say is, it works beautifully using Mission Planner (and also MWP for Linux, if you want to try).... The 1.9.3 configurator I never use.... . Doing a lot of iNav WP flying, both with copters and plane's.... never had a failure using Mission Planner
May 27, 2018, 04:54 AM
Registered User
Used EZ-GUI Ground Staion with 8“ Samsung tablet SM-T315 (Android 4.4.2) for a couple of years without any problems. I had to pause for some month and now I am facing this situation: connecting is ok (strange: with both drivers 0 and 1), but announced with the warning „no data received“ (tried with FC power off and on). I ran the USB Host Diagnostic app, everything seems ok with OTG, tablet can read e.g. USB sticks. Using friends phone Samsung Galaxy S5 Neo ( Android 6.0.1) and tablet Nexus 7 (Android 5.1.1) everything is working. To exclude any cable problems I changed OTG and USB cable too.

As I use this app for mission planning only (and to take note Eziosoft‘s warning not to use EZ-GUI for configuration furthermore) I used the new INAV Mission Planner with same problem. Could it be a driver problem with the Samsung tablet? Hopefully anyone could give me a solution for this problem. TIA

My setup is: INAV 1.9.1 / Omnibus F4V5 / EZ-GUI v4.5.450 / Mission Planner v141.1026
Jun 15, 2018, 01:31 PM
Registered User


Originally Posted by eziosoft
I would like to report a major bug.
I am a new RC player, and I bought your great EZ Ground Station App.
My hardware: X9D+, R9 Mini (sbus+sport), Matek F405-Wing FC, HC-06 Bluetooth 5600 baud rate 8N1, BN-880 GPS
The software: EZ GUI v4.5.450 , iNav 1.91, OpenTx 2.2.1

connect method 1)
HC-06 connect to Matek F405-Wing FC UART1, and my phone connect to HC-06, EZ GUI shows everything correctly.

connect method 2) (it was discussed here
In X9D+, I bind to the R9 mini, and got 18 telemetry including GPS. (and I set the unit as describe here )
In X9D+, there is a serial port inside the battery bay, and can be set to “SPort Mirror" in OpenTx ( more info )
Wiring: X9D+ serial port TX to sbus invertor to HC-06 RX (serial port output voltage is battery voltage, you need a BEC to get 5v or 3.3v for your bluetooth) (no need to connect the X9D+ serial port RX and the HC-06 TX )
I now connect my phone to the HC-06, EZ GUI connect successfully.
But the info show on the app is very wrong.
1 GPS Latitude is missing (it is hidden behind the Longitude), GPS Altitude is wrong, should be value/100 meter, GPS speed is incorrect, SAT number incorrect
2 Heading should be value/10
3 no RSSI
4 level instrument

Please please fix it.
The battery voltage and cell count are working.
Is it possible to release a quick fix, just for GPS?
really need this awesome app.
Last edited by; Jun 15, 2018 at 01:50 PM.
Aug 07, 2018, 12:14 PM
Registered User

Old EZ-GUI on new smartphone

I bought the EZ-GUI Unlocker and used EZ-GUI without problems on an old smartphone in combination with iNAV 1.5.1 and 1.7.3 .
Now I have a new smartphone. The free version of EZ-GUI is running without problems. But when I try to unlock the whole functionallity I have no success - though being logged in with my google account. Searching in the google play stor I don't find the Unlocker app any more.

How can I unlock EZ-GUI on my new smartphone?
Aug 08, 2018, 09:11 AM
Registered User
You should try "iNav Mission Planner"
Aug 08, 2018, 11:56 AM
Registered User
Originally Posted by Schalonsus
You should try "iNav Mission Planner"
Thanks. But in reality I'am asking for a friend of mine - and he has problems with the english language. And as far as I know, "iNav Mission Planner" is not available with a german user interface.
Dec 07, 2018, 05:00 AM
Registered User
Hallo all,
if I could get the XML or html strings of the app I would translate it into German.
Mar 15, 2019, 02:51 AM
Registered User
maybe if dev is not maintaining the project anymore (especially after so may people paid for the unlocker) , releasing source might be a good idea instead of just dropping it like a hot potato and trying to charge people again for inav mission planner....
Mar 24, 2019, 10:34 AM
Registered User
Hi, I have BT HC-05
AT command work if I click button on BT board.
I can't change password or port speed, BT say Error (..)
I connected BT board to SP F3 firmware INAV/SPRACINGF3 2.1.0 in UART1, started EZ GUI on my Xiaomi Redmi Note 4 (MTK), EZ GUI connecting.... and say no connecting.

Should I install an older firmware version?
Apr 05, 2019, 07:41 AM
Registered User
Hi, I'm using ez-gui for some years now. Browsing the playstore I got the following message:
This application is NOT compatible with Betaflight 3.2 and up.
It will still connect and read sensor data, control motors etc, but after setting up PID, Modes or anything else it can override/change your existing configuration in uncontrolled way. “
Its still save to use ezgui with inav2.1? Does anybody use this combination? Problems?

Quick Reply

Thread Tools