Thread Tools
Sep 28, 2015, 02:46 PM
Registered User
Thread OP
Discussion

Please help me, First 450 build and its flipping!!


My 450 Build

Frame: HJ450 4-Axis 450F Frame Airframe FlameWheel Smooth KK MK MWC Quadcopter

Motors: 2212 920KV Brushless Motor (2R/2L) for DJI Phantom

Props: DJI GEMFAN Carbon Nylon 1045 Propellers MultiCopter Quadcopter

ESC’s: SimonK 30A 2-3S Brushless ESC With 5V 3A ESC

Flight Controller: OpenPilot CC3D Flight Controller Bent Pin STM32 32-bit Flexiport

Transmitter/Receiver: Turnigy 9X 9Ch Transmitter w/ Module & 8ch Receiver (Mode 2)

Battery: RC ZIPPY Flightmax 3000mAh 3S1P 20C

Problems during build: When setting up the motors I moved the slider in motor 1 to around 1126(not sure of the measurement name) to get the motor running stable no probs. Went on to motor 2 and it moved about 2-3mm each way, as if it was stuck, then the ESC went up in smoke. I replaced both ESC (obiously) and the motor just to be on the safe side, no problems afterwards.


Adjustments Made: When setting up the Transmitter using the open pilot software, I couldn’t get past the Flight Mode recognition stage, ie when you are asked to move all controls one by one.

There is a 3 way switch just under the flight mode label, but its doesn’t recognise it so after searching online I found a comment on a youtube video which instructed to Transmitter transmitter menu, then function setting, then AUX-CH then lock "GEAR" on CH5.
This worked and allowed me to complete receiver

Current Problem: I started out slowly increasing the throttle because this was my first experience on a larger quadcopter. When increased to when it begun lifting/moving it just flipped resulting in a broken prop. I replaced the broken prop, checked the others and tried again and it did the same thing.


I then completed the entire calibration process for both flight controller and receiver about 10 times and still the same result. After 2 sets of props, and I probably should have done this sooner, but I left the props off and begun to observe the motors when I powered up and moved the controls. I throttled to around 50% then moved the right stick all the way to the left, some motors stopped completely and some continued spinning.

I did this again with various other stick movements and noticed that the motors were behaving really strangely in that when I throttled to say 20%, 3 would start and the other would remain stationary until a little more throttle was given.

Im really stuck and would appreciate all and any help. I have searched online and watched countless videos but cant find this fault. It’s my first build and I anticipated problems, but I don’t even know where to begin in terms of finding the fault.

Is it the motors? The esc’s?

I have screen captured the entire openpilot calibration process for both vehicle and transmitter and also taken pictures of my build.
Sign up now
to remove ads between posts
Sep 28, 2015, 03:24 PM
Registered User
The controller has to be placed in certain way on your quad. Your controller is facing wrong way. There is a small arrow towards the upper edge of the controller (in your picture). The arrow is supposed to be facing forward of your quad. Assuming that your white arms are either the front or rear of your quad, the arrow is facing sideways.
Sep 29, 2015, 02:08 AM
Registered User
Thread OP

Oops


Thank you Risi for you rapid reply, im assuming this is what is causing the problems?

I shall rectify this schoolboy error after work today (which im sure my wife is ecstatic about lol) and report back.

Thank you again sir!!

John
Sep 29, 2015, 08:49 AM
Registered User
Thread OP

Im airborne, but.....


Risi

Im airborne!! ���� fixed the flight controller to face the correct way and started her up.It flipped straight away!!. I then flicked the flight mode switch and instantly the motors all spun in time.

the biggest smile appeared on my face, so thank you risi. Ive just 2 small wee questions...

1 i noticed that when i bank left for example, then return the control to centre, it continues too move in the last moved direction if that makes any sense, is there a fix for that??
2 i have a low voltage alarm But unsure how to fit, i honestly havent looked anywhere to see how its fitted but was wondering if u knew off the top of you head?

Again, thank u so much for your help, im ever so grateful, u have no idea just how much!!

John
Sep 29, 2015, 02:50 PM
Registered User
Thread OP
Sussed the voltage meter, i bought one without the alarm!.
Sep 29, 2015, 04:26 PM
Registered User
I'm glad that you're flying...
As far as the voltage meter goes, you plug into it a small connector that is attached to the battery. Your meter is good for up to 6S batteries, so some pins will not be used. If you are plugging in the 3S battery, you use the left 4 pins. (See the images below.)
I'm not sure, if I understand you correctly about banking, but if I do, that is the inertia that keeps the craft going in the original direction, and if you want to stop the movement, you cannot simply return to the centre, but need to take it slightly passed the centre, for a second...
Hope that helps... Have fun flying!

Rich
Sep 30, 2015, 12:34 AM
Registered User
It sounds like you put it Into acro mode - no gyro/accel assist. It flips because you have the orientation wrong in your FC. I suspect one of your axes needs offset by 180 degrees.
Sep 30, 2015, 12:39 AM
Registered User
Once it is flying, be very careful not to let that receiver get too far away. It has no failsafe and it will continue flying away if it gets out of range. I'd recommend upgrading your tx module to perhaps a FrSky asap.
Oct 02, 2015, 08:10 AM
Registered User
Thread OP
Thanks risi, realised i ordered a voltage indicator without alarm. @hoggerneck, yeah i set it up in acro mode. When i Went through the transmitter setup, it wouldnt recognise the 3 way switch labeled flight mode on the transmitter, so as explained above i had to modify chamnel 5 which enabled me to complete the transmitter setup using the top right switch.

regarding the flipping, after adjusting the flight controller, it still flipped, but i could begin flying once i flicked the flight mode switch. Ive tried to google it but i still dont know what the 2 modes are, ie which one it is when the switch in position 1 and flips the quadcopter, or which mode it is in position 2 that allows the quad to fly
Oct 02, 2015, 08:44 AM
Registered User
Start the gcs and plug the cc3d in while everything is powered. On the rc input page you will see the flight modes real time and move the tx flight mode switch to see which is being switched into. You will need a mode set that self levels if you want it to return to level when stick centers. Like leveling mode or stabilized1 with axis set to attitude/attitude/axis lock.

Configuration>RC Input>Flight Mode Switch Setting tab
Last edited by pug398; Oct 02, 2015 at 08:50 AM.
Oct 02, 2015, 10:16 AM
Registered User
Thread OP

Fm setting


This is how its setup atm, can u guide from here please sir?

Mode 3 is what allows it to fly, the one with rate/rate/
Last edited by scotsman; Oct 02, 2015 at 10:32 AM.
Oct 02, 2015, 01:26 PM
Registered User
That actually looks ok as far as I can tell for switch position 1 and 2. Make sure you calibrate it again after rotating the board as sensor bias will be off if you kept the same calibration.
Oct 02, 2015, 01:40 PM
Registered User
Thread OP
No recalibrated and it still flips, im due flipping it out the flipping window lol
Oct 03, 2015, 02:26 PM
Registered User
Thread OP

Strange Day, Smashed it into 100 pieces


Hey...

After previous attempts and being dumbfounded as to why the first flight mode didn't work, today it just randomly started working!!. I was able to fly the quadcopter gracefully through the air, and was really chuffed too....

Went out about 2 hours ago, sent her up and brought her back down after around 5 mins, with about 20 metres to go, she just gave a slight jolt forwards and plummeted to earth, hitting the only piece of concrete within 500m!!.

Battery was fully charged, everything was working perfect for the first time, ah well..build-fly-crash-repeat lol
Oct 03, 2015, 09:34 PM
Registered User
Prop or motor failure? Sudden flip could be that.


Quick Reply
Message:

Thread Tools