Thread Tools
Mar 11, 2015, 03:46 PM
Registered User
Thread OP
Help!

Naze32 solid blue LED after crash, won't boot


I have a solid blue LED, the board won't connect via usb or bluetooth, no other LED activity indicating failure to boot?
Tried shorting the boot pins, it will accept a firmware flash but still won't boot when power cycled. The CPU isn't getting hot.

Also tried connecting via Hercules, it does nothing when I send reboot command, putty also. Am I missing something?


It was working fine until I lost a prop, then when the quad crashed all the motors continued to run and it would not disarm. The board was not damaged and it wasn't a heavy impact as it was on grass.
Sign up now
to remove ads between posts
Mar 11, 2015, 06:36 PM
Team AlienWarpSquad
The Blue LED is just power.
Sounds like something on the board broke and came un-soldered.
Try examining with a good magnified and get a new board on order.
Mar 11, 2015, 07:13 PM
Registered User
Thread OP
Looked closely and no signs of damage. Weird that it will take a firmware update but won't boot?

Ordered a new one. This is the second to die on me in 2 weeks, the first never even flew, after a few test runs the cpu started getting hot.

Are they particularly ESD sensitive?
Mar 11, 2015, 08:40 PM
Team AlienWarpSquad
Maybe try one of the Clones. There are several now.

They are ESD sensitive but not extremely so.


Quick Reply
Message:

Thread Tools