Thread Tools
Mar 04, 2015, 03:27 PM
Registered User
Thread OP
Discussion

Issue with Devo 7, RX701 and Naza-M Lite on a Storm Drone


New to the hobby and new to the forum too.

i bought a storm drone from helipal and decided to upgrade to a Naza-m Lite controller as well. I tried to use the settings provided by Helipal but they had wrote their guides to use the Gear Switch for IOC, i wanted to use the MIX switch for all 3 modes.

I stumbled across chiefwiftnick's guide that he posted on this forum which was great!

Link: https://www.rcgroups.com/forums/showpost.php?p=27169039


However... i started the process first by resetting all values on my Devo 7 (not F7) so that i could follow his instructions.

I followed everything to the letter (i think), it completed the unbind and bind process, it finished the FIX ID process too (i turned it off after it worked) then i plugged it into my laptop to test all the functions. Everything works exactly how i want it to BUT ..... when i disconnect from the laptop and tried to arm the quad with one of the unlock actions (both sticks down and left), nothing happend. The rx light is not flashing, and it sounds like the Tx is connecting to the quad but when i do the unlock command the rotors dont spin up and nothing happens.

Even the Naza LED module blinks RED, RED, RED (which is 5+ Satelites found i think).

What am i missing? what did i do wrong? is it because the guide i used is for the Devo F7 and mine is a Devo 7?

Please help!

Thank you in advance.
Last edited by Fotoman_Shack; Mar 05, 2015 at 02:09 AM. Reason: Spelling
Sign up now
to remove ads between posts


Quick Reply
Message:

Thread Tools