Thread Tools
Feb 11, 2017, 09:47 PM
Just Plane Nutts
AirDOGGe's Avatar
Proseal makes some good stuff: http://www.homedepot.com/p/ProSeal-3...0066/202805532



But the stuff you asked of being used in factories on full size boats is a high grade marine sealant I have used before to seal a plastic tank. VERY strong, but it took 2 days to set and 7 to fully cure...and it is white... I got it from a local boat supply store (West Marine).

Tensile strength..700lbs...
https://www.westmarine.com/buy/3m--5...1?recordNum=48

Available in bigger tubes too...
https://www.westmarine.com/buy/3m--5...85?recordNum=1

There's a fast-cure version, but it doesn't seem to bond as well to me.
Sign up now
to remove ads between posts
Feb 12, 2017, 03:04 AM
Registered User
Thanks, AirDOGGe. Very helpful information. I will see what I can find in my area.
Jun 15, 2017, 02:51 PM
Registered User
any mods or upgrades, or a forum section for mods/upgrades for this boat? i just got one on trade. wondering if i should slap a old model traxxas xl5 esc in it and run it 3s with a better motor. im guessing the motor is a 380 size motor? any thoughts?
Jun 15, 2017, 07:02 PM
Registered User
ludorc's Avatar
Could someone advise for a cheap marine/waterproof micro servo to replace the stock one?
I am running in salt water, and the servo just Diesel :-(
Jun 29, 2017, 04:49 AM
Registered User
Does anyone know whether the radio system on this boat is compatible with other systems e.g. FlySky or Spektrum? A friend of mine bought one of these at a thrift shop for 99pence, but it doesn't have the charge lead or a transmitter, and is wondering whether he can get an alternative Tx to control it. TIA
Jun 29, 2017, 12:07 PM
Just Plane Nutts
AirDOGGe's Avatar
I don't know of any other TXs that would work, but charge cords here: http://www.gearbest.com/rc-boat-part...348.html?wid=4
Jul 13, 2017, 05:24 PM
Registered User

Loss of steering ability


Got this for my son yesterday.
It ran great for about 25 min, then lost the steering function. When he pulled it out of the pool, it did have a bit of water inside.
We dried it out and tried again, thinking maybe that was the problem.
Today, we've tried several times. It runs fine for a bit, then loses steering function. Motor is fine, it can go forward and reverse. But the servo wants to make weird noises, and even tries to run OUT OF the water, on the stand, with the remote off.
Sounds like a weird short circuit noise.

Ugh.
Bad servo? Bad boat?
Anybody had this happen?
Jul 13, 2017, 06:11 PM
Just Plane Nutts
AirDOGGe's Avatar
Servo got wet and is bad now. Very common. I've killed a few.

Prevention involves sealing the servo casing with something like plasti-dip, or what I and most experienced RC boaters do is open up the servo, then spray some CorrosionX dielectric spray on the little circuit board in the bottom of the case only. Do not spray the potentiometer in the middle of the case, else ti may fail. Use the spray on the circuit board of the receiver/ESC too, but not on the connectors.

Some electronics have been saved after being coated with CX and being let to sit alone for awhile. You could try doing that with your failed servo. I bet when you open it up via the 4 tiny-but-long screws, you'll find a few drops of water in the bottom.

CorrosionX is amazing. They once had an ad showing a TV running underwater after being dipped in the stuff. Get it in some tool supplies, fishing supply stores or online: http://www.ebay.com/itm/CORROSIONX-9...AAAOSw3v5YtPih
Jul 13, 2017, 07:22 PM
Registered User
Sounds like the perfect job for dad!
Lol
Thanks so much!
Aug 20, 2017, 05:35 PM
Registered User

Venom running slow


Hi All,

New to this forum and to RC boats. The Venom UDI001 is the first boat I've ever had. Looking to learn a little about the RC boat hobby and maybe eventually move up.

I've had my Venom for about a month and have been enjoying it. I've run it about 20 times with no issues until the last run yesterday. It would not run at normal speed. Not fast enough to get the nose out of the water. Fresh battery and prop seemed to be spinning fast but boat would only barely move in the water. I noticed that the prop seemed to have a "notchy" feel when rotated by hand (not smooth). Could this be lack of lube on the prop shaft? As I said, I'm a noob and didn't realize this needed to be done so often. Could I have caused permanent damage? If so, what should I replace?
Aug 20, 2017, 09:36 PM
Just Plane Nutts
AirDOGGe's Avatar
Break it down, clean it off, lube it up and piece it back together, then test. That's the only way to be sure.


You should pulls the prop shaft and clean/lube everything after every days running session before putting it away, so it will be ready and reliable for the next time.
Jun 18, 2019, 07:58 PM
Registered User

rc boat


so my venom rc boat does not want to get out of the water it just noise dives what is rong
Jun 20, 2019, 02:53 PM
Just Plane Nutts
AirDOGGe's Avatar
Hard to say with just this limited information. Maybe photos, or better yet a video for us to see the problem firsthand. Was anything changed from stock?


Quick Reply
Message:

Thread Tools