Is it my Rx or Tx? - RC Groups
Thread Tools
May 15, 2004, 03:27 PM
The original Flying Pigs Sqd.
Up&Away's Avatar

Is it my Rx or Tx?


1. Several times now, on plugging in the battery of my Unicorn, the ESC starts beeping like mad. I then unplug the battery, and unplug both sercos and ESC, plug it all in again, and most of the time everything is fine again.

2. Last week I was flying my Unicorn, and out of the blue lost total control and crashed. The two other pilots in the field where on total different frequencies. Upon retrieval there was minimal damage to my 'Corn, but the antenna plug had come loose. I am not sure if this was cause or result. I soldered the plug back on, and had a few normal flights. During the last flight suddenly my 'Corn lurched all over the sky for no apparent reason for a few seconds, and then was a docile as usual. I landed, and while walking back to the car with both Tx and Rx still switched on, the servos suddenly started a life of their own! I assumed someone, somewhere was on my frequency.

3. Yesterday I was flying my Unicorn again, and out of the blue again lost total control and crashed. Upon retrieval while still lying in the position I had found it, no input from my Tx would cause the servos to move. I picked up my 'Corn and started walking back to the car. Again the servos started a life of their own. According to the frequency board I was the only one using Ch60. I asked around, and no-one fessed up being on Ch60. I unplugged the Rx, and found all in order. Plugged everything back in. A few times I had to repeat this (see #1) untill I had armed the ESC properly. I walked onto the runway to launch my 'Corn, when again the servos and the motor started a life all of their own.

Any ideas anyone?
Sign up now
to remove ads between posts
May 15, 2004, 03:40 PM
An Original!
I have heard of a guy having a similar problem caused by the wire going to the antenna inside the case breaking loose. You might check that wire just for security sake. In cases like this it sure would be nice to have a channel checker just to be sure it isn't some out of area interference.
May 16, 2004, 03:13 AM
Registered User
Patrick Plawner's Avatar
To debug it, then just try a different receiver. I must have one for you to try out, and therefore see if this is the problem.

If confirmed, then it will be easier to single out the issue.
May 16, 2004, 03:26 AM
The original Flying Pigs Sqd.
Up&Away's Avatar
There's an idea. Why didn't I think of that ? I have a brand new 6 channel Rx for my Filip. It won't fit in my 'Corn, so I can't fly with it, but I can plug it in to see if I have any problem arming the ESC.

The only problem will be that my wife will see my new Rx...
May 16, 2004, 03:18 PM
The original Flying Pigs Sqd.
Up&Away's Avatar
Well, plugged in my regular Rx, armed the ESC no problem!

What now?
May 16, 2004, 04:10 PM
Registered User
Patrick Plawner's Avatar
It is possible that crashes, damaged the receiver.
My 2 agurot, send it for repair to the place you bought it and don't use it for now.
May 16, 2004, 05:38 PM
An Original!
You might also try a new or different crystal in your problemed Rx. Crystals do go bad as well.
May 17, 2004, 12:54 AM
The original Flying Pigs Sqd.
Up&Away's Avatar
I'm not totally convinced (yet) that it is the problem is with the Rx. I was going to take my Tx in for servicing anyway, before doing the maiden with my Filip 600 Sport. So we'll see. I can do that through my LHS. The Rx has to be serviced in the US.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Trade my EzUHF TX and RX for TBS Crossfire TX erick3150 Aircraft - Electric - Multirotor (FS/W) 0 Mar 23, 2017 04:25 PM
For Sale Trade my EzUHFacebook TX and RX for TBS Crossfire TX erick3150 Aircraft - General - Radio Equipment (FS/W) 0 Mar 23, 2017 04:23 PM
Help! Problems with my tx (or is it the rx) darwinthejonk Beginner Multirotor Drones 10 Feb 03, 2017 06:33 PM
Discussion FPV lucky escape! Cyclops Storm or EzUHF Tx or Rx malfunction? JonBOY26 FPV Equipment 1 Dec 28, 2016 06:03 AM
Found My T9X W/ 8 ch RX for TX/RX 72 mhz dankar04 Aircraft - General - Radio Equipment (FS/W) 0 Nov 20, 2015 11:24 AM