Thread Tools
Jul 16, 2019, 05:52 PM
Registered User
Pixelpeter's Avatar
Quote:
Originally Posted by samisa
FPV maiden went very well, here a video for you.. enjoy!

https://youtu.be/aGSBc6CrJvE
Get message "video not available"
Sign up now
to remove ads between posts
Jul 17, 2019, 02:52 AM
Registered User
Quote:
Originally Posted by Pixelpeter
Get message "video not available"
Works now, my goggles dont have DVR function so recorded with my iphone
Last edited by samisa; Aug 03, 2019 at 05:03 PM.
Jul 17, 2019, 09:48 AM
Just out for fun
graywoulf's Avatar
Quote:
Originally Posted by samisa
FPV maiden went very well, here a video for you.. enjoy!
Very cool to watch. I bet the goggles were fun.
Jul 17, 2019, 10:28 AM
Registered User
Pixelpeter's Avatar
Quote:
Originally Posted by samisa
Works now, my goggles dont have DVR function so recorded with my iphone > https://www.youtube.com/watch?v=LTXr...ature=youtu.be
Yeah that worked. Thanks
Jul 17, 2019, 12:17 PM
Registered User
Looks like the original EV800 goggle screen (?).
Pity about the direct DVR. but you have to use whatever you can and it worked
Jul 21, 2019, 11:39 AM
Registered User
Frank Church's Avatar

Binding problem


Bought this F-959 a long time ago, bound it with no problems and flew it a few times. So now bringing it out of storage, with a freshly charged battery and new batteries in the supplied TX, I turn it on, wait for the flashing red lites to go off but only the motor runs, no rudder or elevator action. Am I supposed to see a light of some sort on the receiver? If so there is no light on. It does beep so I assumed that with the lights going off it indicated it was bound. Any suggestions or ideas as to what is going on here?
Jul 21, 2019, 04:55 PM
Registered User
Frank Church's Avatar
Quote:
Originally Posted by Frank Church
Bought this F-959 a long time ago, bound it with no problems and flew it a few times. So now bringing it out of storage, with a freshly charged battery and new batteries in the supplied TX, I turn it on, wait for the flashing red lites to go off but only the motor runs, no rudder or elevator action. Am I supposed to see a light of some sort on the receiver? If so there is no light on. It does beep so I assumed that with the lights going off it indicated it was bound. Any suggestions or ideas as to what is going on here?
Found the problem, a bad brick. Checked the TX with another F-959 and it worked fine.
Sep 15, 2019, 02:53 PM
Registered User
When I throttle the f959 sky king after 3 seconds it shuts off after replacing the motor and the reciever everything else works fine
Sep 18, 2019, 05:03 AM
Registered User
Quote:
Originally Posted by Paposhack
When I throttle the f959 sky king after 3 seconds it shuts off after replacing the motor and the reciever everything else works fine
Battery?


Quick Reply
Message:

Thread Tools