Pheonix 45 dated September 2003 won't work with PHX-link - RC Groups
Thread Tools
May 02, 2004, 09:23 PM
Danger! Danger!
FrankW's Avatar

Pheonix 45 dated September 2003 won't work with PHX-link

Okay, We have the new PHX-link set up at work and I used it today to set up my new pheonix 25. But I tried to hook up my Pheonix 45 that's dated Sept. 2003 and it won't work. On the website it states that ESCs dated August 2003 and newer should work with the link. I don't really want to send the ESC in, but if I have no other choice then I can. I'm just not a fan of doing the whole transmitter programming. Any advice/help?

Oh, and my Pheonix 10 has softstart programming (a requirement for it to work with the PHX-link) and it doesn't work either.

The Pheonix 25 works perfectly.

Last edited by FrankW; May 02, 2004 at 09:25 PM.
Sign up now
to remove ads between posts
May 03, 2004, 06:02 AM
Registered User
Not an expert (only got mine on Friday) but I had one brand new PH10 and one purchased in December. The new one worked instantly the December one not at all. I remembered a few threads that suggested multiple plugging unplugging cycles and went to town on that with no resluts.

There was also another thread that spoke about getting it to recognise a working one, swap it for a non working one and then all would be well. This worked to a point but the software upload hung. So I unplugged plugged the ESC and it went like normal. Now it is recognised each time.

All of the above is probably against all the rules but the worst that can happen is you need to send the ESC back to CC for a free update.

Last edited by mjdoz; May 03, 2004 at 06:05 AM.