Thread Tools
Jul 30, 2021, 04:05 PM
Registered User
marktur's Avatar
Quote:
Originally Posted by MikeHRC
Run Vstabi and it will show you
I'm sorry - I know where to plug in the satellites... but where do I plug in the ESC to power it? RXa, b, c?

Thanks for your help.
Mark
Sign up now
to remove ads between posts
Jul 30, 2021, 04:07 PM
Registered User
marktur's Avatar
Found this... I'm guessing it is safe in either RCb or RCc?
Last edited by marktur; Jul 30, 2021 at 04:13 PM.
Jul 31, 2021, 12:40 AM
Registered User
2Doggs's Avatar
You found the "wiring your mini Vbar" page then.

On that page, however, scroll down to "Connectors for Spektrum satellites".

The ESC lead should go into RX B and you can have additional power going into RX C - for example if you were using an opto ESC and a separate BEC or RX pack.

In order to avoid burning out the Kbar, never connect the ESC lead or a power connector to RX A, which is a triple signal input.
Aug 01, 2021, 08:00 AM
Registered User
marktur's Avatar
Hi 2Doggs...ok, I got it wired up, bound to 2 sats, and working properly....EXCEPT for arming. Servos all work fine, When I plug in (using a Hobbywing Flyfun 60A V5)...I get three beeps only when I plug in, never hear arming sounds... No subtrim, thr-hold set to -120 (I always plug in with TH on, but tried without, no difference.

If I can figure this last issue out, I can go fly it! Grrrr! LOL - coming from the drone world, I'm guessing this is a controller not seeing full closed throttle, but how to adjust?

Thanks for the help, guys... I'm trying to get away from my flybar helis (10+ years old) and start playing with new technology...if only they came with good docs!
Aug 01, 2021, 08:49 AM
Registered User
Quote:
Originally Posted by marktur
Hi 2Doggs...ok, I got it wired up, bound to 2 sats, and working properly....EXCEPT for arming. Servos all work fine, When I plug in (using a Hobbywing Flyfun 60A V5)...I get three beeps only when I plug in, never hear arming sounds... No subtrim, thr-hold set to -120 (I always plug in with TH on, but tried without, no difference.

If I can figure this last issue out, I can go fly it! Grrrr! LOL - coming from the drone world, I'm guessing this is a controller not seeing full closed throttle, but how to adjust?

Thanks for the help, guys... I'm trying to get away from my flybar helis (10+ years old) and start playing with new technology...if only they came with good docs!
Have you calibrated your ESC - you need to teach it where minimum and maximum throttle are. Also check that you do not have Dual Rates set on the throttle channel, and disable trim on throttle channel (or make sure at minimum)
Aug 01, 2021, 10:16 AM
Registered User
marktur's Avatar
Hi - thanks

No, I am not able to calibrate. I plug it in with the throttle stick high, no extra tones... I've never seen this before... and I haven't gotten to the "closed" side yet, so trim, etc. shouldn't be any issue, however, I tried with trim hi, lo, mid - no difference. No dual rates or subtrims on throttle... brand new model in the radio to be sure. All I set was max travel to -120 on low.

Now, here's something...I just plugged in the ESC to the programming card, nothing but dashes..no values.
This is just weird, I can't believe this is a DOA ESC, because everything else is working. I also realized that I don't even get the 3 beeps unless I have 2 motor wires plugged in.

I have to be mission something really dumb here...and of course I ran all wires, nice and clean, etc. so I really didn't want to pull it apart and plug it into an airplane or something...but maybe I can do it with a reciever and battery pack. But if I calibrate with rx "A", and then move it back to the heli, did I solve any issues?
Aug 01, 2021, 10:21 AM
Registered User
the kbar defaults to trim flight starting with high stick. you have to uncheck the box to allow it to send the signal to the ESC. do it outside, and plug it in. alternately remove your blades to do it on the bench.
Aug 01, 2021, 11:38 AM
Registered User
It is th emotor that makes the beeps, not the ESC - so you'll need the motor connected to hear them, that is normal
Aug 01, 2021, 01:39 PM
Registered User
2Doggs's Avatar
I'd be wary of having TH less than zero - it might cause the ESC to recalibrate. There's no control of throttle thru the Kbar, but you still need to do an ESC throttle calibration.
Aug 01, 2021, 03:19 PM
Registered User
Quote:
Originally Posted by 2Doggs
I'd be wary of having TH less than zero - it might cause the ESC to recalibrate. There's no control of throttle thru the Kbar, but you still need to do an ESC throttle calibration.
Agreed - if you calibrate with it at -120 it will take -120 as low throttle - calibrate with -100
Aug 01, 2021, 06:46 PM
Registered User
marktur's Avatar
Thanks guys - just got home a little bit ago from the flying field... I will do all things above! I didn't look for the checkmark, nor did it catch my eye - so thank you! Also will change to -100. I don't have the blades on so I'll connect the motor as well. REALLY appreciate the help, guys! Thank you!

Today I flew my old, but very good flier - Align Trex 450 Plus - I guess the only one with a flybar...I couldn't remember what model, but went to download manuals and saw it was the only one. I thought it was "Pro" or SE2...lol. But I have if flying rock-solid, no wobbles or shakes, so it's great to get me back in the game after a long time off. I've been flying jets and drones...probably been 10+ years since I flew a heli, but someone got one of the XKK toy helis out at the field, I hovered, I did nose-in hovering, flew a few circuits FFF and hooked all over again!!! This time no fuel, no mess, too! I have a Trex 500 with Flybar too, got her rock-solid as well... and I'm trying to go flybarless, so I bought a Tarot 450 to tinker with. That's what got me here! I think I'll put a scale body on the Align one... The deals on Amazon are amazing! I can't believe how much prices on everything have come down! $126.99 for a variety of 450 bodies. Wow!
Aug 02, 2021, 05:15 PM
Registered User
marktur's Avatar
Quote:
Originally Posted by Wayne Moyer
the kbar defaults to trim flight starting with high stick. you have to uncheck the box to allow it to send the signal to the ESC. do it outside, and plug it in. alternately remove your blades to do it on the bench.
Hi Wayne, where exactly is that little checkbox???

Regardless, I set TX to 100, -100 for throt. Still no change. Very slow beep from the motor.
Aug 02, 2021, 05:37 PM
Registered User
IIRC it's on the opening page of the software, it has been a while since I have been in there... 3 kbars, all flying great...
Aug 02, 2021, 05:59 PM
Registered User
marktur's Avatar
OK, turned off autotrim.
Still not seeing the ESC, dammit.

Slow beep from motor after 3 beeps from ESC.

Would it help if I upload my save file? Well, here it is to save time...I gotta be missing something silly...I believe all the posts that this is a good controller, and from my experience with building drones, I know they can be touchy about arming with certain parameters...

Thanks in advance for everyone's help!
Mark

<REGISTER>
<VALUE Register="0" Value="-45"/>
<VALUE Register="1" Value="0"/>
<VALUE Register="2" Value="0"/>
<VALUE Register="3" Value="0"/>
<VALUE Register="5" Value="32"/>
<VALUE Register="6" Value="30"/>
<VALUE Register="7" Value="55"/>
<VALUE Register="8" Value="55"/>
<VALUE Register="10" Value="20"/>
<VALUE Register="11" Value="20"/>
<VALUE Register="12" Value="0"/>
<VALUE Register="13" Value="0"/>
<VALUE Register="14" Value="98"/>
<VALUE Register="16" Value="100"/>
<VALUE Register="17" Value="100"/>
<VALUE Register="18" Value="100"/>
<VALUE Register="19" Value="0"/>
<VALUE Register="20" Value="0"/>
<VALUE Register="21" Value="-100"/>
<VALUE Register="22" Value="-87"/>
<VALUE Register="23" Value="50"/>
<VALUE Register="24" Value="87"/>
<VALUE Register="25" Value="50"/>
<VALUE Register="26" Value="0"/>
<VALUE Register="27" Value="0"/>
<VALUE Register="28" Value="55"/>
<VALUE Register="30" Value="33"/>
<VALUE Register="31" Value="50"/>
<VALUE Register="32" Value="50"/>
<VALUE Register="33" Value="31"/>
<VALUE Register="35" Value="33"/>
<VALUE Register="36" Value="0"/>
<VALUE Register="37" Value="0"/>
<VALUE Register="38" Value="0"/>
<VALUE Register="39" Value="0"/>
<VALUE Register="40" Value="33"/>
<VALUE Register="41" Value="17"/>
<VALUE Register="42" Value="58"/>
<VALUE Register="43" Value="0"/>
<VALUE Register="46" Value="15"/>
<VALUE Register="47" Value="50"/>
<VALUE Register="48" Value="85"/>
<VALUE Register="50" Value="59"/>
<VALUE Register="51" Value="60"/>
<VALUE Register="52" Value="67"/>
<VALUE Register="53" Value="8"/>
<VALUE Register="54" Value="22"/>
<VALUE Register="55" Value="-99"/>
<VALUE Register="56" Value="9"/>
<VALUE Register="57" Value="0"/>
<VALUE Register="58" Value="30"/>
<VALUE Register="59" Value="80"/>
<VALUE Register="66" Value="80"/>
<VALUE Register="67" Value="10"/>
<VALUE Register="68" Value="20"/>
<VALUE Register="69" Value="0"/>
<VALUE Register="72" Value="3"/>
<VALUE Register="75" Value="5"/>
<VALUE Register="77" Value="2"/>
<VALUE Register="79" Value="48"/>
<VALUE Register="82" Value="0"/>
<VALUE Register="200" Value="3"/>
<VALUE Register="201" Value="3"/>
<VALUE Register="202" Value="2"/>
<VALUE Register="203" Value="2"/>
<VALUE Register="204" Value="0"/>
<VALUE Register="205" Value="1"/>
<VALUE Register="206" Value="1"/>
<VALUE Register="207" Value="0"/>
<VALUE Register="210" Value="0"/>
<VALUE Register="211" Value="1"/>
<VALUE Register="212" Value="2"/>
<VALUE Register="213" Value="3"/>
<VALUE Register="214" Value="0"/>
<VALUE Register="215" Value="6"/>
<VALUE Register="216" Value="1"/>
<VALUE Register="219" Value="10"/>
<VALUE Register="221" Value="7"/>
<VALUE Register="222" Value="3"/>
<VALUE Register="223" Value="0"/>
<VALUE Register="224" Value="-30"/>
<VALUE Register="228" Value="0"/>
<VALUE Register="229" Value="1"/>
<VALUE Register="255" Value="0"/>
<VALUE Register="256" Value="0"/>
<VALUE Register="257" Value="0"/>
<VALUE Register="109" Value="83"/>
<VALUE Register="110" Value="786"/>
<VALUE Register="111" Value="4094"/>
<VALUE Register="112" Value="4101"/>
<VALUE Register="113" Value="4093"/>
<VALUE Register="120" Value="0"/>
<VALUE Register="121" Value="0"/>
<VALUE Register="125" Value="772"/>
<VALUE Register="126" Value="0"/>
<VALUE Register="127" Value="0"/>
<VALUE Register="128" Value="140"/>
<VALUE Register="141" Value="0"/>
<VALUE Register="498" Value="5939"/>
<VALUE Register="499" Value="4"/>
<VALUE Register="510" Value="21"/>
<VALUE Register="511" Value="16"/>
<VALUE Register="512" Value="0"/>
<VALUE Register="513" Value="0"/>
<VALUE Register="514" Value="0"/>
<VALUE Register="515" Value="24"/>
<VALUE Register="516" Value="9"/>
<VALUE Register="517" Value="10"/>
<VALUE Register="518" Value="13"/>
<VALUE Register="519" Value="38"/>
<VALUE Register="45" Value="25"/>
<VALUE Register="70" Value="50"/>
<VALUE Register="71" Value="60"/>
<VALUE Register="80" Value="-1"/>
<VALUE Register="81" Value="-1"/>
<VALUE Register="83" Value="100"/>
<VALUE Register="84" Value="30"/>
<VALUE Register="85" Value="0"/>
<VALUE Register="86" Value="30"/>
<VALUE Register="87" Value="100"/>
<VALUE Register="88" Value="30"/>
<VALUE Register="89" Value="25"/>
<VALUE Register="90" Value="10"/>
<VALUE Register="91" Value="0"/>
<VALUE Register="92" Value="20"/>
<VALUE Register="93" Value="3"/>
<VALUE Register="94" Value="20"/>
<VALUE Register="122" Value="0"/>
<VALUE Register="123" Value="0"/>
<VALUE Register="124" Value="0"/>
<VALUE Register="142" Value="0"/>
<VALUE Register="143" Value="0"/>
<VALUE Register="129" Value="0"/>
<VALUE Register="231" Value="50"/>
<VALUE Register="232" Value="50"/>
<VALUE Register="233" Value="100"/>
<VALUE Register="234" Value="0"/>
<VALUE Register="235" Value="0"/>
<VALUE Register="236" Value="0"/>
<VALUE Register="237" Value="-1"/>
<VALUE Register="239" Value="6"/>
<VALUE Register="240" Value="1"/>
<VALUE Register="241" Value="0"/>
</REGISTER>
Aug 02, 2021, 11:42 PM
Registered User
It sounds to me like the ESC isn't seeing zero stick, this is usually due to it not being calibrated - have you got it to calibrate yet?

While most ESCs calibrate in the same way, some differ - which ESC is it?


Quick Reply
Message:

Thread Tools