Thread Tools
Jul 27, 2014, 08:59 PM
Registered User
Discussion

PL6 bad cell count


Pl6 charger, maybe 6 months old, just started reporting bad cell count. It's been getting some other errors occasionally, I think system error 96.

I've checked the FMA and Xh setting, neither works. Plugged my cables, balance board, and battery into a different pl6 and it works fine.

Pretty sure it's going to have to go back to FMA. Anyone else have this issue, or know a way to fix it?
Sign up now
to remove ads between posts
Jul 27, 2014, 11:22 PM
Revolectrix Ambassador
Usually its caused by an issue with the balance board, pack, cables or connectors. Its best to match the wiring mode to your board. If the charger is not seeing the correct voltages on balance port and the total does not match the pack voltage, the error is reported. I'd use a DVM to check that each cell is read properly at the connector that goes into the charger.
Jul 27, 2014, 11:55 PM
Registered User
Yep, so I thought. That's why I used a different pl6 with all the same cabling, board, battery, and it worked fine.
Jul 28, 2014, 06:07 AM
Southern Pride
everydayflyer's Avatar
It could be dirty /oxidized balancing connection on the charger. First thing I do when I get any such errors is reach for my can of Deox It D5 and spray all connections, connects and disconnect several times ,spay again and then retry.
Jun 20, 2018, 09:45 AM
FPV Recon
Altimat's Avatar
I have the same bad cell count problem consistently with one of my PL6s. Tried the D5 and moved the pack, charge cables, and balance board/cable to the other PL6 multiple times and that charger has no issue.

It ramps up charge power to about 4 amps then starts back down and to the error.

Do I need to send it in or could a firmware upgrade correct this?

TIA for any help.


Quick Reply
Message:

Thread Tools