Help – I Can’t Get it UP - RC Groups
Thread Tools
Apr 15, 2004, 06:25 PM
A man with too many toys

Help – I Can’t Get it UP

Patrick – HELP !

I just updated the software with my PHX-Link and my helicopter will not fly!

I changed nothing except the software and it spooled up to about 30% head speed and no more?

I programmed the High governor mode and I get a little more head speed – about half of full throttle. The full throttle LED never comes on. I tried the fixed throttle mode and it works but seams not to have a very soft start as the governor mode?

I have a Phoenix-35 running a Mega 16/15/3 and use the low governor mode.

HELP I can’t fly my helicopter!
I usually go out and do a little flying every evening – but not tonight!

1.01 software
soft cutoff
high governor, low governor
standard advance
Sign up now
to remove ads between posts
Apr 15, 2004, 08:14 PM
A man with too many toys
Has anyone else tried the governor mode with 1.01 software?

What the PHX-Link is a way to download and save the old software so you can always go back to a version that worked for your particular setup.

Apr 16, 2004, 10:11 AM
Registered User
Patrick del Castillo's Avatar
RC Man -- the RPM levels are a little different on different software, but there is no upper limit to the high governor mode.

How do you have your transmitter setup? You should be using a flat curve for the throttle.

You might try pumping up your ATVs to allow more RPM.

Apr 16, 2004, 10:58 AM
A man with too many toys
I reloaded all the software this morning and tried it again. Same results!

I increased the ATV to the max of 140 (Futaba 8UHFs). It ran a little faster but still not up to the point where the LED comes on. I measured the head speed and computed the motor rpm 1880 * 281 / 14 = 37,735.

I think this version has a real bug in the governor mode.

With my helicopter Eolo with 14t pinion and 4s LiPo the motor rpm should be in the 42,000 to 43,000 rpm range. My old setup would work at 85%.

My Phoenix is about 6 months old.

Apr 16, 2004, 12:20 PM
Always right
Hovertime's Avatar
Rc-Man - I have tried it last night on micro 10 razor setup and all is good?
Apr 16, 2004, 12:23 PM
Always right
Hovertime's Avatar
RcMan- did you upload 1.01 BETA?
That version was not allowing me to get up to rpm either, make sure you get 1.01 revised.
Last edited by Hovertime; Apr 16, 2004 at 03:47 PM.
Apr 16, 2004, 03:38 PM
A man with too many toys
I have the latest version. In fact I just uninstalled and reinstalled the latest version this morning to make sure I had the latest software.

It looks like the upper limit with a 6-pole motor (Mega) will not allow enough motor rpm (43,000).

Patrick is there any to get the upper limit bumped up on the next version or will I have to send it in to you to fix the problem.

Apr 19, 2004, 06:16 AM
Knight of Ni-wom

same deal

Hey guys,

I have the EXACT same problem as RC Man does with my Hornet.

My setup is an original Hornet CP powered by a razor v2 micro-heli (and yes, its is one of the performing razors), an 8 cell powerex pack, and a PH10 dated 8/12/03.

I am using the 1.01 software straight off the site, and I've tried just about every combo I can think of setting wise... governor mode just gives HORRIBLE rpm's no matter what... low gov maxes out at about 1000 rpm or less, high mode perhaps at 1500, and this is at 100% throttle setting. In fixed mode the RPM is better, but startup doesn't seem to matter much...not soft at all.

Before the update installed by the link software my heli flew just fine with 2100 RPM at 73% throttle in high gov mode.

I'm in the middle of upgrading to Lipos so im not too worried about getting this fixed immediately, but I sure would like to know what the problem is.

Apr 19, 2004, 09:11 AM
Registered User
Patrick del Castillo's Avatar
Hi Guys,

As far as I know there were no changes to the governor modes at all since last August. But we might have broken something accidently. I'll check it out today and we'll fix it up.

Apr 21, 2004, 09:14 AM
A man with too many toys

Are you making any progress on the governor problem.

I would really like to get this thing back in the air!

Apr 21, 2004, 11:39 AM
Always right
Hovertime's Avatar
RC Man did you try to upload older 1.0 version?
Im gonna spool my logo upp today see if something went wrong with version 1.01.
Apr 21, 2004, 01:36 PM
Always right
Hovertime's Avatar
Well checked mine and everything is fine, RPM as before.
Maybe its different with different Phoenix? I use older bigger double boarded phoenix45. My usb link "sees" it as phoenix 35/45 (F221).
Can it be that you have uploaded wrong software to your phoenix?
Apr 21, 2004, 02:33 PM
A man with too many toys
I loaded V1.00 software 35/45 (F221).

The governor modes work it’s just that the motor never comes up to full rpm.

I think it is a limitation with 6-poll motors running at high rpm.

Patrick – I check the date that I got the controller and it was late September 2003. It was sent in for a software update at that time.
Apr 21, 2004, 02:45 PM
Always right
Hovertime's Avatar
RC Man- if its not typo and you have V1.00 - you NEED V1.01, and it will solve your problem !!!
Apr 21, 2004, 05:45 PM
Knight of Ni-wom

I have the same problem as RC man (only with a Razor motor instead) and the problem is defenitely not solved with version 1.01
The razor microheli is a 4 pole motor, so the problem doesn't seem to be limited to 6 pole motors either.

I would actually like to get ahold of a version 1.00 software to see if that would change anything, so if anybody has a copy, let me know!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Can't get escs to sync up through librepilot Minwards Beginner Multirotor Drones 8 Mar 19, 2017 11:03 PM
Discussion I can't get it up PasQuad Beginner Multirotor Drones 11 Sep 22, 2016 06:15 PM
Help! Eachine Racer 250 and Turnigy 9x r/c, can't get rate switch set up lookatmeow Multirotor Drone Talk 2 Feb 23, 2016 12:40 AM