Thread Tools
Apr 06, 2004, 12:10 PM
Registered User

RX or TX Poblems?


I'd like to go and fly but my rx isn't responding to any control input. when the servos are plugged into the rx and I then plug the rx in and the servos twitch whioch is normal so I know that the servos are getting power, but when I try to make any input, nothing happens. Has this happend to anyone before? Any help is appreciated!
Sign up now
to remove ads between posts
Apr 06, 2004, 12:58 PM
Registered User
It's happened to loads of people. What you really need is another receiver, xtals etc. to find out what has failed by swapping things around til it works.

Most likely failure is Rx xtal, followed by Rx.

Have you checked that everything is plugged in right, and the tx and rx are on the same channel. (The oldest mistakes seem to be the most popular!)

Stuart
Apr 06, 2004, 01:42 PM
Registered User
How do I make sure they are both on the same channel? Just an FYI, I have a JR Max 6 system, I don't know if your familiar with that. Do i change the channel with the tx? Thanks for your help!
Apr 06, 2004, 03:12 PM
Registered User
Both the transmitter and receiver have crystals which control the channel they are working on. They both have to have the same channel number.

Has this set up worked before ? If so what has changed ? What sort of receiver is it ? What type of model, electric or glow ?

Steve
Apr 06, 2004, 09:22 PM
Registered User
The set up has been working fine. I took the xtal out of the receiver just to see what it looked like and I might have put it in backwards and I tried it and it didn't work. Could that have messed it up? I then switched it around and it still didn't work. It's a glow model and its the NER-627X 7 channel receiver. Thanks!
Apr 07, 2004, 03:08 AM
Registered User
Crystals aren't polarised so it doesn't matter which way round you plug them in. However they are easy to damage if you drop them or bang them on anything.

It would be worth taking the crystal out again and replugging it VERY CAREFULLY. There are quite a few receivers where it can look like the crystal is plugged in but it has actually missed the internal connectors altogether. You need to sort of feel how it connects up inside.

Unfortunately you seem to be proving the old saying "If it ain't broke don't mess with it"

Steve
Apr 07, 2004, 08:56 AM
Registered User
I feel like an idiot, (if I just didn't mess with it...) Well I tried what you said and it just doesnt work still. Could it be anything else or should I get a new xtal?
Apr 09, 2004, 09:02 AM
Marion
Is it possible that you changed the servo connections? Sometimes servos will twitch at power application, even if they are plugged in backwards. I have seen lots of experienced flyers -- including me -- plug servos in backwards. It causes no harm -- just confusion.

Of course, if the receiver and transmitter are not on the same channel, then nothing will work :-(
Apr 09, 2004, 05:08 PM
Registered User
that was one of the first things I tried when I was trying to fix it. I'm going to get a new xtal for the rx this evening and see if thats what the problem is, I have a hunch it is. Thanks for your response! ExploreR