Revolectrix FUIM3 USB Driver Issues - RC Groups
Thread Tools
Feb 16, 2014, 03:34 PM
Registered User
Discussion

Revolectrix FUIM3 USB Driver Issues


Hello all!

I am trying to attach my Cellpro 8 charger to my Win 7 32 bit laptop. I have downloaded the charger software, and from there I have downloaded the drivers for the FUIM3 USB device, but I keep getting a message the the USB device isn't recognized. I see an Error Code 43 when I go into device manager and look into the un-recognized USB device. I googled the code 43, and tried some of the suggestions to fix it, but no luck there either.

I have been working at this for about 3 hours now and nothing that I have tried has worked. I have uninstalled and reinstalled the charging software as well as the drivers. The FUIM3 isn't plugged into the laptop while I'm installing the drivers per the FAQ from Revolectrix. I have googled all other possible issues that I can think of, read through a number of threads of similar issues and nothing has worked yet.

Edit: Things that I have tried to resolve the issue:

I can download and install the CCS with no trouble. The program appears to open and run with no trouble.

From CCS, I click on the link to download the FUIM3 drivers. The FUIM3 device is NOT plugged into the computer at this point. Once the driver is downloaded, I open CCS back up, plug the FUIM3 into the computer USB port and I get an error message saying that the computer is unable to recognize the device. The error code is Error 43. Also, the circuit board of the FUIM3 never shows any lit LEDs.

I have tried many things with the same results as above, but I will list them for the sake of trouble shooting.

-I have uninstalled and reinstalled both the CCS and the FUIM3 drivers many times.

-I have restarted the computer between CCS, and FUIM3 installs.

-I have updated the .NET to the most current version.

-I have tried all USB ports on the laptop.

-I have tried installing the FUIM3 drivers with both the FUIM3 device connected, and not connected to the computer.

-I have made sure that I am not installing the FUIM2 device drivers.

-I have followed the Revolectrix FUIM3 driver installation FAQ to the T multiple times.

-I have tried plugging the FUIM3 into the PowerLab8 (that is powered) before I plug it into the computer.

-I have tried a number of things that have been found to resolve 'Code 43' USB error codes.

-I have searched extensively on the net for other resolutions to the issue, and followed their advice which is pretty much included in the items tried above.

I have done all the things listed above with no success. If anyone has any ideas of something else to try, I'm all ears.

Thanks again!
Last edited by advblane; Feb 16, 2014 at 11:56 PM.
Sign up now
to remove ads between posts
Feb 17, 2014, 02:28 PM
Revolectrix Ambassador
You may have tried these things already, but I will just throw them out there in case they are helpful.

1) Disconnect all USB devices from the laptop. Then power off the laptop. Remove the battery (if you can) and let the laptop sit unpowered for at least 5 minutes. Put the battery back in and power up. Connect the FUIM3 before connecting any other USB devices. Check the status in device manager.

2) Try a different USB cable.

3) Try the FUIM3 on a different PC or laptop if you have one. I realize that may not be an option.

4) Long shot here, but verify you have a FUIM3 and not the FUIM2. Pictures on the bottom.
http://www.revolectrix.com/new_appli...re/pc.usb.html
Feb 17, 2014, 02:47 PM
Registered User
traxx de maxx's Avatar
I normally find i plug in the charger the wrong way.
Feb 17, 2014, 08:55 PM
Registered User

Fixed!!!


I tried everything posted as suggestions, save for the one thing that I didn't think would make a difference. I open the cord drawer and dig for another USB cable. I find one, for a Garmin GPS. I plug it into the FUIM3, then plug it into the computer and just like that the drivers load followed by the red light on the PCB lighting. I couldn't believe my eyes. Thank you so much, traxx!! I can't thank you enough. It really is hard to believe that it was something so simple after I had tried so many other, more complicated solutions.

Now that the cable works, I have used the CCS while I was charging a battery and it is truly awesome. The software seems to add a bunch of functionality and flexibility.

Thanks again, everyone. This forum makes so many things possible.
Feb 17, 2014, 11:51 PM
Revolectrix Ambassador
Good deal. Glad to help. Before you dispose of that cable, if you have an iCharger it may be the one that comes with that unit. Its a special USB cable with the ground removed. You'll need it for the iCharger. Otherwise might as well chuck it so it doesn't accidently get put back into service.
Feb 18, 2014, 08:04 AM
Registered User
Quote:
Originally Posted by Gregor99
Good deal. Glad to help. Before you dispose of that cable, if you have an iCharger it may be the one that comes with that unit. Its a special USB cable with the ground removed. You'll need it for the iCharger. Otherwise might as well chuck it so it doesn't accidently get put back into service.
I have a Revolectrix CellPro 8, so I think that I'll toss the bad USB cable.

Thanks again, everyone!!
Jun 29, 2014, 08:21 AM
Registered User
laquival's Avatar

Experienced the same ordeal... BUT rcgroups.com Forums saved the day ! ! !


Quote:
Originally Posted by advblane
Hello all!

I am trying to attach my Cellpro 8 charger to my Win 7 32 bit laptop. I have downloaded the charger software, and from there I have downloaded the drivers for the FUIM3 USB device, but I keep getting a message the the USB device isn't recognized. I see an Error Code 43 when I go into device manager and look into the un-recognized USB device. I googled the code 43, and tried some of the suggestions to fix it, but no luck there either.

I have been working at this for about 3 hours now and nothing that I have tried has worked. I have uninstalled and reinstalled the charging software as well as the drivers. The FUIM3 isn't plugged into the laptop while I'm installing the drivers per the FAQ from Revolectrix. I have googled all other possible issues that I can think of, read through a number of threads of similar issues and nothing has worked yet.

Edit: Things that I have tried to resolve the issue:

I can download and install the CCS with no trouble. The program appears to open and run with no trouble.

From CCS, I click on the link to download the FUIM3 drivers. The FUIM3 device is NOT plugged into the computer at this point. Once the driver is downloaded, I open CCS back up, plug the FUIM3 into the computer USB port and I get an error message saying that the computer is unable to recognize the device. The error code is Error 43. Also, the circuit board of the FUIM3 never shows any lit LEDs.

I have tried many things with the same results as above, but I will list them for the sake of trouble shooting.

-I have uninstalled and reinstalled both the CCS and the FUIM3 drivers many times.

-I have restarted the computer between CCS, and FUIM3 installs.

-I have updated the .NET to the most current version.

-I have tried all USB ports on the laptop.

-I have tried installing the FUIM3 drivers with both the FUIM3 device connected, and not connected to the computer.

-I have made sure that I am not installing the FUIM2 device drivers.

-I have followed the Revolectrix FUIM3 driver installation FAQ to the T multiple times.

-I have tried plugging the FUIM3 into the PowerLab8 (that is powered) before I plug it into the computer.

-I have tried a number of things that have been found to resolve 'Code 43' USB error codes.

-I have searched extensively on the net for other resolutions to the issue, and followed their advice which is pretty much included in the items tried above.

I have done all the things listed above with no success. If anyone has any ideas of something else to try, I'm all ears.

Thanks again!


Like the multitude of other users of this product, I'm the Excited Owner of a brand-new Cellpro PowerLab 8 v2 EC5 Combo 7 (Combo with MPA and FUIM3) from Singapore Store...

The excitement and elation that normally accompanies the arrival of a brand-new 'thing ' was sadly cut short...

Why?

I experienced the same 'ordeal' that advblane suffered and went through ...

I immediately filed an online case following the instructions found on this site: http://www.revolectrix.com/support_options.htm

"To initiate a case directly on line for any of the above:

1. Log on to your account at www.store.revolectrix.com
2. Click the "My Account" tab
3. Under Support, click "Contact Support"
4. On the case form, enter a subject which contains the product name, part number, or description
5. Type a message in the message field
6. The fields on the top right of the form are optional
7. Click Submit

A customer representative will contact you via email."

I was pleasantly surprised that Revolectrix / FMA did make contact in a very short while indeed...

The 'remedies prescribed' was followed to the letter-- BUT sadly, to no avail...

Combing through Revolectrix website, I stumbled upon a link to rcgroups and came across the Thread: (https://www.rcgroups.com/forums/show...hp?t=2106087);

Gregor99's prescriptions: "Item 2- Try a different USB cable." -- DID THE TRICK ! ! ! for my case problem...

Now, I hope that Revolectrix's Singapore Store can send me a replacement USB cable since I could not do my 'SIMmming' while doing my battery charging since I pulled out the USB cable from my SIM and plugged it to FUIM3 PC USB Interface and made it work.



NOW, I'M ALL SMILES AGAIN ! ! ! --- since I AM CONFIDENTLY CHARGING MY BATTERY PACKS WITH A SUPERIOR PRODUCT...

Hey! ! ! REVOLECTRIX / FMA --- do not let your GREAT PRODUCTS be undermined by a third party item like the USB cable that was sent with my brand-new Cellpro PowerLab 8 v2 EC5 Combo 7 (Combo with MPA and FUIM3) from Singapore Store ruin the whole unit...

Do a Pre-delivery checking of the USB cable before shipping to customers, PLEASE!

P.S.: CAN YOU PLEASE SEND ME A REPLACEMENT USB CABLE? A WEEK-OLD COMBO UNIT IS STILL COVERED BY THE WARRANTY, RIGHT?!!! CHEERS / THANKS RCGROUPS!
Jun 29, 2014, 01:54 PM
Revolectrix Ambassador
Good report. Glad this thread was helpful.
Oct 25, 2017, 01:07 AM
Registered User

Still an issue!


It is now 2017, and my new FUIM3 delivered today, included a faulty USB cable - luckily I had another one readily available to test this issue. Revolectrix, you really need to do something about this. Now I need to go buy a replacement cable.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Revolectrix FUIM3 USB Driver Issues advblane Batteries and Chargers 2 Feb 16, 2014 03:33 PM