Thread Tools
Old Nov 21, 2013, 08:27 PM
ryan.overleese is offline
Find More Posts by ryan.overleese
Registered User
Discussion

Naza M V2 Issue with Aileron


I just finished all of the soldering and connecting of wires on my new F450 with Naza M V2. I have a Devo 10 controller which I used on my old F450 with Naza M V1. When I first plug into Naza assistant, I get a CFG Error: "Configuration error, this may cause by firmware upgrade from old version.or abnormal Tx calibration. Re-calibrate your transmitter,and power cycle your controller and check all of the parameters." Then when I turn on the Tx, I get this Error[29]: "Motors Start failure caused by TX stick(s) mid point error too bigIf the TX stick(s) mid point error is too big, Motors Start will fail when you execute the Combination Stick Commands (CSC) and lead to the aircraft will not takeoff.. And the LED will blink Red four times per second continually to warn you.
TX stick(s) mid point error too big can be caused by the following reasons:
(1) There is TX stick (except the throttle stick) not at center when power on the autopilot system.
(2) The TX sticks has been trimmed, which leads to the large deviation of mid point. For example, the SUB-TRIM has been adjusted for Futaba transmitter.
(3) The TX stick(s) travel has larger asymmetry.
For the reason (1), please put all TX sticks at the mid point, and then power cycle the autopilot system to re-record the mid point. If the problem continues, that can be caused by the reason (2) or reason (3), you need to adjust the output range of your TX, and then use the Assistant Software to redo the TX calibration. Please carry out the following procedures.
(1) Connect to the Assistant software, click Basic-> R/C-> Command Sticks Calibration, and push all TX sticks throughout their complete travel range to see if any stick cannot reach its largest position.
(2) Adjust the largest travel of TX stick until the cursor on the Assistant software can reach both end positions, according to your TX manual.
(3) Power cycle the autopilot system, note that power cycle is required.
(4) Redo the TX calibration according to the Assistant software."

I cannot find any problems anywhere. When I try to calibrate the sticks, I cannot get the Aileron slider to move in either direction as it is stuck in the middle. I have switched stick modes on the Tx to see if the issue was a bad connection in the controller but no matter what stick or direction I have programmed, the Aileron slider will not move left or right. It is very frustrating since the stuff is brand new but I am not sure if I am just missing something when it comes to binding the controller, or what the real issue is. I need some help. Thanks all!
Sign up now
to remove ads between posts
Old Nov 29, 2013, 01:00 PM
Dagger one is offline
Find More Posts by Dagger one
Registered User
I am experiencing the same problem, but in my case it is stuck at full aileron to the left. But when I set the stick to full right it moves to the middle. Until now I have been able to fly if I disconnect the servo cable for the aileron before I power up the quad and than afterwards connect it again. But that is not good enough solution. Have you found something out?
Old Jul 24, 2015, 09:21 PM
dcg9381 is offline
Find More Posts by dcg9381
Registered User
I have this too, but re-binding seems to re-set the center telemetry... Having figured it out yet.
Old Jul 30, 2016, 03:33 AM
irishluck is offline
Find More Posts by irishluck
Registered User
Im having an issue with this myself. Just put together a hexacopter with the new V2. Im using a taranis -plus TX.

i go to calibrate the TX and I had to move the inputs around on the mixer because usually a CC3D using sbus has the throttle input on channel 3. So when I moved the aileron to channel 1, the stick is stuck to the far right, when I move the stick to the left on my TX it just goes to the center. I changed the offset on my tx to -100 which moves the little slider to the center on the installer but still cant get the slider to move to the left.

Has anyone figured out a solution to this?

Solution found:
Tap the FC with your finger or on a table to unstick the gyro. It worked for me last night.
Last edited by irishluck; Jul 30, 2016 at 12:31 PM.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Naza M Lite Hardware with Naza v1/v2 software? jgerlitz Multirotor Electronics 6 Sep 12, 2016 05:40 AM
Discussion New Firmware of DJI IOSD Supports Naza-M/Naza-M V2 Now! DJI INNOVATIONS Aerial Photography 3 Feb 08, 2014 12:10 PM
Discussion Naza-M V2 setup issues on Discovery Pro tom3holer Multirotor Talk 4 Nov 05, 2013 03:58 PM
Discussion Naza V2 versus Naza M (v1) with updated firmware Jelico Multirotor Talk 3 Jun 05, 2013 05:43 AM
New Product Naza M V2 vs Naza M V1 Thumper1 Multirotor Talk 6 May 31, 2013 12:59 PM