GoodLuckBuy Gimbal Troubles - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Nov 17, 2013, 03:28 PM
Registered User

GoodLuckBuy Gimbal Troubles

I know this is probably like beating dead horse but i too have now fallen into the trap of Goodluckbuy. Got my gimbal in the other day hooked it up to the phantom Aux Power and started it up. everything seemed fine however the pitch motor does not Move/respond. i checked all the wiring everything seems sound, i even switch the motor inputs just to check if the pitch motor even worked. When i did this the motor powered on and moved a bit so i know the motor itself isnt bricked. I tried the software route but im stuck. All my research points to reflashing the martinez v2 firmware/Updating the software and what not. but I cant get any of these drivers to work that enable my computer to identfy the martinez board when i plug it in to the usb.Im trying to get these drivers to work from this site . but nothing seems to work. Does anyone have any ideas? im stuck i just want this thing to work.In the video i attached i dont have the gopro on the gimbal due to the fact i had to use it to make the video.However the gimbal behaves more or less the same with or without the gopro
GOPR0047 (0 min 40 sec)
Sign up now
to remove ads between posts
Nov 17, 2013, 04:57 PM
It looks like the pitch PID is set to 0 or something (when its 0 it won't move and will 'lock' in a position).. post screenshots of the gui/config because the roll looks fine.. if it reacts backwards change the motor direction (swap the 3pin cable the other way if it has one)

The drivers are easily available on the internet, do some searching! This page has some links to 32 and 64bit versions
Nov 17, 2013, 05:11 PM
Registered User
Thats the second part of the problem. i cant find any drivers/programs that will detect the martinez board so i can use the software to edit values. im using the micro usb to usb plug on the side of the board.
Nov 17, 2013, 05:39 PM
The link i posted above has some, have you tried them? Half way down the page it says:

32-bit drivers here. 64-bit. you will have to force install the drivers . Do not do use windows update.
Nov 17, 2013, 09:55 PM
Registered User
Thanks sorry didnt read your post correctly was running out the door. im going to try these drivers out and see whats happens. As far as searching ive been doing nothing but for the last few days.
Nov 18, 2013, 01:13 AM
Registered User
This gimbal will never fly.
Last edited by Dr.Blackbear; Nov 18, 2013 at 02:05 AM.
Nov 18, 2013, 03:46 AM
Originally Posted by Dr.Blackbear
This gimbal will never fly.
Why do you say that? They are a pain to set up that's for sure!
Nov 18, 2013, 11:50 AM
Registered User
i finally got a driver to load and now the board is recognized as a com port. one step foward,but now the gui is not recognizing it.even with matching com ports. serial error it says. so im going to spend the next few hours after work trying to figure out what is wrong.
Nov 18, 2013, 12:14 PM
Registered User
1. you need to have your gopro in the gimbal - it WON'T WORK CORRECTLY without the camera attached. It needs to be balance.

2. Ignore the advice regarding the martinez drivers. This gimbal uses hacked alexmos v2.2b. Download the GUI from here:

3. The gimbal works great
Nov 18, 2013, 02:55 PM
Registered User
I realize the gimbal will not perform correctly without the gopro,but as i stated before i needed to take it off to film the problem. thanks for the link tomtnt ill try out this gui when i get home.
Nov 19, 2013, 12:43 AM
Registered User
After hours of messing around with my gimbal/software, I think my motor 2 output is shot on the board.If i reverse the outputs to the motors via software and reverse the plugs on the board itself. my pitch motor will work/track perfectly. If i keep it stock setup- plugs in right place/out puts to motor in right place only my roll motor will work/track perfectly. i can get each motor to perform its job perfectly just not together. I think this ship sank before it sailed.
Last edited by Dr.Blackbear; Nov 19, 2013 at 12:59 AM.
Dec 25, 2013, 03:58 PM
Registered User
Hi all,

I am also in a similar position to the OP. My goodluckbuy 2-axis brushless gimbal worked fine out of the box but started acting weird after a couple of crashes. Now it wobbles all over the place and no amount of tweaking in the SImpleBCG GUI seems to help. If anything it is worse.

1. I downloaded and installed the GUI software 2.2b, and the drivers to connect the USB cable.
2. I connected the gimbal and it seems I have board version 1, firmware 2b2 so the GUI can talk to the control board.

I found the original PID settings from the net for this gimbal model 98390 and put those in after I hit set to default by accident. See attached file.

Since then things have just gone from bad to worse. No amount of calibrating seems to make any difference. I have put in many hours on this and it's driving me nuts!

Do I need to flash the firmware or something? If so, how do I do this?
I tried using the Xloader to get the 2.2b hex file but everytime I press "Flash" it starts to write and then I get an error message. Even if I upload the 2.2b hex file straight and try to flash I get the same thing.

What am I doing wrong? Any suggestions or solutions would be greatly appreciated!
Dec 25, 2013, 04:08 PM
Registered User
Last edited by Finncelt; Dec 25, 2013 at 04:13 PM. Reason: doublepost
Dec 26, 2013, 02:21 AM
Registered User
Here is the link for the default settings for your gimbal.
Dec 30, 2013, 10:51 AM
Registered User
You can not update firmware
You need nulled firmware
In other words you just bricked your gimbal

Dont ask ne how I know
Last edited by wippo76; Dec 31, 2013 at 07:26 AM.

Thread Tools