Thread Tools
This thread is privately moderated by BladeScraper, who may elect to delete unwanted replies.
Oct 24, 2013, 06:28 PM
Custom User Title
Thread OP
Discussion

Why my BL was flying so odd...


I figured out why my BL flew odd, especially with the 130X blades.

After crashing due to my BL flying very weird and randomly, I decided I was tired of the heli flying so funny. So I took the head off, and began disassembling it. Almost immediately after taking off the swash I realized what was wrong:

The swash balls connecting to the blade grips were about to fall out! They had slowly backed out of the swashplate, and were extremely loose allowing several degrees of blade pitch, completely uncontrollable. The bigger 130X blades made this effect even worse...

I reinstalled the ball WITH LOCTITE and immediately noticed less slop.

I had noticed before that one of the swash balls that the blade grip link connects to the blade grips came in contact with the rear servo ball links... but I first thought it was a manufacturing defect. It made a clicking sound every full spin, I thought it was no big deal.

Only now I realize that that is what was causing the BL to fly so erratically. I later flew again, and landed, and the OTHER ball (the one I didn't re-install) was lose. Now both as reinstalled with loctite.

Lesson learned:

ALWAYS CHECK METAL SWASHPLATES FOR PROPERLY TIGHTENED AND LOCTITED BALL LINKS!
Sign up now
to remove ads between posts


Quick Reply
Message:
Thread Tools