Thread Tools
May 20, 2017, 11:57 PM
Thread OP
What's interesting is that there are a few thousand of these things out there and you don't find a single post about a failure of anything except a broken push button.
Sign up now
to remove ads between posts
May 21, 2017, 05:25 AM
Registered User
Quote:
Originally Posted by JimDrew
What's interesting is that there are a few thousand of these things out there and you don't find a single post about a failure of anything except a broken push button.
Perhaps the video will shed some light ...
May 21, 2017, 10:56 AM
BigTradioman's Avatar
So here is the promised short video. All I would add is that when the unit first arrived a small pack was connected and the unit set for Futaba (2 flashes) then put away until I offered to give it away to a friend.

Xpander2 (3 min 25 sec)
May 21, 2017, 01:21 PM
Thread OP
Ok, per your video - the X10+ worked fine with the flight pack plugged in and you were able to program it. It was only after you soldered the heavy power wires to the board that it stopped working. Please take closeup pictures of the front and backside of the board, and post them here.
May 21, 2017, 01:45 PM
BigTradioman's Avatar

X10+ Channel Expander




The bottom has been coated with clear plasticote insulation.
May 21, 2017, 06:11 PM
Registered User
Pilot232's Avatar

X10+ Self inflicted issue


Jim

Here are a couple of pictured of my X10+ after a slip with a Dremel tool in an attempt to drill out too much solder in the Power Lead lands. My Bad!!
Believe it or not, it still works. I don't I trust it in an airplane, but it is still functional. Futaba transmitter. Please look at the pictures and make a recommendation for repair.

Warm Regards,

Travis

This is NOT my usual workmanship, but I was in a hurry. Never again. Every one else, have a good laugh on me.
May 21, 2017, 08:39 PM
Thread OP
BigT, clean the solder splatter from between the pads. It's entirely possible that the board will not start up with resistance (solder blobs) between the pads, but there is enough voltage available to power a receiver. I have seen this myself.

Pilot232, there is a reason why that works! What you destroyed were the capacitors for the crystal. When the X10+ powers up, the CPU trys to use the crystal. When it doesn't oscillate, which is definitely not happening in your case, it switches to an internal crystal. It's not as stable as the external crystal, but this is done (on all of our products) just in case there is ever a crystal failure due to vibration, extreme temperature (180+ degrees), and apparently Dremel too accidents. . Don't use that. You can return it for a new one.
May 21, 2017, 11:28 PM
Registered User
Pilot232's Avatar
Jim,

Many thanks for standing behind your products, even though it is entirely my fault. You would have to look far a wide to find another vendor who would replace the unit under these conditions.

My Hat is Off to you!!!

Travis
May 22, 2017, 01:48 AM
BigTradioman's Avatar

X10+ Channel Expander


Quote:
Originally Posted by JimDrew
BigT, clean the solder splatter from between the pads. It's entirely possible that the board will not start up with resistance (solder blobs) between the pads, but there is enough voltage available to power a receiver. I have seen this myself.

one.

I understand your instruction but I cannot see any solder between the positive and negative pads with the naked eye. I have taken a voltage reading from the servo rail and it is the same as the volts going into the pads and the other way round. I will remove the wires completely and report

EDIT
I have removed the supply wires and cleaned all solder off, I can see no "splatter". the board is still not working. I think what you interpreted as "splatter" was in fact air bubbles in the plasticote.

I have sent an email to request tracking details of the replacement board that was shipped on the 16th of May. I have had neither tracking info or the board. I am posting this message here as you said you did not receive any of my earlier emails.
Last edited by BigTradioman; May 22, 2017 at 12:07 PM.
May 22, 2017, 03:16 PM
BigTradioman's Avatar
Ok tracking details now received via email so now I know that comms system works
May 23, 2017, 11:16 AM
Registered User
Pilot232's Avatar

Payment


When I checkout in trying to pay for return shipping I can select either PayPal or Send Payment.
I do not have a PayPal account so I selected Send Payment. What form of payment do you accept (personal check, USPS money order)?

Warm Regards,

Travis
May 23, 2017, 02:52 PM
BigTradioman's Avatar
So replacement has now arrived today, 7 dYs, not bad, got stung for import duty so will challenge that. Now, the question is do I give this to my friend in a sealed packet and wish him good luck or do Se open it and try again? Answer, sealed packet wins!!
May 23, 2017, 03:03 PM
Foam abuser!
crxmanpat's Avatar
Please let us know when your friend opens it and tests it out. Would be interested to see how that goes.

I've got 4 of these in various planes, but power for all is supplied by an external BEC plugged into the battery port. I have not hard-wired power to any of them. They all work flawlessly.

Pat
May 23, 2017, 03:46 PM
Registered User
Quote:
Originally Posted by BigTradioman
So replacement has now arrived today, 7 dYs, not bad, got stung for import duty so will challenge that. Now, the question is do I give this to my friend in a sealed packet and wish him good luck or do Se open it and try again? Answer, sealed packet wins!!
I vote try it !!!
May 23, 2017, 07:49 PM
Thread OP
Quote:
Originally Posted by Pilot232
When I checkout in trying to pay for return shipping I can select either PayPal or Send Payment.
I do not have a PayPal account so I selected Send Payment. What form of payment do you accept (personal check, USPS money order)?

Warm Regards,

Travis
Hmm... Check, money order, or cash. I believe we can take anything.


Quick Reply
Message:

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question X10+ Expander with Nano - customer comments please... JimDrew Xtreme Power Systems 48 Sep 22, 2013 09:54 PM
Discussion Channel expander question Engineer Bill Xtreme Power Systems 9 Jun 24, 2013 05:08 PM
Sold Parkzone X10 6 channel transmitter Tampatexan Aircraft - General - Radio Equipment (FS/W) 0 Jun 10, 2012 07:15 AM
Sold Berg 5 channel receiver w/ 4 channel expander Fizzy Aircraft - General - Radio Equipment (FS/W) 0 Oct 02, 2008 05:52 PM