Thread Tools
This thread is privately moderated by iskess, who may elect to delete unwanted replies.
Aug 26, 2013, 02:26 PM
FPV in Hawaii
iskess's Avatar
Thread OP
Mini-HowTo

Connecting Bluetooth from the APM to Mission Planner


I have used this BT Module with the APM in lieu of the telemetry module and sucessfully linked it to Mission Planner on my Windows 7 laptop. I ran into a few complications along the way, maybe I can save you from them.

1) Go to the Bluetooth Devices and double click on the BT module > Hardware tab > Properties > Change Settings > Port Settings > Bits per Second to 57600.
Do NOT follow this path... Hardware tab > Propeties > Port Settings tab. You MUST go through that administrator Change Settings button. If you do directly to the Port Settings tab you will get stuck and your baud changes won't stick. You must also uncheck "Reset APM on USB Connect" under Configuration>Planner>APM Reset

2) If you get a "Connection Fail" error:
The secret is to disconnect the bluetooth module from its cable and reconnect it after getting the MP "Connection Fail" error. After this it worked, and so did the MinimOSD. I have not had to do this little trick ever since, just that one time and everything just works now.
I found this tip in this video at 11:47 of RCJose's Bluetooth Configuration Tutorial.
Sign up now
to remove ads between posts
Mar 11, 2014, 06:20 PM
Registered User

That doesn't work for me


I have a HK Pro Board 2560, a bluetooth module HB01 and i can not connect the board to MP on a PC running windows7.
The quad board is running MegapirateNG V1.0.3
I tried what you say: i set the connection on 115200 bauds which is the speed of my bluetooth device, i unchecked "reset APM on USB connect" in the Mission Planer config.
I always get a connection fail. I also tried to disconnect and reconnect the bluetooth module after getting a first connection fail.
If i test the bluetooth connection between the BT module and the PC using a terminal, it works. It seems that MP makes the problem.
Help please
Mar 12, 2014, 02:53 PM
Registered User
Quote:
Originally Posted by kartman
I have a HK Pro Board 2560, a bluetooth module HB01 and i can not connect the board to MP on a PC running windows7.
The quad board is running MegapirateNG V1.0.3
I tried what you say: i set the connection on 115200 bauds which is the speed of my bluetooth device, i unchecked "reset APM on USB connect" in the Mission Planer config.
I always get a connection fail. I also tried to disconnect and reconnect the bluetooth module after getting a first connection fail.
If i test the bluetooth connection between the BT module and the PC using a terminal, it works. It seems that MP makes the problem.
Help please
Hello,
This seems to be the accepted way to go to get your BT to connect. I have the same BT unit and can never get it to connect via Windows, but my Android connects every time. So use port 0 and make sure rx and tx are crossed over. Don't worry about unticking the "reset APM on USB connect". With no power applied to the quad, press connect on mission planner after checking your connection port. Use 115000 connect speed ( because this is what port 0 is set to ). PRESS CONNECT , Wait 15 seconds then plug the quad into power and it will connect. Unfortunately you will have to do this each time you connect via BT. Now if you want to connect via usb, remember to pull the plug from the BT module. The parallel connection on this bus can cause a drop out on connection via usb. Hope you get it going.
Mar 19, 2014, 04:27 PM
Registered User
Just tried it the way iskess noted it, and it works like a charm , thanks !
Mar 20, 2014, 09:35 PM
FPV in Hawaii
iskess's Avatar
Thread OP
I'm very pleased that I was able to help keep someone from going through the frustrations I experienced.
Mar 29, 2014, 01:52 PM
RC pilot by soul
Quote:
Originally Posted by iskess
I have used this BT Module with the APM in lieu of the telemetry module and sucessfully linked it to Mission Planner on my Windows 7 laptop. I ran into a few complications along the way, maybe I can save you from them.

1) Go to the Bluetooth Devices and double click on the BT module > Hardware tab > Properties > Change Settings > Port Settings > Bits per Second to 57600.
Do NOT follow this path... Hardware tab > Propeties > Port Settings tab. You MUST go through that administrator Change Settings button. If you do directly to the Port Settings tab you will get stuck and your baud changes won't stick. You must also uncheck "Reset APM on USB Connect" under Configuration>Planner>APM Reset

2) If you get a "Connection Fail" error:
The secret is to disconnect the bluetooth module from its cable and reconnect it after getting the MP "Connection Fail" error. After this it worked, and so did the MinimOSD. I have not had to do this little trick ever since, just that one time and everything just works now.
I found this tip in this video at 11:47 of RCJose's Bluetooth Configuration Tutorial.
Hello my friend,

im trying your method with no luck as of yet. so a few questions:
1. which baud rate did you configure the module to? 57600?
2. when i connect it via USB i get 2 com ports - is that OK and which one should i pick?

right now both of them dont connect, and i did what you described step by step carefully.

thanks.
Jun 30, 2014, 12:38 PM
Registered User
Quote:
Originally Posted by flierman1945
Hello,
This seems to be the accepted way to go to get your BT to connect. I have the same BT unit and can never get it to connect via Windows, but my Android connects every time. So use port 0 and make sure rx and tx are crossed over. Don't worry about unticking the "reset APM on USB connect". With no power applied to the quad, press connect on mission planner after checking your connection port. Use 115000 connect speed ( because this is what port 0 is set to ). PRESS CONNECT , Wait 15 seconds then plug the quad into power and it will connect. Unfortunately you will have to do this each time you connect via BT. Now if you want to connect via usb, remember to pull the plug from the BT module. The parallel connection on this bus can cause a drop out on connection via usb. Hope you get it going.
Oh wow thanks. I was pulling my hair out well whats left. I now have a Win7 connection via bluetooth to my litle 250 quad. I was able to connect with any of my android devices but not either of my PC's Thanks
Aug 27, 2014, 12:50 PM
Registered User
Hello everyone,

I was also going crazy with this setup.

I had my HK Multiwii/Megapirate MEGA AIO board with Crius_BT (bluetooth interface) working perfectly with Multiwii 2.3 Firmware.

After loading Megapirate was facing the same problem of "connection error".

I have tried :
1) Change BT Baud rate to 57600 (and change it too on Megapirate source code as Serial 0 is 115200 by default).
2) tried with Megapirate version 3.0.1 R4 and 3.1.5 R2
3) tried with windows 8 and windows Vista

What ended up working for me was just to uncheck the "reset APM on USD connect" on config/planner tab.

Thank you ISKESS for your share!
Sep 04, 2014, 10:49 AM
Registered User
Hi, I have changed successfully the baudrate of the BT module using a terminal. But I am not sure about parity and stop bits. They are sopposed to be 0, thus the command should be:
UART:57600,0,0
Correct?
Many thanks.
Sep 08, 2014, 02:19 PM
Registered User
Hello,

I just used a command that changes Baud, not other parameteres like number of data bits or stop bits

I followed this instructions
Bluetooth module configurations
For advance users who wish to customize their Bluetooth module configurations, this tutorial shows you how this can be done.
You will need to connect the bluetooth module directly to your PC through serial interface. Since these days hardly any PC has serial interface, a USB-to-RS232 converter like the one below may be used.

Connect this module to the Bluetooth module according to the table below
Bluetooth module USB to Serial Module
Vcc Vcc
GND GND
TXD RXD
RXD TXD
While configuring the bluetooth module, it shouldn't be connected wirelessly with any other bluetooth devices, so switch off the bluetooth of your PC and/or smart phones.
The default settings of the Bluetooth is:
Baudrate: 9600
Name: linvor
Pairing code: 1234
Any changes to the above configurations will be saved even when power is off.
All the commands sent to the Buetooth must not contain a 'newline' character at the end, puTTY doesn't do well in this regards. Hence we recommend using the 'Serial Monitor' in the Arduino IDE to configure the Bluetooth module. The procedures are as follows:
1, connect the Bluetooth to the pc, the LED should be flashing
2, If you have an Arduino board connecting to the pc via USB, please unplug it.
3, Launch the Arduino IDE (the program where you write Arduion code and download to the Arduino)
4, select the correct COM port that the Bluetooth is connected to.

5, Open the 'Serial Monitor'

Once the Serial Monitor pops up, make sure the 'no line ending' is selected. To test the communication between the Bluetooth and the PC, send the command AT (case sensitive), and hit the 'Send' button, the Bluetooth should reply 'OK'

If you can get the Bluetooth to reply, you are ready to configure the Bluetooth module to your preference!




Change the Baudrate
The example below shows how to set the baudrate to 4800 bps
Send the command (case sensitive!)
AT+BAUD3
the Bluetooth will reply:
OK4800
As shown in the figure below

Now, since the Baudrate of the Bluetooth has been changed, you need to change the Baudrate of the terminal program to 4800 in order to talk to the Bluetooth again.
The index after the command AT+BAUD corresponds to the following Baudrate:
1----1200bps
2----2400bps
3----4800bps
4----9600bps
5----19200bps
6----38400bps
7----57600bps
8----115200bps
9----230400bps
A----460800bps
B----921600bps
C----1382400bps
The change of Baudrate takes effect immediately after the command is sent. So if you want to keep configuring the Bluetooth module, you need to set the Baudrate of your terminal program to the new Baudrate the Bluetooth is using. To test it, send AT again, you should receive 'OK'.
NOTE: some MAX 232 chips cannot work reliably for Baudrates faster than 115200bps, therefore, we don't recommend to set the Bluetooth to a Baudrate that is faster than 115200bps.
Nov 25, 2014, 02:28 PM
Registered User
I think the problem under windows 7 and 8 is the BT connetion.

I have configured my CRIUS BT device and it works under Android MissionPlanner

Then I have tried under Windows 8, I paired the BT, two com ports appeared but MissionPlanner did not want to connect do APM via BT.
What I noticed is that the led on the BT module is blinking all the time, it means that system does not even try co connect to BT module.

Then I made a shot under Windows XP. Same effect under MissionPlanner. But then I went to blue tooth settings and there I clicked on the BT device and it connected, LED on BT went to solid red. Then I run MissionPlanner and connected to the APM without a problem. :-)

So problem is the MissionPlanner which doesnt initiate BT connection, it tries to connect to com port but its not working because BT connection is not established.

So if You find a way, (maybe some utility), to force Windows 8 to connect to BT device just like it is possible under windows XP then you will be able to connect to APM via BT
Dec 30, 2014, 06:39 AM
MHefny
MHefny's Avatar
Hi,
This Android Application uses Bluetooth with Multiwii / Mission Planner APM to get a free-range telemetry using 3G/4G network

You can Also use Andruav as a standalone App for FPV and camera Shooting

Andruav - Using Telemetry Feature with Multiwii Board (8 min 6 sec)
Feb 07, 2015, 02:11 AM
Registered User
philgib's Avatar
What are the minimum and cheapest android phones you have tested which we could use for your application please ?
Feb 07, 2015, 06:19 PM
MHefny
MHefny's Avatar
Quote:
Originally Posted by philgib
What are the minimum and cheapest android phones you have tested which we could use for your application please ?
Well it depends on what do you expect from it.

for example full features -without gyro- can work great on Samsung Galaxy S Pro.
also mobile like Prestigio works great.

for telemetry purpose only you need almost any android 2.3 or upper.
It is the FPV section of Andruav that may require better equipments, still depends on your usage.
Jan 24, 2016, 01:42 PM
Registered User
preisedj's Avatar
I've been successfully connecting to my bluetooth module using Tower on my Galaxy 4 phone. When I try to add a second bluetooth module, the device pairs but never connects via Tower. When I use another phone, I can connect just fine. So it seems that once Tower connects to one blue tooth devices, it will not connect to another. Can anyone confirm this and if so, is there a workaround?


Quick Reply
Message:
Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! PX4 + Mission Planner Initial Setup - Can't connect! Bangor Multirotor Drone Electronics 5 Nov 01, 2015 10:27 PM
Discussion APM 2.5 - Mission Planner No Connection gorillatschhh Multirotor Drone Electronics 7 Jan 11, 2014 07:20 PM
Discussion Aerosky H-100 with HK Multiwii Pro Running MegaPirates with GPS and Mission Planner snorkrc Multirotor Drone Talk 9 Aug 19, 2013 10:05 PM
APM 2.5/ Arduflyer Waypoint mission planner test echo75 DK FPV 6 Apr 12, 2013 06:03 PM
Discussion APM PLanner problem nickwad Multirotor Drone Talk 0 Jun 18, 2011 07:46 AM