Thread Tools
Feb 09, 2004, 09:20 AM
Registered User

ECO 16 collective setup


I have a ECO 8 conversion to a 16 with the Mega 30/3.
I am using a JR 8103 transmitter. I am a beginner just off
the training gear hovering tail in only.
The heli seems to be balanced out, but the but is very sensitive to the slightest breeze where it will gain altitude quickly and then
drop down. I am not sure my throttle and pich curves are set properly.
I believe the main rotor blades are around +6 deg. at mid throttle
and the motor is at 85% at mid throttle.
compared to my VE the main rotor appears to be slower than that of the voyager (sound only, I do not have a tach.)
any ideas?
TomR
Sign up now
to remove ads between posts
Feb 09, 2004, 12:13 PM
AMA 46133
>>is very sensitive to the slightest breeze where it will gain altitude quickly and then<<

That is normal since you have a long rotor blade. That translate into a much lighter disc loading.

>>I believe the main rotor blades are around +6 deg. at mid throttle
and the motor is at 85% at mid throttle.<<

That sounds about right.

>>compared to my VE the main rotor appears to be slower than that of the voyager (sound only, I do not have a tach.)
any ideas?<<

The longer the rotor blade the slow it turns before lifting off.

You can soften the hovering sensitivity by going back to an ECO 8 with shorter blades and shorter boom.

Part of learning to fly an RC helicopter is to use the collective to anticipate the wind.
Feb 09, 2004, 12:24 PM
Registered User
SeismicCWave, thanks for the reply, I guess it's all summed up with the age old phrase "practice, practice and more practice"!
Thanks,
Tom R