Thread Tools
Old Jul 25, 2013, 03:44 PM
Toffe87 is offline
Find More Posts by Toffe87
Registered User
Discussion

TBS Disco + DJI Naza V2 - Red Yellow light error


Hello

I have just recovered my tbs after a little fall in the forest, tried to fly it today and after takeoff it started blinking red yellow all the time.

I just let it blink and it flies just like atti mode.

If i land i stops and blinks green again, then i takeoff it hovers nice a few secs then starts blink again.. if i just ignore it it casually blinks green sometimes.

I have tried calibrating it each time it starts. Done the "deep" calibration of the "IMU".

Anyone know what it might be? The difference since i crashed done to the craft is that i've put the FPV TX flat instead on the top plate. And the GPS also flat instead of on the stick. (The stick dosent fit in my new carry case)
Sign up now
to remove ads between posts
Old Jul 25, 2013, 03:58 PM
albx is offline
Find More Posts by albx
Registered User
albx's Avatar
To ne this seems a compass error
Old Jul 25, 2013, 04:03 PM
Toffe87 is offline
Find More Posts by Toffe87
Registered User
I mounted the gps on the pole again.. jackpot.. :-/

Can this be the case??

I had it into the servoconnectors on the back there the RX for remote is.. I thought RX / RX did not interfere with eachother? battery was under it
Old Jul 26, 2013, 09:46 AM
Toffe87 is offline
Find More Posts by Toffe87
Registered User
Ok, now its f**ked. Took 5 minutes to get fix. When i get fix it flew up. Driftet around and around. (not on pole)..

I really dont want that frcking pole.. Is it a must? :-/

Is there any way to test if the gps is dead after that crash?

Old Jul 26, 2013, 09:57 AM
Mike_Then is online now
Find More Posts by Mike_Then
I hate waiting for parts
Mike_Then's Avatar
Have you checked the Naza manual? It explains in detail what the light error codes mean.
RCG Plus Member
Old Jul 26, 2013, 09:58 AM
dybbob is offline
Find More Posts by dybbob
Registered User
im not an expert but if it (the gps) was mounted on the mounting stick then you mounted it flat on the chassis did you also go into the assisstant and change the location parameters for the gps. since you have to put in -10 for the last gps parameter it might need to be 0 ?

just a thought.
Old Jul 26, 2013, 01:01 PM
Fastgixxerlv is offline
Find More Posts by Fastgixxerlv
Registered User
Fastgixxerlv's Avatar
Orange light means your in atti. mode and the red (depending on how many ie 3 blinks) is the satellite signal. No blink is good signal, with blink weak signal.

I have never entered the values of where it installed and it works. I even move it around from time to time with no issues.

Try and keep it away from the frame and VTx antenna.
Old Jul 26, 2013, 01:07 PM
Toffe87 is offline
Find More Posts by Toffe87
Registered User
I know what the light is It was flashing RED and YELLOW when i landed it started blinking green. I calibrated, flew and same thing.

When i mounted it back with the RX above the battery the module got miscalibrated and dident hold position at all.

I moved it to the middle on the left of the TX and its 100% stable now.. :P So if mounting behind keep it atleast 10cm above battery. Works fine. If not keep it away! :P
Old Mar 18, 2014, 12:05 PM
lougedo is offline
Find More Posts by lougedo
Registered User
lougedo's Avatar
Quote:
Originally Posted by Toffe87 View Post
I know what the light is It was flashing RED and YELLOW when i landed it started blinking green. I calibrated, flew and same thing.

When i mounted it back with the RX above the battery the module got miscalibrated and dident hold position at all.

I moved it to the middle on the left of the TX and its 100% stable now.. :P So if mounting behind keep it atleast 10cm above battery. Works fine. If not keep it away! :P
Thank you! i will try that, im having the same issues.. difting sometimes like crazy and not holding the position
Old Mar 18, 2014, 03:15 PM
rcpaintfx is offline
Find More Posts by rcpaintfx
Kev Waite
It is a compass error, it is in the manual. I had this when the GPS puck was too low and gets interference from the magnetic field generated by the motors. Raised the height of the puck above the motors and never had the problem since, over a year ago.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale DJI 450 Quad, 550 Hexa, Phantom, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 May 09, 2013 12:54 PM
For Sale DJI 450 Quad, 550 Hexa, Phantom, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 May 08, 2013 12:43 AM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 25, 2013 02:55 PM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 21, 2013 04:19 PM
For Sale DJI 450 Quadcopter, 550 Hexacopter, TBS Disco Quad, & Turnigy H.A.L. LED light kits! macentyre Aircraft - Electric - Multirotor (FS/W) 0 Apr 21, 2013 03:17 AM