Thread Tools
Old Jul 06, 2013, 09:43 PM
Laden is offline
Find More Posts by Laden
Laden
Discussion

I give up.. Where's the fun?


I have a Quad fitted with an APM 2.5. I have calibrated the ESCs and the Radio. It bench tests ok with no props. Motors spin up and shut down as expected.

I have had two major crashes an in both occasions the fail safe doesn't shut of the motors. The quad is totally out of control and launches itself, flips over and won't shut down.

I have rechecked the fail safe settings and the value in channel three is set to 5 above the level when the Radio is turned off. Something is crazy in the APM and its driving me to a point where it's all too hard. Any help would be appreciated.
Sign up now
to remove ads between posts
Old Jul 06, 2013, 10:35 PM
RCvertt is offline
Find More Posts by RCvertt
Registered User
RCvertt's Avatar
I'm not familiar with the APM.

The motors on a quad usually don't shut down unless you disarm it.

If you think the failsafe is being activated which is causing the crashes then it sounds like a TX range check is needed. Might be a power issue if you are powering the Arduino from an ESC or have any servos getting power from the arduino. Using a separate switching 3 amp 5v BEC has solved my brown out problems. Any servos get the red and black wire connected directly to the BEC output. My arduino also has a separate line from the BEC for power. Basically a Y harness from the BEC to the arduino and the other side to any servos.

If that's not it then disregard while I go kill some more brain cell with TV.
Old Jul 07, 2013, 12:01 AM
Laden is offline
Find More Posts by Laden
Laden
Apart from the Quad flipping I can't disarm the Apm. The thing won't shut down.
Old Jul 07, 2013, 03:18 AM
RCvertt is offline
Find More Posts by RCvertt
Registered User
RCvertt's Avatar
Sounds like the TX end points might not be set wide enough. There is probably a TX stick combo to disarm the quad and the endpoints for those sticks have to be set large enough.

Try setting all of your TX enpoints to their max upper and lower limits of travel. If you don't have a computer radio you might also have to move the TX trim tabs in the same direction as the TX stick combo to give enough throw.

Do all this testing with the props removed from the motors.
Last edited by RCvertt; Jul 07, 2013 at 03:37 PM.
Old Jul 10, 2013, 10:05 PM
PonyBoy1973 is offline
Find More Posts by PonyBoy1973
Registered User
Keep at it man, you'll get it. Put it down for a few days, or maybe pick up a LadyBird or something real simple to keep the flame alive. I know this stuff can be frustrating at times. Just give it a rest and keep asking questions here and at FVP labs and stuff. We are all here to help. I just ordered one of those FC boards, and i know it's a leap ahead of the KK2.0 that I've been using. I have a lot of reading to do.

You can do it!!!
Old Jul 11, 2013, 06:12 PM
Strange1 is offline
Find More Posts by Strange1
Registered User
I've got an APM 2.5+ on a homebrew quad. I am a n00b but maybe I can help?

Give us some more details about the build. What TX/RX? How's it all wired up? Have you calibrated the sensors on the APM yet? Pics maybe?

Start here and work through step-by-step: http://copter.ardupilot.com/quick-st...d-station-apm/

If you ran through all the calibration steps, throttle all the way down should turn off the motors regardless. Hook up via USB and check your inputs via the Mission Planner radio test. There are A LOT of calibration hoops to jump through with the APM. It took me a while to get it configured but it works like a champ once completed.

Don't give up! Its complicated, but its a very well featured controller.
Old Jul 12, 2013, 07:42 AM
DanE80 is offline
Find More Posts by DanE80
Registered User
Quote:
Originally Posted by Laden View Post
I have a Quad fitted with an APM 2.5. I have calibrated the ESCs and the Radio. It bench tests ok with no props. Motors spin up and shut down as expected.

I have had two major crashes an in both occasions the fail safe doesn't shut of the motors. The quad is totally out of control and launches itself, flips over and won't shut down.

I have rechecked the fail safe settings and the value in channel three is set to 5 above the level when the Radio is turned off. Something is crazy in the APM and its driving me to a point where it's all too hard. Any help would be appreciated.
I am using the APM 2.5 and I had some problems disarming too. The problem was my motors were too small for my payload and the ESC's would go into failsafe. At the time, I was using stock DJI 2212 920kv motors for my hexacopter. Once I replaced the motors to 2814 710kv motors, I do not have any problems anymore. Also, I was, and still am using the stock DJI 30A Opto ESCs.

Due to the flips, have you gone through the level and compass calibrations? Also, have you checked the copter vibration levels, mag field and mag x, y, and z offsets? The magnetic interference due to the APM placed too close to the power source, ESC's etc. will create problems. Note: I originally had my APM placed on my DJI F550 power distribution board. Once I relocated the APM to the top of the copter, it helped reduce magnetic interference.

Here are some videos by one of the developers that might help.
https://www.youtube.com/user/rmackay9?feature=watch

Don't give up. We all get frustrated at times.

Hope this helps.
Last edited by DanE80; Jul 12, 2013 at 09:50 AM.
Old Jul 13, 2013, 01:47 AM
Laden is offline
Find More Posts by Laden
Laden
Thanks for the replies. I took your advice and left it alone for a while. I have now stripped and rebuilt the quad. I haven't managed to auto trim yet due to the weather, but it all seems to function as expected....so far.

I note that the APM 2.5 still disarms regularly, particularly if it let still for a short while the LED starts to flash. Not sure if thats normal.

I suspect whats happening is the APM disarms when it under low throttle and at that point the failsafe kicks in a the quad takes off widely in order to "return to launch"

I have a Spektrum 7EU a AR6200, 4 x 2830 -900kv motors and a 2650mA Liipo.The ESCs seem to calibrate OK but I have noticed that the throttle movement from motors off, to motors running is very, very small. Approx 2mm of movement. So when you think you have completely shut off -there's still a chance that the throttle is not full down.
If I could work out why it disarms I think I will be on my way to having some fun
Old Jul 13, 2013, 05:33 AM
WendoNZ is offline
Find More Posts by WendoNZ
Registered User
I believe (and I'm not completely sure of this) that the APM will auto-disarm if left armed but on the ground, ie no input and motors off. This is so you don't forget it's armed and approach it after having had it sit for a while, certainly other FC's do this
Old Jul 13, 2013, 07:30 PM
Laden is offline
Find More Posts by Laden
Laden
Thanks for the input. It sounds logical
Old Jul 14, 2013, 12:29 AM
sgg05158 is offline
Find More Posts by sgg05158
Registered User
I have exactly the same problem in some of my apm2.5 FC.. my copter stays on air even though I have my throttle set to zero..... simple solution my friend... in Mission planner try erasing the contents of your EEPROM.. (command erase).. then reload the firmware.. trust me this will work.
Old Jul 14, 2013, 08:46 AM
v00d0o is offline
Find More Posts by v00d0o
Registered User
v00d0o's Avatar
May sound stupid but make sure the APM is pointing in the right direction? Flipping is usually incorrect board orientation.

Or check that your motors and props are spinning in the right direction.
Old Jul 14, 2013, 03:59 PM
DanE80 is offline
Find More Posts by DanE80
Registered User
Quote:
Originally Posted by WendoNZ View Post
I believe (and I'm not completely sure of this) that the APM will auto-disarm if left armed but on the ground, ie no input and motors off. This is so you don't forget it's armed and approach it after having had it sit for a while, certainly other FC's do this
You are correct. I believe that is what disarmed my copter after the failsafe mode from the ESCs kicked in once I landed.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion I give up. Please help sundog Power Systems 7 May 09, 2013 04:07 AM
Help! MultiWii - About To Give Up sixshooterstang Multirotor Electronics 5 Apr 04, 2013 05:30 PM
Idea CBS: Let's Give Up on the Constitution craab Life, The Universe, and Politics 52 Jan 29, 2013 10:43 AM
Discussion I give up, you guys where right jacobfischer Multirotor Talk 31 Nov 08, 2012 10:59 PM
Rant OK, I give up. Where is this LiPoCalc??? Fitz Walker Batteries and Chargers 8 Nov 29, 2002 02:28 AM