JXD 340 Drift King helicopter donot fly - RC Groups
Thread Tools
Jun 24, 2013, 08:45 AM
Registered User

JXD 340 Drift King helicopter donot fly

Hi, I bought JXD 340 Drift king (4 channel) helicopter last year and periodically I flew it on average of 1.5 -2 months of gap. Last time, almost 2 months back I flew it very well - no crash, the battery was completely discharged then I charge it by using USB and once the charging was complete; I stored it (in the original box it comes in). NOTE: every time I do this I made sure both helicopter and transmitter is turned to “OFF” before charging the helicopter. Now after almost 2 months, I took it out , switch “ON” the helicopter it lights up and the light blinks as usual. Then once the frequency was set with transmitter I moved the lever forward to spin the blade. Once I push the lever forward (upwards), the blades spin for 2-3 seconds and then stops. Then I pull back the lever on transmitter to center and when I push back the lever forward again, it does the same thing! Spins for 2-3 seconds and stops. Never go off the ground.

Now I am not sure what is the problem with it. Helicopter charges well, I drained the battery and then charge it again. But still face the same problem. I also tried changing the all 6 batteries on transmitter and faced the same issue.

Can anyone please help with this? Do I have to change the battery on Helicopter? Also, if I have to, can I use 240mah 3.7v instead of what came originally (200mah 3.7v) will this make difference in performance?
Sign up now
to remove ads between posts
Jun 24, 2013, 03:37 PM
Registered User
Its a piece of garbage don't waste your time get a V911. Really they are junk.
Jun 25, 2013, 06:52 AM
Registered User
Originally Posted by dankar04
Its a piece of garbage don't waste your time get a V911. Really they are junk.
Jun 25, 2013, 01:07 PM
Different fly 4 different guy
gordonzo's Avatar

It sounds like you have damaged your battery. A new one is easy to install.

You will get more useful help over on this forum.

What they don't tell you is that the li-po battery must not be fully discharged. As soon as full throttle is required to lift you must stop, rest and cool the battery for 10 min, then charge it. Wait 10 min again after charging.

The battery must also not be stored fully charged. If you are not going to fly for a while, fly a fully charged battery for about 2 min. before storing. IME that gets it close enough to a safe storage charge.

You will find most people here to be very helpful, but not all. And note that cross-posting is also frowned upon.

regards . . . g
Jun 29, 2013, 11:52 AM
Registered User

Thank you for replying. I tried changing the battery this morning. And it does the same thing again! This trick din't worked for me

As I mentioned in my initial post above it still does the same thing. I wonder if the main motor is gone. Any idea what could went wrong? Anyone can help please.
Jun 29, 2013, 12:28 PM
Cranky old fart
Balr14's Avatar
You need to check the voltage of the battery before and after you attempt to fly. Otherwise, all you can do is guess and then you might just as well toss the thing out, because by the time you replace everything it might be (battery, charger, motor, board) you could have bought a better heli. You really need a voltmeter for this hobby.
Jun 30, 2013, 01:10 AM
Registered User
I checked the voltage it's 3.7v... I guess you are right but just can't let it go as I liked it.
Jun 30, 2013, 01:30 AM
Registered User
Do you think it could be the transmitter fault?
Jun 30, 2013, 02:27 AM
Cranky old fart
Balr14's Avatar
3.7v means it's low. Not enough to fly most aircraft. It needs to be around 4.2v after charging.
Jun 30, 2013, 03:05 AM
Registered User
If your battery has 3.7 v after charging its either battery or charger or both.
Do as you may but really putting effort into a very low grade heli. I have one from last year and battery went south after 25 flights. Never bothered to fix it. It did fly fine for a short time but tx is mode four. Ass backwards from mode two.
Blade makes two nice co-ax helis/ WL toys has them also. If you like helis get a V911 f/p 4ch, single rotor and fly a real heli.
Jun 30, 2013, 04:23 AM
Registered User
@Balr14 - Thank you. But I was talking about the capacity.. that is what came originally.
Jun 30, 2013, 04:36 AM
Registered User

Hmmm... din't knew this was coming. Okay. looks like time to change my Heli.
Thank you!
Jun 30, 2013, 12:17 PM
Cranky old fart
Balr14's Avatar
Dankar is right. There's very little to recommend the Drift King. It's certainly a very poor learning tool.

But, FYI: battery capacity is a nominal value. All lipos are rated at 3.7v per cell. It's actual capacity is 4.2 - 4.3v per cell, when charged. I rarely go below 3.7v per cell when discharged or you risk battery damage.
Jul 01, 2013, 01:29 AM
Registered User
Thank you! I have good news. My Drift king is up again. the problem was not with the battery but was with the motor gear which is connected to blade gear, it was touching the circuit board. That was causing an connection with electric board (sorry if I am not using correct terms here). I did some research and this is how I found my problem fixed.
Jul 01, 2013, 12:31 PM
Registered User
Good for you getting it going. Maybe down the road give V911 a try. One fine low cost heli.

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion JXD 340 RC Drift King 4CH Gyro Mini Helicopter klinger1 Micro Helis 3 Jan 12, 2013 09:33 AM
For Sale JXD-340 Drift King 4 Channel IR Helicopter Jake8131 Aircraft - Electric - Helis (FS/W) 0 Oct 13, 2012 06:39 PM
Discussion JXD 340 Drift King Infrared RC Helicopter 4 Channel RTF wont fly Kesie1289 Mini Helis 2 Oct 02, 2012 05:13 PM
Discussion JXD 340 Drift King 4ch RC Helicopter w/ Gyro LightLake Coaxial Helicopters 0 Jan 03, 2012 10:48 PM