Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Jun 19, 2013, 03:12 PM
azzarin is offline
Find More Posts by azzarin
Registered User
Help!

DJI NAZA v2 connect to PC


Hi guys, im brand new here, hope you can help me.

I have serched hours for this problem, and it does look like people have the simular problem but that my LED light does not glow at all and the PC does not noticed the Naza at all.. no sound nor can i find it in the divice management.

More about the problem i have:

Hi there.

I have an DJI naza V2. I have been able to connect it to the PC before. But now it wont connect any PC.
Before the LED was solide green when i connected it, now its no color at all. the ledlight stops.
Can not either see that its connected to the computer managment. Please help me
Sign up now
to remove ads between posts
Old Jun 19, 2013, 04:24 PM
Empire Support 3 is offline
Find More Posts by Empire Support 3
Empire Hobbies Support
Does the LED work when it is not connected.
Old Jun 20, 2013, 06:53 PM
azzarin is offline
Find More Posts by azzarin
Registered User
Yes it does work fine.
Old Jun 20, 2013, 07:02 PM
Empire Support 3 is offline
Find More Posts by Empire Support 3
Empire Hobbies Support
Do you have access to another computer? Have you tried another usb cable?
Old Jun 20, 2013, 07:03 PM
kallend is offline
Find More Posts by kallend
Flying R/C since 1964
kallend's Avatar
Just to clarify, you installed the drivers on several PCs and your NAZA won't connect to any of them.
RCG Plus Member
Latest blog entry: Using a DX9 to "strobe" LED...
Old Jun 21, 2013, 01:52 AM
azzarin is offline
Find More Posts by azzarin
Registered User
That's correct, before the LED went solide green. Now it just turns off. I ll try on a windows XP pc aswell. I have also tried to disconnect the GPS and the esc's. No luck.
Old Jun 21, 2013, 04:19 AM
azzarin is offline
Find More Posts by azzarin
Registered User
I tried on a windows XP computer too. Nothing happened. The pc does not notice anything is connected. When I install the driver it says there is nothing to update. This happened to all the computers.
Old Jun 21, 2013, 04:36 AM
flitelab is offline
Find More Posts by flitelab
flitelab's Avatar
Do you have the lipo connected when you are doing this, as it is needed to be powered up.
Have you tried another USB cable? I've found some can be troublesome.
Site Sponsor
Old Jun 21, 2013, 04:59 AM
azzarin is offline
Find More Posts by azzarin
Registered User
Yes i do have the lipo Connected. I have tried With 2 different cables + orginal cable. so 3 cables i Guess. It is strang, it worked just fine before. I have not been flying more then 3 mins With it. so no crashes or something like that.
Old Jun 21, 2013, 05:03 AM
flitelab is offline
Find More Posts by flitelab
flitelab's Avatar
Check to make sure the VU unit has not become disconnected or lose from the NAZA X3 port.
Site Sponsor
Old Jun 21, 2013, 05:06 AM
azzarin is offline
Find More Posts by azzarin
Registered User
I ll do so. but would it be able to start motors and so on if it was?
Led Works fine when its not Connected to the PC. But i ll test it, and come back in 10 minutes thanks for the help btw. I means alot
Old Jun 21, 2013, 05:29 AM
azzarin is offline
Find More Posts by azzarin
Registered User
OK! it actually Works now. I did poke the cable to X3 and used another USB cable and the solide green LED light glows stronger then ever!

You are now my god Flitelab even it was the most wired peoblem i ever seen. It was Connected.. but i just poked it! Now i want to fly, but its raining alot here. Im sure you cant make Norway sunny too, but after all thanks for the help!

Well in Bergen you should have an unbrealla ontop of the drone
Old Jun 21, 2013, 05:35 AM
flitelab is offline
Find More Posts by flitelab
flitelab's Avatar
Great, glad you got it working finally. USB can be a bit flakey at times so a loose or weak connection can cause issues. it is a good idea to do regular checks of all your connections anyway, just in case something works its way loose over time, you don't want an in flight failure as a result of it.
Site Sponsor
Old Jun 21, 2013, 05:43 AM
azzarin is offline
Find More Posts by azzarin
Registered User
Indeed it is. i had checked all the cables but that one, and the TX/RX cables. So thank you again. i ll wait for the rain to stop if it ever does.
Old Jun 30, 2013, 07:16 AM
ewgen is offline
Find More Posts by ewgen
Registered User
Hi Guys, I have similar PC connection failure. Usb device has err 43, and in DevMgmt console shows as Unknown usb device(reset port failed). Previously had no any issues with connection. Now led always shows green signal, even with no connection to USB, right after i connect power to PMU. I've also checked x3 cable is fine, and disconnected any extension . Not sure whether it is LED failure that is relatively cheap, or with NAZA it self


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Anybody know how to connect a second led to a DJI NAZA nosmo king Multirotor Talk 23 Oct 26, 2014 04:33 AM
Help! DJI Naza TX connection problem after dropping controller mgs0098 Multirotor Electronics 6 Feb 06, 2013 01:16 PM
Help! DJI F450 NAZA/GPS will not connect to assistant software, any ideas would be great. jasper7821 Multirotor Electronics 2 Oct 24, 2012 06:53 PM
Discussion Help with connecting dji naza.... ripmax Multirotor Talk 4 May 05, 2012 03:12 PM
Discussion DJI NAZA / GAUI 500X- PC won't recognize hardware Jelico Multirotor Talk 1 Feb 03, 2012 06:07 AM