multistar 30a stop working on 4s after simonk *solved* - RC Groups
Thread Tools
Apr 27, 2013, 07:07 PM
Registered User
dcv92111's Avatar

multistar 30a stop working on 4s after simonk *solved*

i just finish a build and been flying ok with a few problems that i am trying to tune out. today i try to use some 4s battery and kept getting red light from multiwii pro2. i remove the esc since it is also the bec, and replace it with a non flash simonk one. fires right up. anyone else have this problem with multistar, it is using kda.hex latest code 9-30.


*****nevermind i solved it, it was one speed controller, they all flew fine preflash but after flash one esc stop working on 4S battery. runs fine if i remove the middle wire. i just been lazy, but i think i take all the advices going around about just cutting the middle wire and running a 5v BEC. so if you using non opto esc with BEC, this could happen!
Last edited by dcv92111; Apr 27, 2013 at 07:49 PM.
Sign up now
to remove ads between posts

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Turnigy Multistars with SimonK - motor stops and beeping StRessik Power Systems 4 Mar 27, 2013 03:40 PM
Discussion Optima 6 stopped working after 2 weeks powered storage rhokita Hitec/Multiplex USA 2 Jan 29, 2013 10:28 PM
Question can a mystery brand 30A simonk handle 4S? helifrek Multirotor Drone Electronics 0 Jan 11, 2013 05:49 PM
Discussion How upgrade firmware (simonk) on Turnigy plush 30a esc slidins15 Multirotor Drone Talk 20 Oct 15, 2012 08:01 AM
Help! The LED on a few on my controllers stops working after I do a firmware update. gonzales Castle Creations 2 Feb 14, 2010 01:30 PM