Safety Code 82 - Page 2 - RC Groups
Thread Tools
May 02, 2013, 08:28 PM
Registered User
Well I got my cable in the mail today. I got everything installed and plugged in... charger is still not working. I did a factory restore under the firmware tab and that didn't help. The software tells me it has supply voltage of 24.63V so I'm assuming the power supply is working.

I guess it is getting sent back...
Last edited by 95bat; May 02, 2013 at 08:42 PM.
Sign up now
to remove ads between posts
May 02, 2013, 08:51 PM
Revolectrix Ambassador
I assume you got the connectors clean? If yes, then time to engage the vendor or FMA for warranty service.
May 03, 2013, 11:57 PM
Registered User
I did clean everything, and saw an interesting problem... The plugs on the charger are about 1/2 inside of the port so I bet the banana plugs aren't making very good contact in there. I am going to modify my plug wires tomorrow and see if I can add another 1/4 or 1/2 inch to the plug. I just don't want to void the warranty somehow. I emailed the company I bought it from and haven't heard back in a few days... Hopefully they won't leave me hanging.
May 04, 2013, 01:22 AM
Revolectrix Ambassador
Might need some of these.

http://www.usastore.revolectrix.com/...a-Plug-Cable_2
May 08, 2013, 09:21 PM
Registered User
Hey Gregor, I keep trying to send you a PM, but my sent box is not showing that I sent the PM. Did you by chance get a PM from me? Or possibly 3 now, since I tried to send it 3 times.
May 08, 2013, 10:24 PM
Revolectrix Ambassador
Got all three PMs. Just replied.
Jan 26, 2017, 07:22 AM
Registered User
I started getting the 82 error code when I tried doing some cycling of parallel-connected blocks of LiPo cells, 130Ah-worth in all, at over 10A. I swapped the cables connecting the cells to the PL8 with considerably heavier ones (1.0mm2 to 2.5mm2) and the issue disappeared immediately. It's now doing 20A without issue (so far - after 4 hours).


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Cellpro 10s strange safety codes. Curare FMA Direct 11 Oct 10, 2015 06:07 PM
Discussion Safety Code #97 Amps were not read on startup SkyRaptor FMA Direct 2 Feb 14, 2013 07:40 AM
Discussion PowerLab8 - Error Safety Code 82 - 'Amps out of Range' martinwinlow FMA Direct 3 Apr 08, 2012 11:48 AM
Discussion AMA safety code rule 4 rewritten: 2010 AMA safety code rule 5 Thomas B AMA (Academy of Model Aeronautics) 18 Jan 20, 2010 03:51 PM
AMA Safety code change ED B Foamies (Kits) 7 Jul 02, 2002 05:44 PM