Safety Code 82 - RC Groups
Thread Tools
Apr 26, 2013, 09:59 PM
Registered User
Discussion

Safety Code 82


Hello,
I recently purchased a PowerLab 8 (v2) and am having trouble with it. I am continually getting safety code 82 and can't find what the code means. I do not have the cable that connects the PL8 to the computer (which apparently I should have ordered). Can anyone tell me what the error code means?

I have the PL8 being powered by at MaxAmps 24V power supply and I'm trying to charge a 6500mAh 2S2P LiPo battery (It is an SMC Racing battery). The first time I used it, about a week ago, I charged a battery using lipo accurate charge, ran the battery in my truck (stopped before the LVC), then discharged it all with no problems. I go to use it today and plug in the same battery and get the error with any charge or discharge I select.

After getting error after error, I plugged in a brand new battery today and it charged somehow. I ran the battery in my truck (stopped before the LVC), then tried to plug it back in the charger and it will neither discharge nor charge the battery, giving safety code 82 again.

Any help would be appreciated!
Sign up now
to remove ads between posts
Apr 26, 2013, 11:18 PM
Revolectrix Ambassador
What firmware version are you running? It's displayed at start up. Can you test with a different power supply?
Apr 26, 2013, 11:34 PM
Registered User
I am running the firmware the came with it, version 3.31.

I don't have another power supply to eliminate that as a possibility for problems. The unit is two separate 12v supplies combined, but I believe their instructions were to not run them independently, they said only use a specific one as a 12v supply.

Edit - I tried with one of the two units plugged in and still get the error.
Last edited by 95bat; Apr 26, 2013 at 11:56 PM.
Apr 27, 2013, 12:10 AM
Revolectrix Ambassador
Can you try it running from an automotive battery (car not running)?
Apr 27, 2013, 12:47 AM
Registered User
I got some clips and hooked it up to my car battery, same error. I also tried another brand new battery (I bought 4) and still got the error.

Thanks for your help so far... I read through as much ad I could find and just can't figure out what's wrong.
Apr 27, 2013, 01:11 AM
Revolectrix Ambassador
One more thing to try. Different main charge cables to the packs.
Apr 27, 2013, 09:05 AM
Registered User
I will have to search for something to use for that. I'm going to the hobby store today, I'll check there. I'm using one of these right now:
http://www.progressiverc.com/paralle...rge-cable.html
I bought it so I could possibly charge more batteries at once, but so far I've just charged one at a time. I tried two different ends and got the same error, but they all lead back to the same main wires so if those are bad it won't help I guess.
Apr 27, 2013, 04:21 PM
Revolectrix Ambassador
Another thought. Are you using the stock EC5 connectors, or did you replace them with something else?
Apr 27, 2013, 05:42 PM
Registered User
Well I bought a charging cable at the hobby store today, no luck. I am still getting the error code.

I'm using the stock EC5 connector plugged into an EC5 -> 4MM banana plug wire than then plugs into my power supply. Looks like this:
http://www.progressiverc.com/ec5-charge-cable.html

It seems like the only constant is the charger... could I possibly have a bad one? Is there a list of what the error codes mean? A list of codes would be pretty helpful...
Apr 27, 2013, 06:08 PM
Revolectrix Ambassador
Safety code 82 means the charger was not able sustain the set current. This is a very rare condition and the only other one I'm aware of was related to a power supply whose voltage fluctuated under load. Many of the safety and error codes are listed in the manual. The less common ones are occasionally discussed in this forum.

When you connected it to your car's battery what connectors were used? 4mm plugs are not suitable for the Powerlab8. Not enough of a reliable connection for high current rates. When I tested them about 25 amps is the maximum you could get through them reliably. I would replace the connector on your charger with an EC5. Even that does not resolve the issue, its an important change to make to our setup. Test with and EC5 on the power supply and if the issue still occurs, you can try re-flashing the firmware when you get the PC cable. Or contact the vendor, or FMA.
Apr 27, 2013, 07:45 PM
Registered User
When I connected to the car battery I used jumper cables attached to the 4MM banana plugs. I tried to charge at a low current (I believe I set it to 3A if I remember correctly). I will get an EC5 plug and solder it on to the power supply next week. It seems having a few extra connectors around would be helpful.

Just out of curiosity, what is the difference between using banana plugs on the input side and the banana plugs on the output of the PowerLab 8? If 25 amps is the most you could get through banana plugs, what were you able to get through the EC5? Interesting how one connection works so differently from another. I would imagine the wire gauge itself becomes a limiting factor at some point.
Apr 27, 2013, 09:14 PM
Revolectrix Ambassador
The FMA 4mm banana plugs are actually longer most providing more contact area. Regular 4mm bananas really don't very well with the Powerlab. If you are using the short standard length be sure to perform IR temp checks during charging to ensure they are not heating up. FMA has received damaged Powerlabs where the user provided the 4mm banana and it melted the output plug.

This is another option for long 4mm connectors.

http://cheapbatterypacks.com/product...-Plug-UG2.aspx

In your case, if you were charging at low current, replacing the connector will mostly be preventative and not likely solve the issue. You can try the factory restore, but may need it to be serviced.
Apr 28, 2013, 12:05 AM
Registered User
Yeah, the way it is behaving even at trying a low charge it seems it needs something. The moment I push enter and it tries to charge I get the error code, it is instant. I push enter to clear it and sometimes the error goes off again 4-5 more times without even trying to charge.

The plugs I am using are pretty long. The cable I bought at the hobby store today is like half as long as the one on the power supply. I'm going to order the PC USB cable tomorrow since it seems I'll be needing that. I will still need to get an EC5 cable on there too. I am decent at soldering, should be able to wire it up. My goal is to eventually charge all 4 batteries at once so everything is ready to go for an afternoon.

Thanks again for all your help... I have learned quite a bit about this charger!
Apr 28, 2013, 09:48 PM
Revolectrix Ambassador
You also might want to clean the contacts on the charger's EC5. I saw this thread today and thought of your issue. Symptoms are a bit different, but both are supply/connection related. Easy enough to test. Deoxit works great.

https://www.rcgroups.com/forums/show....php?t=1881630
Apr 29, 2013, 06:24 PM
Registered User
Awesome, I'll add that to the list. I have EC5 connectors and the USB cable in the mail, I'll have both by Thursday


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Cellpro 10s strange safety codes. Curare FMA Direct 11 Oct 10, 2015 05:07 PM
Discussion Safety Code #97 Amps were not read on startup SkyRaptor FMA Direct 2 Feb 14, 2013 06:40 AM
Discussion PowerLab8 - Error Safety Code 82 - 'Amps out of Range' martinwinlow FMA Direct 3 Apr 08, 2012 10:48 AM
Discussion AMA safety code rule 4 rewritten: 2010 AMA safety code rule 5 Thomas B AMA (Academy of Model Aeronautics) 18 Jan 20, 2010 02:51 PM
AMA Safety code change ED B Foamies (Kits) 7 Jul 02, 2002 04:44 PM