New Products Flash Sale
Thread Tools
Old Apr 26, 2013, 10:57 AM
shaneperch is offline
Find More Posts by shaneperch
Registered User
Discussion

SB-1 Battery


I have been so busy the past year. I didn't do much with my subs the past 9 months. I decided it was time to charge all three. I turned them on two run great you can hear the ballast pump run. My original first one nothing. I turn on the switch and the lights on the control board come on but dimly. I hooked up my charger and the light won't come on. I had it on all night and still no charge. so I open up the sub, hook up an external 12 battery to the supply wires and it works great. I hook the charger directly to the battery terminals and no charge. I would think I have a bad battery. Has this happened to anyone? Where can I get a replacement battery the same exact size? I wonder if Mike's Subworks would have one. If not who? Thanks
Sign up now
to remove ads between posts
Old Apr 26, 2013, 11:49 AM
GSPI is offline
Find More Posts by GSPI
Registered User
Tower has them here:

http://www3.towerhobbies.com/cgi-bin...?&I=LXASZH&P=Z

Replacement parts list here:

http://www3.towerhobbies.com/cgi-bin...I=TTRB5220&P=Z
Old May 03, 2013, 02:38 PM
shaneperch is offline
Find More Posts by shaneperch
Registered User
I am bothered by this. Is it normal to have a battery fail,, when stored so long to where it will not accept a charge? I tried to charge it with several chargers even the stock charger overnight and nothing. The other two SB-1s take a charge and I got them both charged up. I hooked up a 12v alarm battery lead acid and the systems come on and the pump does it's thing. I then tried to charge the battery directly with alligator clips, right on the disconnected battery and won't accept the charge. So I ruled out the board, I hope. SI this possible or am I the only lucky one.
Old May 03, 2013, 02:46 PM
GSPI is offline
Find More Posts by GSPI
Registered User
lead acid batteries in general can lose their ability to charge if not cycled regularly.
Old May 03, 2013, 06:16 PM
shaneperch is offline
Find More Posts by shaneperch
Registered User
right. well I got to order one. at least the sub still works.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cool My SB-1 Arrived Today ! BieneFlyer Submarines 17 May 08, 2013 08:38 PM
Yippee! SB-1 Flawless BieneFlyer Submarines 20 May 05, 2013 01:20 PM
Question Adjusting trim weights on SB-1 ? BieneFlyer Submarines 1 Apr 17, 2013 03:32 AM
Sold Hacker X-70-SB-pro ESC with Buffer Battery JimG_AZ Aircraft - Electric - Power Systems (FS/W) 4 Apr 05, 2013 02:07 PM
Sold Hacker X-70-SB-pro ESC with Buffer Battery JimG_AZ Aircraft - Electric - Power Systems (FS/W) 0 Jan 27, 2013 06:23 PM