Shop our Airplanes Products Drone Products Sales
Thread Tools
Apr 04, 2013, 12:27 PM
Registered User
Discussion

multiwii pro with gps - help loading a sketch


so i got my hand on a multiwii pro inc gps
i got it in quad mode
i did an eeprom clear ino then tried re loading a new sketch but it keeps coming back with
initsensors was not declared in this scope

im a total noob at all this so please be gentle
multiwii.com forums are quite nasty and have been told that if i dont understand code , i shouldnr be playing


any help ?
Sign up now
to remove ads between posts
Apr 04, 2013, 12:35 PM
Registered Lunatic
RTRyder's Avatar
Without knowing exactly what application you're using to do the load all I can do is guess, but it sounds like if you're using Arduino it can't find the correct library for the functions. In Arduino under file, preferences, you need to set the sketchbook location to the directory containing the Multiwii files you're trying to compile and load, if it's set to some other location you can get errors like you're seeing.
Apr 04, 2013, 01:00 PM
Registered User
sorry yes its arduino
im using the open tab to open where the ino file is and doing it that way
Apr 04, 2013, 02:20 PM
who put that tree there
dazza44's Avatar
try multiwii 2.1 see if it loads..

load this first from ardiuno to the board
http://sdrv.ms/TYWOB1

then check the gui for gps working(you will see gps flashing in the gui)
this configs the gps..

next you need upload this..
this is the flight firmware..
http://sdrv.ms/UmytGv

thats it, all codes are ready made just select com port on tools and correct board =
ardiuno mega 2560 or mega adk...
hit upload job done..
Apr 04, 2013, 04:11 PM
Registered User
super !!! after a while i thought right ill download the ino fresh and it worked

but now none of the sensors work lol

dazza am i better of scrapping the progress and using the above info and script?
sorry i got a bit excited
Apr 04, 2013, 04:59 PM
Registered User
"initsensors was not declared in this scope"

The compiler is telling you that the variable "initsensors" is being used outside the function/routine where it was declared.

This and other funky errors can also be caused by missing semicolons and/or incorrect syntax somewhere prior to the error point.

You need to learn Arduino programming to fix this, or find someone who knows.

HTH
Apr 04, 2013, 05:37 PM
Registered User
ive been a bit of an eager fool
used dazzas second script and .... booooom it all works except for gps but i think thats down to the wirring
there is 6 wires
ive wired as per hobbykings pic but 2 wires are left
do they need to go somewhere?
actually excited i have progress
Apr 04, 2013, 06:06 PM
who put that tree there
dazza44's Avatar
did you go as in the post.
load 1st one then do second one as gps will not work otherwise.

wiring like this for mtk gps
https://static.rcgroups.net/forums/a...g?d=1364932836

yes wire both ends not used
Apr 04, 2013, 06:48 PM
Registered User
the anza youre awesome
answers ive been looking for have been found !!!! cheers dazza
the gps pkt is flashing now so i presume thats working ????
should it show my position on the map? and the number of satalites?

so excited even more !!!!!!
Apr 04, 2013, 07:26 PM
Registered User
right an update

ive had this board on a model since febuary and spent many hours trying to sort it
at first i thought i had blown the board when servos kept on smouldering
but
i persisted and im no computer nerd , i struggle to send an email
and
being partially blind doesnt help
but thanks to you guys , espially dazza , im blown away
all the things that should work DO !!!!!!
im blown away and sooo happy !!!!

dazza , how do i lower the start rpm's ?
there a bit high and is nearly ready to take off
so so so happy !!!!
Apr 04, 2013, 07:33 PM
who put that tree there
dazza44's Avatar
look in the config-h file youll find....motor stop, uncomment it- remove the //
your motors wont start now till you apply throttle..
Apr 04, 2013, 07:59 PM
Registered User
ah yes
its a bit lower on start up but not much
Apr 05, 2013, 06:12 PM
Registered User
just going to calibrate all the esc's thwn its ngood to go
Jun 08, 2013, 07:45 AM
Registered User
well i broke my original board and ive just replaced it
i did the eprom cleaar and tried loading my original sketch but nothing is working
it says
readeprom was not declared

any pointers ??


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log NEW: whitespy MWC Pro 2.0 FC +MTEK GPS for MultiWii (now w/UBlox GPS) kinderkram Multirotor Drone Electronics 2500 Dec 26, 2015 11:29 AM
Discussion Aerosky H-100 with HK Multiwii Pro Running MegaPirates with GPS and Mission Planner snorkrc Multirotor Drone Talk 9 Aug 19, 2013 10:05 PM
Discussion need help with multiwii pro 3dx450 Multirotor Drone Electronics 4 Apr 05, 2013 05:14 PM
Discussion Need help with HK multiwii SE v2.0 with v2.1 firmware rahul1991 Multirotor Drone Talk 4 Apr 02, 2013 07:31 AM
For Sale MultiWii PRO with GPS alwaysconfused Aircraft - Electric - Multirotor (FS/W) 5 Jan 29, 2013 02:14 PM