Lumenier RB2205C-12 2400KV SKITZO Ceramic Bearing Motor
Thread Tools
Old Mar 17, 2013, 12:26 AM
lionels is offline
Find More Posts by lionels
Registered User
Discussion

kkmulticopter v5.5 Xcopter v2.9


Hi all, I'm hoping some one can help me get this Xcopter working.
the problem i'm having is when i plug the battery in all i get is a beep 2sec intervals.
I have read a lot of post from calibrating my esc to activating the board (putting the throttle down and to the right) none works.
I have a specktrum 7se TX, using a orange RX and a hobbywing quattro 20AX4 esc. I using a kkmulticopter V5.5 w/ Xcopter v2.9 installed controller. this is my second board i purchased, thinking the first one went bad on me.

i can hook up the throttle directly to my RX and the ESC and get all 4 motors to spin up. I can also program the ESC using the beeps as described in the manual.

what i cannot do is hook everything to normal and and get the motors to spin up. I turned the yaw pot all the way down, set my throttle trims all the way down. yet the blue light never flashes and and it only beeps at 2sec intervals.

I have gone as far as powered up the RX with a second esc to get RX bind first and then applyed power to the kkmulticopter board. With my throttle stick at full throttle to get to ESC programming mode. Nothing but a 2 second interval beep.

i just don't know what else to do other then throwing it in the trash can. maybe one of you supr guru's and suggest somethng else i can try before i trash can it,
I have tried alot of different things, including buying another KK board. It seems like i just can't get the KK board to activate. and yes i have tried to reverse the throttle on my TX.

thank you for reading this post.
Sign up now
to remove ads between posts
Old Mar 17, 2013, 12:42 AM
turbored21 is offline
Find More Posts by turbored21
Registered User
try reversing your rudder channel on the tx i had the same issue to diagnose take off the props and move the throttle stick down and to the LEFT if the board arms "blue light comes on" your rudder channel is backwards

tim
Old Mar 17, 2013, 01:00 AM
lionels is offline
Find More Posts by lionels
Registered User
thankyou for the suggestion. but been there done that. any other ideas? but do have a question, do you pull the throttle left after the 123beeps? i notice i get the beeps before my RX binds and pull it left or right, or full throttle left or right after my RX binds.
Old Mar 17, 2013, 01:04 AM
livinlife is offline
Find More Posts by livinlife
Registered User
The ESC's are beeping because they have power, but no signal from the FC. This is because your most likely not bound to the RX yet. The beeping should stop when the RX binds to the TX. If it doesn't try raising your throttle trim up a bit. As long as the ESC's are beeping you probably are not going to be able to arm the board. Also make sure all your pots are at the middle position.
Old Mar 17, 2013, 01:08 AM
livinlife is offline
Find More Posts by livinlife
Registered User
It would also help if you could post a picture of the board, so I can double check your connections.
Old Mar 17, 2013, 01:12 AM
livinlife is offline
Find More Posts by livinlife
Registered User
If you haven't done the stick centering yet you need too. I suspect that you are not giving a high enough signal on the throttle because the FC deosn't know where your center position is.

Your current stick position can be center by following next steps except throttle.


- Set Pitch gain pot to zero. (CCW)

- Set Transmitter trims to center.
- Power on.
- LED flashes 3 times.(Ready)
- Check a receiver power.
- Wait a few seconds.
- LED flashes 1 time.
- Power off.
- Restore Pitch gain pot.
Old Jun 05, 2013, 09:26 AM
mike300z is offline
Find More Posts by mike300z
Registered User
Bump, not to thread jack, but I cant get my board to bind with my TX. Only beeps. Please anyone?
Old Aug 03, 2013, 03:08 PM
Quattrostagione is offline
Find More Posts by Quattrostagione
Registered User
Any luck yet?

I had similar issues until last night..
Only one motor would spin.
Solve:
The hobbywing quattro has 4 ESC's on one board alright but trouble is they need to be calibrated each separately unless.. You use the calibration hub
So put the three wire lead to channel 3 (throttle) and calibrate / program that one first.
Then move it to channel 1 and put an elastic band to the riht stick and the suspension hook in the middle to make channel 1 send 0 signal
And put all other 3 signal wires one by one to channel 3 and program them alike!

I set batery type to lipo, as default is nimh
Problem i have that i think i got overpowerd motors 2300kv normally 1000 should work great now my quad is unmanageable so probably i need to buy new ones unless one of you bright guys has a better plan..


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion KKmulticopter V5.5 Controller BlackBoard V2.1 Program navihawk Multirotor Talk 3 Oct 04, 2013 02:57 AM
Discussion KKmulticopter V5.5 with AR600 vectorscope Radios 4 Jan 22, 2013 04:27 PM
Discussion KKMulticopter v5.5 Circuit board V2.3 Help Aaagogo Multirotor Talk 1 Jan 21, 2013 11:22 PM
Question KK v5.5 Flight Circuit Control Board v2.9 Guntar Multirotor Talk 0 Jan 07, 2013 09:36 AM
Discussion $22.9 Latest KKmulticopter controller V5.5 Board,V2.3 program coolmans Hot Online Deals 0 Apr 19, 2012 02:20 PM