Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Feb 24, 2013, 10:38 AM
PaulyBarnes is offline
Find More Posts by PaulyBarnes
Registered User
Help!

Hexacopter Build failing at motor test stage.


Hey Guys,

I have been SLOWLY building a Hexacopter for the past year and I ran into my first hiccup that I can't seem to find online. The problem is I connected all the motors and ESCs to the control board (making sure the connections were facing in the correct direction, black to the outside of the board) and the next step was to calibrate the throttle with the transmitter. I plugged in the battery saw one quick flash on the control board and then nothing happened, no beeps. I tried again fearing I just fried it, but one quick flash, no beeps. What am I doing wrong?

This is my setup:
  • HK Multi-Rotor Control Board V3.0 (Flashed with Hexacopter V1.6j xxcontrol by Mike Barton)
  • HobbyKing Red Brick 25A ESC (Discontinued)
  • Turnigy Aerodrive SK3 - 2830-920kv Brushless Outrunner Motor
  • Turnigy 9x RX/TX

I'm not going to pretend to know much about RC, cause I don't, but you got to start somewhere. Now while I wait for your responses I am going to slam my head into a wall for tackling a hexacopter as my first build.

Thanks all,

Pauly
Sign up now
to remove ads between posts
Old Feb 24, 2013, 11:02 AM
chris24g is offline
Find More Posts by chris24g
Registered User
doubt you fried anything. a pic would help.
Old Feb 24, 2013, 02:17 PM
kauaicuda is offline
Find More Posts by kauaicuda
Registered User
kauaicuda's Avatar
I would run one motor/esc from the throttle channel to test operation/programming.

Also, you may need to arm the board by doing a yaw right control or something after you power it up.
Old Feb 24, 2013, 03:46 PM
Steveis is offline
Find More Posts by Steveis
AVR Dude
I'm not familiar with Mike's firmware but one quick flash usually means "I'm alive". And, the normal process to calibrate the ESCs is to set one of the pots to zero. Suggest you Google setting up his firmware.
Old Feb 24, 2013, 06:29 PM
PaulyBarnes is offline
Find More Posts by PaulyBarnes
Registered User
Thanks for the tips. I found out what my issue was and it came down to it being old firmware in the flashing tool. Instead of what is in the repository which was v1.6 I found a v2.9!

Here is the site where I found it.
http://www.kkmulticopter.kr/index.ht...a=xxcontroller

Motors now start up. On to the next step. Thanks to all that replied.
Old Feb 24, 2013, 11:31 PM
PaulyBarnes is offline
Find More Posts by PaulyBarnes
Registered User
Alright, so now the new issue that I am having is that all my motors are rotating in the same direction. If I can't figure it out, I'll be back.

Update: Ok so I figured out how to change directions in the motors with this nice little tutorial.
How to Reverse the Rotation of your RC Motor (4 min 13 sec)

Easy enough.
Last edited by PaulyBarnes; Feb 25, 2013 at 12:21 AM. Reason: Figured it out


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Anyone did the motor redundancy test for Naza Y6 mode? as my result, it failed... Jason_cx Multirotor Talk 33 Jul 25, 2013 08:03 PM
Discussion Tried to DS at a Dam using Euro bottom style and failed? Directions Dynamic Soaring 10 Jan 23, 2013 08:58 PM
Discussion GH3 testing at night with the Cinestar jeffscholl Aerial Photography 2 Jan 21, 2013 02:46 PM
Discussion Autonomous hexacopter / rover build and testing blog batfire Multirotor Talk 0 Aug 21, 2012 03:38 PM