New Products Flash Sale
Thread Tools
Old Feb 17, 2013, 10:16 PM
LowkeyRC is offline
Find More Posts by LowkeyRC
4d FTW
Help!

I cant update!!!


Hello,

I am running PhoenixRC v2.5.u and I want to upgrade to v3 or v4. I cant find a update that will work. If you have a link/file that will work please respond.


Thanks,

LowkeyRC
Sign up now
to remove ads between posts
Old Feb 17, 2013, 10:26 PM
jeffpn is offline
Find More Posts by jeffpn
Registered User
Tech support should be able to help you. give them a call.
Old Feb 18, 2013, 09:46 AM
lx2008 is offline
Find More Posts by lx2008
Registered User
just went thru what is happening to you. i have the v2.5 also. was told that they no longer support the 2.5 anymore for updates. they changed the ip address that it uses in the 4.0 version. i had tried for 3-4 straight days and it did not work.
(btw, the info above comes from phoenix rc.)

i mentioned this in another forum and was told the same.
so i called horizon hobby and they said the same. so they are sending me the latest version at no cost. should be getting it today. but, they said since the only server for the phoenix is in the U.K., i may still have some problems with an update. only because of the server being so busy though.
Old Feb 18, 2013, 10:19 AM
LowkeyRC is offline
Find More Posts by LowkeyRC
4d FTW
Quote:
Originally Posted by lx2008 View Post
just went thru what is happening to you. i have the v2.5 also. was told that they no longer support the 2.5 anymore for updates. they changed the ip address that it uses in the 4.0 version. i had tried for 3-4 straight days and it did not work.
(btw, the info above comes from phoenix rc.)

i mentioned this in another forum and was told the same.
so i called horizon hobby and they said the same. so they are sending me the latest version at no cost. should be getting it today. but, they said since the only server for the phoenix is in the U.K., i may still have some problems with an update. only because of the server being so busy though.
Thanks I will call them later today.

LowkeyRC
Old Dec 24, 2013, 11:26 AM
DAKn2 is offline
Find More Posts by DAKn2
Registered User
DAKn2's Avatar
Just upgraded to Windows 8.1 and also couldn't get my Phoenix version 2.5f to upgrade. Searched and found this post; called Horizon Hobby expecting the complimentary upgrade disk, however, I would have to send them pictures of my previous disk and Phoenix USB adapter and that now they are charging $26 for a replacement disk!

I complained that that was ridiculous; I was using 4.x last week and now that I upgraded my OS (which they show as compatible) I have to pay them - even though they claim FREE upgrades. Guy wouldn't budge as "that is their policy".

Unreal.
Old Dec 25, 2013, 04:34 PM
Helos36 is offline
Find More Posts by Helos36
Registered User

Upgrade any version to 4.0


Here you can download the update to 4.0, then automatic updates will work...this file will update any version to 4.0 If one of the links don't work try the others...should be 821 MB download...I am very surprised Tech support did not tell you where to get the update.

http://www.phoenix-sim-files.com/upd..._40_update.exe

http://www.phoenixsim-files2.com/upd..._40_update.exe

http://www.phoenix-sim-files3.com/up..._40_update.exe

Ken
Old Dec 26, 2013, 08:43 AM
grimbeaver is offline
Find More Posts by grimbeaver
Registered User
Quote:
Originally Posted by Helos36 View Post
I am very surprised Tech support did not tell you where to get the update.
Don't be. I'm surprised the links even still work. There's a thread somewhere that someone got a response claiming it was getting too difficult for them to continue building upgrades from older versions. Others theorize that it's Horizon Hobby's influence.

But really it's not a feasible business model for Runtime Games to continue to give away free upgrades forever. Also I doubt Horizon Hobby is willing to give away upgrades forever. It will not surprise me if v5 is a paid upgrade.
Old Dec 31, 2013, 07:46 PM
carlostomasso is offline
Find More Posts by carlostomasso
Registered User
carlostomasso's Avatar

Works great :)


the second link worked for me

up& running ver. 4.0.q, great stuff!!!

Thank you Ken


Happy new year


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Ls-222 has a chipped gear cant find parts : ( King Ting Coaxial Helicopters 28 Jan 09, 2015 02:40 AM
Discussion You Cant Ban Evil Sweeper Nut Life, The Universe, and Politics 0 Jan 11, 2013 02:34 PM
Discussion Cant use update client or firmware update jaysbay Aerial Photography 6 Nov 07, 2011 11:19 PM
Help! First run - FM-1E - Cant wheelie ?? UPDATE - She can now !!! bbking9 Motorcycles 22 Apr 22, 2007 10:58 PM
Discussion Cant update to version 5.00.6!! cobrapilot Simulators 0 Feb 10, 2006 08:20 PM