Shop our Airplanes Products Drone Products Sales
Thread Tools
Feb 10, 2013, 08:48 PM
Registered User
Discussion

ESC not working


Hi folks,

I think that one of my turnigy esc plush 25A is not working.
The esc is new, i only tested it once and it worked fine, but now i don't get any beeps from the motor it is connected to and i have 0 volts on the bec (in my other esc i have 5V).

I've tested it with other motors and the problem persists (the motors are all ok).
I've also checked all the connections and they seem to be ok (i'm using bullet connectors).

The low voltage cutoff function of this esc is activated for 3.3v or less but i'm using a fully charged 3S battery (~ 12.4 volts).

Any ideas of what is going on?
Sign up now
to remove ads between posts
Feb 10, 2013, 09:29 PM
Space Coast USA
hoppy's Avatar
Disconnect leads to motor and try again without them connected. Same result?
Feb 11, 2013, 02:57 AM
Registered User
If your voltage measurement is correct, either your BEC is not working, or it's connection to the receiver is bad (or your ESC doesn't have a BEC). If that's the case, your receiver is not getting any power, so the ESC can't initialise and make its beeps -- and your servos won't be working either.

If you've got a standard NiMh receiver battery, you could power your receiver using that, and see if the ESC works then. To be sure it's not the throttle channel on the receiver that's faulty, using the receiver battery, plug any servo into the throttle channel and see if it responds to throttle stick movement.
Feb 13, 2013, 04:48 PM
Registered User
I've figured out that the problem was on the gnd connection.
I recheck all the connections again and in the process of doing it sometimes i had a voltage signal sometimes i only had 0 volts.
It turned out to be just a not well soldered bullet connector.
I just had to solder the connector again.

Thanks for your help anyway.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Spektrum dx6i trim not working!!!! wigsw001 Radios 18 Sep 16, 2014 03:25 PM
Discussion FDR pro + Osd pro not working? ekozxx Eagle Tree Systems 10 Mar 07, 2013 08:06 PM
Discussion New Syma S107 for nephew not working properly help please Theo911 Beginner Training Area (Heli-Electric) 29 Jan 10, 2013 09:38 AM
Help! Calibrating ACC not working. FIXED Sandav Multirotor Drone Electronics 3 Jan 05, 2013 08:56 AM
Discussion Roll gimbal not working at all with Naza Glenstr Multirotor Drone Talk 0 Jan 03, 2013 06:47 PM