New Products Flash Sale
Thread Tools
Old Jan 31, 2013, 07:15 PM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Video

ESC Problem. . . .


Hi Demondriver here have a look at the problem i'm having with my 75Amp HET ESC on my 707, any suggestions will be appreciated!
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Sign up now
to remove ads between posts
Old Jan 31, 2013, 10:31 PM
rrg is offline
rrg
Find More Posts by rrg
rrg
Registered User
rrg's Avatar
May be the "Current Limiting" on the esc. Can you get your hands on a program card? Did you run the throttle all the way up then back down just for giggles....
Old Jan 31, 2013, 10:35 PM
foam and tape is online now
Find More Posts by foam and tape
Retardedly intelligent
foam and tape's Avatar
Programming error would be my guess, Were the esc's purchased at different times? It could also be a firmware issue (not upgraded to the latest settings).
Old Feb 01, 2013, 01:22 AM
LuvEvolution7 is offline
Find More Posts by LuvEvolution7
Registered User
LuvEvolution7's Avatar
or you've got a bad FET.
Old Feb 01, 2013, 03:35 AM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by rrg View Post
May be the "Current Limiting" on the esc. Can you get your hands on a program card? Did you run the throttle all the way up then back down just for giggles....
I have the programming sheet that came with it, this a virtually brand new ESC.
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Old Feb 01, 2013, 03:37 AM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by foam and tape View Post
Programming error would be my guess, Were the esc's purchased at different times? It could also be a firmware issue (not upgraded to the latest settings).
Its possible Peter, it works fine on 18 volts but past that is a no go.
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Old Feb 01, 2013, 03:40 AM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by LuvEvolution7 View Post
or you've got a bad FET.
A bad FET board, Its possible Rich but it wouldn't run anything if that where the case.

I'm gonna try and fly her on 2 18volt lipos and hope for the best saturday.

In the mean time I'm gonna listen & run down all these Good suggestions.
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Old Feb 02, 2013, 12:42 AM
mlee8249 is offline
Find More Posts by mlee8249
Fly R/C writer
I know this sounds dumb, stupid, impossible...but I had a problem where the motor I had would only studder. Both motor and ESC were brand, spanking new. I figured the ESC was a bum. Called the guy I purchased it from and he said, please clean off the connectors from the battery and the ESC with alcohol.

Whaaaat?!!! Are you kidding me?

He was right. It's worth a try because you have nothing to lose.

Mike Lee
Old Feb 02, 2013, 12:51 AM
LuvEvolution7 is offline
Find More Posts by LuvEvolution7
Registered User
LuvEvolution7's Avatar
it could also be that your ESC hasn't been set up at the factory to automatically detect 6S and only automatically detect 1S-5S.
Old Feb 02, 2013, 02:39 AM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by mlee8249 View Post
I know this sounds dumb, stupid, impossible...but I had a problem where the motor I had would only studder. Both motor and ESC were brand, spanking new. I figured the ESC was a bum. Called the guy I purchased it from and he said, please clean off the connectors from the battery and the ESC with alcohol.

Whaaaat?!!! Are you kidding me?

He was right. It's worth a try because you have nothing to lose.

Mike Lee
Thanks Mike, Not a bad idea Sir!
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Old Feb 02, 2013, 02:41 AM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by LuvEvolution7 View Post
it could also be that your ESC hasn't been set up at the factory to automatically detect 6S and only automatically detect 1S-5S.
I'm leaning to that explanation the most Rich, if it where truly defective it wouldn't handle any current at all.
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!
Old Feb 02, 2013, 02:42 AM
LuvEvolution7 is offline
Find More Posts by LuvEvolution7
Registered User
LuvEvolution7's Avatar
for sure. is there no information on the site about it? how about some info on one of the forums? there's gotta be a way to program that, without having the card. a series of beeps while using the transmitter is all you really need.
Old Feb 03, 2013, 06:59 AM
scruffy1 is offline
Find More Posts by scruffy1
looking up, down under
scruffy1's Avatar
you have the throttle on the wrong stick

nah, just playing with you - no idea why it does that, sorry
Old Feb 03, 2013, 09:16 AM
rrg is offline
rrg
Find More Posts by rrg
rrg
Registered User
rrg's Avatar
Anything yet?????
Old Feb 03, 2013, 11:53 PM
demondriver is offline
Find More Posts by demondriver
Up-Out-&-Gone
demondriver's Avatar
Quote:
Originally Posted by scruffy1 View Post
you have the throttle on the wrong stick

nah, just playing with you - no idea why it does that, sorry
Yeah I'm still looking, I might have to step up to a 100 AMp esc.
RCG Plus Member
Latest blog entry: RC Slimer from Ghostbusters!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion SimonK esc and pancake motors problem? milo12 Multirotor Talk 9 Apr 27, 2014 05:41 AM
Help! E-flite Pro60 ESC problems kawika1kalina Power Systems 2 Jan 19, 2013 03:04 PM
Help! Motor/ESC problem after soldering?? low beeps and motor wont start calle3 Micro Helis 0 Jan 14, 2013 01:58 PM
Help! ESC Problem with Turnigy 9x Wrice4 Power Systems 2 Jan 10, 2013 09:20 AM
Discussion TX, RX, ESC, BEC, where is my problem? flybyjohn Power Systems 10 Jan 03, 2013 07:09 PM