Thread Tools
Jan 31, 2013, 12:17 AM
Registered User
Discussion

LED steps on 6s??


Dó any of you know if those LED strips Can handle 6s??
Its the Big led strips from altigator
Sign up now
to remove ads between posts
Jan 31, 2013, 04:12 AM
Supersonic Engineering
GordonTarling's Avatar
Most LED strips are rated at 12 Volts, so not advisable to connect directly to 6S. Perhaps you can connect two in series?
Jan 31, 2013, 03:16 PM
Registered User
You are going to need a 12v regulator. You can wire a 7812 very easily between the batteries and the LED strips.
Jan 31, 2013, 03:40 PM
Registered User
Quote:
Originally Posted by GordonTarling View Post
Most LED strips are rated at 12 Volts, so not advisable to connect directly to 6S. Perhaps you can connect two in series?
Yep, this should work.
Jan 31, 2013, 04:49 PM
Registered User
You can also use your balance tap from your battery and get a male end and the connector or just solder the wire to the male tap. Then you can have either 3s or 4s you pick thats what I do on my 6S machines. No regulator needed with this method.

Michael64
Feb 01, 2013, 02:49 AM
Registered User
Quote:
Originally Posted by Michael64 View Post
You can also use your balance tap from your battery and get a male end and the connector or just solder the wire to the male tap. Then you can have either 3s or 4s you pick thats what I do on my 6S machines. No regulator needed with this method.

Michael64
cut them in to 2 and conect in serial.mthat is what I did on my multicopter which run 5 or 6 s. the 7812 will geting crazzynhot ifmused.


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Micro / mini canopy from plastic bottle...step by step bulesz Mini Multirotor Drones 35 Feb 25, 2013 04:51 PM
Question 1115/2.5d on 6s? biskit High Performance 2 Jan 08, 2013 02:27 AM
Discussion percentage power steps to run led setup pshappens Power Systems 2 Jan 29, 2009 07:40 PM
Discussion Step-Up Transformer for LEDs / Small Switches Frankenator Flight Accessories 13 Jun 20, 2008 07:13 PM
Help! Dead LED on Optic 6s maguro Hitec/Multiplex USA 1 Jan 29, 2008 01:20 PM