Tricopter spin - yaw problem - RC Groups
Shop our Airplanes Products Drone Products Sales
Thread Tools
Jan 29, 2013, 02:04 PM
Registered User
Discussion

Tricopter spin - yaw problem


Hi all,
I converted my quadcopter into a tricopter.
I made a working yaw mechanism, I set tricopter mod in the KK2 board, I calibrated all ESC, and I calibrated the sensors. all props were mounted as require.
the tri is spinning very fast on the yaw axis, I don't know what to do...
I'm using an old cheap analog servo that I got when i bought a bixler,
can that make problems? maybe it's too slow? btw i defined it as low (servo parameter under mixer settings)
can you think of something else that maybe i did wrong?

I attached a few pictures.
Sign up now
to remove ads between posts
Jan 29, 2013, 02:10 PM
AVR Dude
Go to the "Mixer Editor" and change the channel (number to the upper right) to 4 where the yaw servo is connected. Then change the "rudder" mix value to -100.
Jan 29, 2013, 04:29 PM
Registered User
it works!!!
the servo was already configured to ch4, but the rudder mix was 100. i changed it to -100 and it fly like a charm!
I think KK should write a note about it in the manual... i would never figure that out alone...

Thanks a lot!!!
Jan 29, 2013, 04:53 PM
Registered User
Glad you got it going. If you need to fine tune the yaw, play with the offset on that same screen. Mine slowly rotated in one direction so I changed the offset from 50 to like 43 and it was right on.
Jan 30, 2013, 01:40 AM
Registered User
thanks,
now i have new screen of options to spend time on, and i'm saying it in a good way, i love tuning this piece of flying screws...
Jan 30, 2013, 02:06 AM
AVR Dude
Quote:
Originally Posted by squid10
I think KK should write a note about it in the manual... i would never figure that out alone...

Thanks a lot!!!
It's on the first post of KK's thread (faq #14)

https://www.rcgroups.com/forums/show...1675613&pp=100
Jan 30, 2013, 02:30 AM
Registered User
yea well i don't understand why it didn't change by itself at the moment i switched layout from quad to tri?
I don't see any reason to keep the Yaw at 100 in a tricopter layout...
Jan 30, 2013, 02:55 AM
Registered User
jimbob69's Avatar
Quote:
Originally Posted by squid10
yea well i don't understand why it didn't change by itself at the moment i switched layout from quad to tri?
I don't see any reason to keep the Yaw at 100 in a tricopter layout...
Different servos require different settings. Some are +100 some are -100 etc.
Jan 30, 2013, 03:10 AM
Registered User
ok now i get it,
thanks
Feb 02, 2013, 10:27 PM
Registered User
Quick question since you have done what im doing, what do you connect the yaw servo to? is it one for the motor outputs?
Feb 03, 2013, 11:39 AM
Registered User
ripmax's Avatar
Quote:
Originally Posted by h710railfan
Quick question since you have done what im doing, what do you connect the yaw servo to? is it one for the motor outputs?
m4 motor output
Feb 03, 2013, 01:04 PM
figuring it out...sort of!
goodhumormarc's Avatar
Quote:
Originally Posted by h710railfan
Quick question since you have done what im doing, what do you connect the yaw servo to? is it one for the motor outputs?
servo goes to M4
Mar 02, 2013, 02:16 PM
Martin Andrews
marty7's Avatar

Thank you


Quote:
Originally Posted by Steveis
Go to the "Mixer Editor" and change the channel (number to the upper right) to 4 where the yaw servo is connected. Then change the "rudder" mix value to -100.
You sorted my spinning Tricopter - Many thanks
Mar 14, 2013, 10:40 AM
Registered User
I am using a Hobbyking V2 board..I am facing the same problem,tricopter didnot lift off,but spins on ground..I have Hobbyking 6 channel radio...Would it be okay if I try out this on my setup? Please help..
Mar 14, 2013, 10:45 AM
Registered User
Yes, follow the servo reversing instructions. Good luck!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade SR 120 spinning problem yamabiker Electric Heli Talk 3 Jan 29, 2013 01:48 AM
Discussion [tricopter] yaw mechanism KK board problem?(video) abriosi Multirotor Drone Talk 2 Nov 14, 2011 04:13 PM
Discussion yaw gyro reverse problem kkblackboard tricopter v2.3 Daemon Multirotor Drone Talk 9 Oct 31, 2011 12:36 AM
Discussion MCX Ongoing "Yaw Spin Problem" faithalone Coaxial Helicopters 15 Apr 20, 2009 01:06 PM
Help! Save me from insanity - Walkera 5#4 / Venom Ocean Rescue - yaw problems - spinning moonjoose Coaxial Helicopters 4 Oct 24, 2007 12:00 PM