Mach 3 (unlicensed) and Foamlinx 2912 - RC Groups
Thread Tools
Jan 24, 2013, 02:34 PM
dare to be dull
bigjohn's Avatar

Mach 3 (unlicensed) and Foamlinx 2912

I have been trying to get Mach 3 to run a Foamlinx 2912 for the past few evenings. I have run into a real snag that I don't have a fix for yet. I'm not an expert and am not very familiar with Mach3 yet.

The Foamlinx machine was bought 2nd hand. To prove it works, I loaded the NT control PC with Foamworks 3, since it is an all-in-one program. That allowed me to check out the parallel conection, the motors, etc. Everything worked once I sorted the bits out. I didn't actually try to cut foam though, just wanted proof that all the parts worked.

To get serious, since I am already a Profili user, I wanted to load Mach 3 and cut cores that way. I loaded Mach 3 and also incorporated the cool custom 4 axis control screen:
I am using the X, Y, A, B axes in the software. The problem I am having is that the vertical axes do not change direction. If I give the up jog, they go up. If I command a down jog, they go up.

In order to troubleshoot, I deactivated the A & B axis and am just concentrating on figuring the problem out on the Y axis. Then I'll make changes to the B axis when I figure it out.

I have changed the Dir Low Active settings around without fixing this problem. I have completely remapped the jog keys a couple times to different keys to make sure there wass nothing wierd there.

Not sure what the problem is. I suspect that the pin that controlls direction, #5 for the Y axis is not active for some reason. I have set up the pin numbers per the foamlinx docs as far as I know. I notice that if you put a nonsense value in the dir pin box for one of the horizontal axes, it will behave the same way each time - one direction only, regardless of which key/arrow is pushed.

I think that would originate either because the software/driver is broken which could be:
- Bad install/corrupt driver or
- Some software setting i don't know about that needs to activate the dir pins or
- The card(s) controlling the vertical axes on the foamlix box is not responding to the dir command.

I think tonite, for troubleshooting, I will swap the dir and step pin numbers between the X and Y rows in the Mach3 Motor Output page, so the x-axis controls the vertical drive and the y-axis controls the horizontal drive on the foamlinx box. That way I will be able to tell if the software/PC side is not issuing the direction command or if the Foamlinx control box is not processing it.

If anyone has seen something similar, please chime in. Spending the evening troubleshooting instead of making stuff, stinks.
Sign up now
to remove ads between posts
Jan 26, 2013, 02:29 PM
Registered User
dpot's Avatar
check port pins are set to 1 on all axis
Jan 26, 2013, 04:01 PM
dare to be dull
bigjohn's Avatar
Here are some screen shots. I've done the steps I planned above and have reduced it down to either there is a problem getting the signal down the parallel cable or there is a problem in the Foamlinx box. The Mach3 seems tobe doing what I ask.

It looks like I will need to borrow a scope from work and verify that the signal is getting to the foamlinx box.

I will also be looking at the SMD-158 motor driver that drives the vertical axes in the foamlinx box. I toook the lid off and traced both vertical motors back to this unit. Surprisingly little info about this unit is avaiable on line. If anyone is familiar with it, please let me know.
Jan 27, 2013, 09:20 AM
dare to be dull
bigjohn's Avatar
If anyone is having difficulty seeing these images, you can right click onthem, and "open in new tab". Then switch to the new tab and click on the image to see full size.

As to my problem, I'm really starting to suspect the SMD-158 driver, since that controlls both vertical axes and they both have this problem.

However, I'm also wondering if the signal on the pins is constant or oscillating at some rate, and if that could be confusing the motor driver. Thoughts?

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Mach 3 users dougmontgomery CAD/CAM 14 Feb 12, 2013 11:47 AM
Discussion mach 3 or usb motion controller rotccapt CAD/CAM 2 Jan 20, 2013 04:26 PM
For Sale CNC CAM System Core2 Duo System (Full Mach 3 License & Windows 8 Pro) Aurora9 Non R/C Items (FS/W) 0 Jan 02, 2013 08:56 AM
HET Typhoon 2912/10 lilpip Power Systems 0 Aug 28, 2005 02:42 PM
I.F.O. mach 3 spy0o7 Parkflyers 5 Jun 16, 2001 01:17 AM