Thread Tools
Old Apr 17, 2013, 04:51 PM
gilandar is offline
Find More Posts by gilandar
Registered User
i think you have to raise the Power and maybe the I, to get rid of the vibes. You can see the vibes on the gimbal?
Quote:
Originally Posted by saabguyspg View Post
I finally sorted out my shaking issue... wow three weeks later...

anyway now I find that if I try and pitch the camera vertically (straight down) then I get the crazy high frequency vibes....

If I redcue my D gain down so that this goes away then the pitch axis is not stable...

Any ideas? Has anyone else had this issue?

Steve
Sign up now
to remove ads between posts
Old Apr 17, 2013, 05:09 PM
copterfan1 is offline
Find More Posts by copterfan1
Registered User
How can I check which version of Firmware is on my board?

I always get the answer "upload failed" while using xloader v1.00.
Anyone an idea?
Last edited by copterfan1; Apr 17, 2013 at 05:49 PM.
Old Apr 17, 2013, 05:49 PM
power is offline
Find More Posts by power
Begin with end in mind...
power's Avatar
Quote:
Originally Posted by copterfan1 View Post
How can I check which version of Firmware is on my board?
Look at the upper left corner of the GUI, it should state which version is loaded. Doesn't matter which GUI you use it will show the FW version...

It will always state "upload failed" this has been mentioned several times....

Mike
Old Apr 17, 2013, 06:09 PM
Psionic001 is offline
Find More Posts by Psionic001
Psionic001's Avatar
I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt





Quote:
Originally Posted by saabguyspg View Post
I finally sorted out my shaking issue... wow three weeks later...

anyway now I find that if I try and pitch the camera vertically (straight down) then I get the crazy high frequency vibes....

If I redcue my D gain down so that this goes away then the pitch axis is not stable...

Any ideas? Has anyone else had this issue?

Steve
RCG Plus Member
Old Apr 17, 2013, 06:38 PM
copterfan1 is offline
Find More Posts by copterfan1
Registered User
Please help!
I have soldered the sensor plate and connected to my now AlexMos Board.
When I connect the board via USB to my Win7 Computer the board flashes green for a while then permanent.
When i start the GUI it Shows BoardVer. 0,0 and nothing happens. When i try to upload a new firmway, xloader says "upload failed". No idea, what to do.
When i shake the sensor board i cannot see any Feedback in the GUI.

Connection Problem or Driver problem for USB?




Quote:
Originally Posted by power View Post
Look at the upper left corner of the GUI, it should state which version is loaded. Doesn't matter which GUI you use it will show the FW version...

It will always state "upload failed" this has been mentioned several times....

Mike
Old Apr 17, 2013, 06:47 PM
Psionic001 is offline
Find More Posts by Psionic001
Psionic001's Avatar
Clearly you have been unsuccessful at uploading the firmware to the board.
There's a few ways to upload firmware, have you tried the other apps?

"To upgrade firmware, download latest firmware (.hex file) and XLoader or AvrdudeR utility. Run utility, select COM port where controller is connected, and specify hex file to upload. Leave all other settings at default (baud is 115200, device is "SimpleBGC"). If device is restarted after upload - it means all done. Run GUI and check if firmware version has changed.

LINUX and MAC users: use avrdude to upload firmware. See command line parameters in XLoader/upload.bat."


Quote:
Originally Posted by copterfan1 View Post
Please help!
I have soldered the sensor plate and connected to my now AlexMos Board.
When I connect the board via USB to my Win7 Computer the board flashes green for a while then permanent.
When i start the GUI it Shows BoardVer. 0,0 and nothing happens. When i try to upload a new firmway, xloader says "upload failed". No idea, what to do.
When i shake the sensor board i cannot see any Feedback in the GUI.

Connection Problem or Driver problem for USB?
RCG Plus Member
Old Apr 17, 2013, 06:57 PM
flitelab is offline
Find More Posts by flitelab
flitelab's Avatar
Quote:
Originally Posted by Psionic001 View Post
I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt

Very nice clean design. Assume you 3D printed it yourself?
Site Sponsor
Old Apr 17, 2013, 07:01 PM
copterfan1 is offline
Find More Posts by copterfan1
Registered User
Now i tried with AVRDudeR. After a second it says flashing done but nothing happens.
Seems i have Problems with this USB Driver.



Quote:
Originally Posted by Psionic001 View Post
Clearly you have been unsuccessful at uploading the firmware to the board.
There's a few ways to upload firmware, have you tried the other apps?

"To upgrade firmware, download latest firmware (.hex file) and XLoader or AvrdudeR utility. Run utility, select COM port where controller is connected, and specify hex file to upload. Leave all other settings at default (baud is 115200, device is "SimpleBGC"). If device is restarted after upload - it means all done. Run GUI and check if firmware version has changed.

LINUX and MAC users: use avrdude to upload firmware. See command line parameters in XLoader/upload.bat."
Old Apr 17, 2013, 07:16 PM
v00d0o is offline
Find More Posts by v00d0o
Registered User
v00d0o's Avatar
Where can I get some cheap vibration dampers? Preferably in the US.
Old Apr 17, 2013, 07:21 PM
copterfan1 is offline
Find More Posts by copterfan1
Registered User
Now i tried an other computer with Windows 8.
Firmware update with xloader started and seemed to work, because of blinking Controller. But it stills blinks very fast (green). I disconnected the board from USB and after reconnecting it still is blinking green very fast - ??
Anyone an idea?


Quote:
Originally Posted by copterfan1 View Post
Now i tried with AVRDudeR. After a second it says flashing done but nothing happens.
Seems i have Problems with this USB Driver.
Old Apr 17, 2013, 08:34 PM
power is offline
Find More Posts by power
Begin with end in mind...
power's Avatar
[QUOTE=Psionic001;24750438]I designed and printed a compact gimbal, the "Minim Gimbal" for GP3.
It works beautifully, but when I point it down vertically it also goes nuts.
I think it's a limitation in the firmware.
Admittedly I haven't tried increasing the tilt range in the software, so maybe it's an end stop issue.

Cheers
Matt

I have my limits set at 90 deg each way on both pitch and roll. I have had no issues with the gimbal twitching at all when I go to vertical.

Mike
Old Apr 17, 2013, 08:40 PM
power is offline
Find More Posts by power
Begin with end in mind...
power's Avatar
Quote:
Originally Posted by copterfan1 View Post
Now i tried an other computer with Windows 8.
Firmware update with xloader started and seemed to work, because of blinking Controller. But it stills blinks very fast (green). I disconnected the board from USB and after reconnecting it still is blinking green very fast - ??
Anyone an idea?
Read this post....

https://www.rcgroups.com/forums/show...postcount=1621

You have to install the drivers, I messed around for some time like you and then installed/reinstalled the drivers from the link in this post and everything was smooth from there...

Mike
Old Apr 17, 2013, 09:15 PM
saabguyspg is offline
Find More Posts by saabguyspg
saabguyspg's Avatar
Thanks to everyone for the response.

I am seeing this vibration when not in flight. Ie on the bench.

I assume my gimbal may not be 100% in line so I am ensuring it is all perfect now.

I have read that askman has the same issues.

When I point the camera straight down on the bench I hear a real "moaning" noise that goes louder and louder.

If I reduce my d down to 3 then it goes away and works perfet however that is too low for proper tilt stabilization in flight

I will post a video as soon as I get the gimbal back together.

Steve
Site Sponsor
Old Apr 17, 2013, 10:23 PM
Levinemax is offline
Find More Posts by Levinemax
Registered User
Finely got everything ready to fly
Brushless Gimbal (AlexMos Gimbal) (2 min 33 sec)
Old Apr 17, 2013, 11:04 PM
JussiH is offline
Find More Posts by JussiH
Friend is a 4 letter word...
JussiH's Avatar
Controllers will be available from thursday 14:00 CET at Viacopter and Flyduino.

We have revised the IMU a bit to include a JST XH connector and matching cable.



Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Mini-HowTo Super Simple Gimbal - SSG - KK2.1 & OpenPilot support crezzee Aerial Photography 1672 Jul 01, 2016 06:42 AM
Yippee! Simple Brushless Gimbal Controller--FPV MODEL fpvmodels Multirotor Talk 3396 Dec 26, 2014 07:23 PM
Discussion A very simple camera-gimbal for Gaui 330xs babanan Multirotor Talk 2 Oct 09, 2013 09:46 AM