New Products Flash Sale
Thread Tools
Old Dec 22, 2003, 10:53 PM
rcwyant is offline
Find More Posts by rcwyant
MICRO Power KING!
rcwyant's Avatar

HPI Nitro RS4 3 KIT SS engine issues


I some how have pulled the pull cord too far, and not it will not retract back into the housing!

Any tips on how to fix it? Also, and good tips on breaking a new engine in would be great..i am having a hard time getting it started.

Thank you
Sign up now
to remove ads between posts
Old Dec 23, 2003, 01:46 AM
Bruzer is offline
Find More Posts by Bruzer
Registered User
well you are gonna have to take the pull start housing off the back of the engine and get loose what is stuck. As far as starting goes try to prime the engine and then pull the starter a couple of times befoe attaching the glow driver. Hope this helps you out.
Old Dec 23, 2003, 10:42 AM
rcwyant is offline
Find More Posts by rcwyant
MICRO Power KING!
rcwyant's Avatar
Great...thank you. I will look at the pull system....I am thinking about using a bump starter box instead...so we will see.
Old Dec 24, 2003, 03:24 PM
miller_87 is offline
Find More Posts by miller_87
Registered User
bump start is definately the way to go. Also, when breaking in the engine, if this is your first time, definately take your time, because a well broken in engine will last you much longer and run much better. If there is really tight compression in the engine when you are first breaking it in, try to take a heat gun or a hair dryer on the outside of the engine to heat it up, ive found that to help getting it started for the first time. Second, when breaking it in, dont be affraid to run too rich. When i broke in my o.s. engine, i kept the glow starter on the whole time so it wouldnt choke out because it was so rich, and just let it idle on a box so the wheels didnt touch the ground. I did that the first few times breaking it in, and then i set it against a wall, and let it idle with the wheels on the ground for two tanks. Then the fifth time, i let it just idle around on a flat surface, not giving it any gas at all. about the sixth tank, i reved it very little on a box, then set it on the ground, and let it idle around on a flat surface just reving it just a little bit, maybe quarter throttle, and just a quick rev. Around the 7th or 8th run is when i actually started to lean it out to my actual settings, but still running it pretty rich. once i had it set, then i actually started to give it gas, and by the tenth run i gave it full throttle. Better to take your time and do it right, rather than be in a hurry, and screw up your engine.
Old Dec 30, 2003, 03:03 AM
Heelix is offline
Find More Posts by Heelix
Registered User
If you want to see a nice HPI car IM me and il send you pics!!
My AIM is QVX


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Nitro RS4 3 18 SS RTR MiNiFlIgHt Cars - Cars and Parts (FS/W) 1 Apr 26, 2006 12:11 AM
HPI Nitro RS4 3 Evo newbie tuning. BIGPhutte Nitro and Glow Power Cars 2 Sep 18, 2004 12:03 AM