Shop our Airplanes Products Drone Products Sales
Thread Tools
Old Jan 12, 2013, 10:28 AM
Marcos Sallua is offline
Find More Posts by Marcos Sallua
Registered User
Question

Air Field Programming Card and Quick Connect


The green light is blinking but don't have red light's

The red LEDs come on only after pressing the button to select a setting first???

Any help please
Sign up now
to remove ads between posts
Old Jan 16, 2013, 03:34 AM
Clintstone is offline
Find More Posts by Clintstone
Castle Support
Clintstone's Avatar
Quote:
Originally Posted by Marcos Sallua View Post
The green light is blinking but don't have red light's

The red LEDs come on only after pressing the button to select a setting first???

Any help please
Need more information...

What ESC are you using?

What firmware are you using?

How are you powering the RX?
Old Jan 16, 2013, 08:57 AM
Marcos Sallua is offline
Find More Posts by Marcos Sallua
Registered User
Quote:
Originally Posted by Clintstone View Post
Need more information...

What ESC are you using?

What firmware are you using?

How are you powering the RX?
I make two test , one in a CC 120HV and other CC 160HV both with v3.27 firmware

No power in the RX

Thanks in advance
Old Jan 17, 2013, 06:13 AM
Clintstone is offline
Find More Posts by Clintstone
Castle Support
Clintstone's Avatar
Quote:
Originally Posted by Marcos Sallua View Post
I make two test , one in a CC 120HV and other CC 160HV both with v3.27 firmware

No power in the RX

Thanks in advance
What are you using for RX POWER as the Castle HV does not have a BEC?

Also you can remove the quick link to eliminate it as a problem while testing....
Old Jan 17, 2013, 09:12 AM
Marcos Sallua is offline
Find More Posts by Marcos Sallua
Registered User
Quote:
Originally Posted by Clintstone View Post
What are you using for RX POWER as the Castle HV does not have a BEC?

Also you can remove the quick link to eliminate it as a problem while testing....
I have a 2S Lipo, all the electronics is HV, Futaba S-Bus HV RX, Outrage Torq 9080 y 9188, BeastX.

I make some test without quick link and report later

Thanks!
Old Jan 17, 2013, 12:00 PM
Marcos Sallua is offline
Find More Posts by Marcos Sallua
Registered User
Thank you Clint, solved!

I was connecting incorrectly, was using it as a castle link, I made ​​a connection on Y and now is working OK.

thank you!


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Found Castle Creations Field Link Portable Program Card r0beert0 Aircraft - Electric - Power Systems (FS/W) 1 Oct 10, 2012 03:20 PM
Sold Castlecreations ice 120hv v2 10 flights field programming card included! whippo Aircraft - Electric - Power Systems (FS/W) 1 Oct 01, 2012 08:37 PM
Sold Castlecreations ice 120hv v2 10 flights field programming card included! whippo Aircraft - Electric - Airplanes (FS/W) 0 Sep 30, 2012 09:36 PM
Sold Castlecreations ice 120hv v2 10 flights field programming card included! whippo Aircraft - Electric - Jets (FS/W) 0 Sep 30, 2012 09:35 PM
Sold Castlecreations ice 120hv v2 10 flights field programming card included! whippo Aircraft - Electric - Helis (FS/W) 0 Sep 30, 2012 09:34 PM